SLES HA STONITH timeout problem with IPMI

Hello,

I'm facing problem with STONITH timeout configuration through IPMI. Even if i set paramaters stonith-timeout=60s, failure-timeout=60s on resource still STONITH reboot my node ignoring timeout. If I loose network connection to node for 1 sec always reboot of the node is done.
How configure cluster to manage 1-5 sec network unavailable state?.

Best regards,
Marcin Przerwa

Comments

  • Automatic ReplyAutomatic Reply No Reply Posting Bot
    marcinqo,

    It appears that in the past few days you have not received a response to your
    posting. That concerns us, and has triggered this automated reply.

    These forums are peer-to-peer, best effort, volunteer run and that if your issue
    is urgent or not getting a response, you might try one of the following options:

    - Visit http://www.suse.com/support and search the knowledgebase and/or check all
    the other support options available.
    - Open a service request: https://www.suse.com/support
    - You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.suse.com)

    Be sure to read the forum FAQ about what to expect in the way of responses:
    http://forums.suse.com/faq.php

    If this is a reply to a duplicate posting or otherwise posted in error, please
    ignore and accept our apologies and rest assured we will issue a stern reprimand
    to our posting bot..

    Good luck!

    Your SUSE Forums Team
    http://forums.suse.com
  • strahil-nikolov-dxcstrahil-nikolov-dxc Established Member
    marcinqo wrote: »
    Hello,

    I'm facing problem with STONITH timeout configuration through IPMI. Even if i set paramaters stonith-timeout=60s, failure-timeout=60s on resource still STONITH reboot my node ignoring timeout. If I loose network connection to node for 1 sec always reboot of the node is done.
    How configure cluster to manage 1-5 sec network unavailable state?.

    Best regards,
    Marcin Przerwa
    Stonith timeout is just to delay the stonith , but you will never prevent STONITH this way.

    You can adjust the "token" & "consensus" timeouts.

    For details check : man 5 corosync.conf
Sign In or Register to comment.