SLED15, WE, sssd doesn't start

This issue is open for serval month in service as well.
Enviroment: Windows AD network
SLES: sssd start fine and work fine
SLED: sssd doesn't start.
I had reinstalled the laptop several times- same result.
Now I installed a new version on a USB stik - same result.
it seem when installing workstation extension is the problem. When installing we, it changes the kernel as well.

I appreciate if my sssd get started again since it makes work in LAN easier.

Comments

  • LawrenceLawrence Established Member
    hcp_dk,
    Could you start with posting the results of:

    ~# zypper search sssd

    and the contents of your sssd.conf file?


    -- lawrence
  • Hi Lawrence. In meantime I have installed SLED 15.1 and now SLE 15.2 with similar result.
    There are still issues to see the network. I can work around via IP adresses.

    > S  | Name                | Summary                                                    | Type
    
    ---+---------------------+------------------------------------------------------------+--------
    i  | python3-sssd-config | Python API for configuring sssd                            | package
    i+ | sssd                | System Security Services Daemon                            | package
       | sssd-32bit          | System Security Services Daemon                            | package
    i+ | sssd-ad             | The ActiveDirectory backend plugin for sssd                | package
       | sssd-dbus           | The D-Bus responder of sssd                                | package
       | sssd-ipa            | FreeIPA backend plugin for sssd                            | package
       | sssd-krb5           | The Kerberos authentication backend plugin for sssd        | package
    i  | sssd-krb5-common    | SSSD helpers needed for Kerberos and GSSAPI authentication | package
    i  | sssd-ldap           | The LDAP backend plugin for sssd                           | package
       | sssd-proxy          | The proxy backend plugin for sssd                          | package
    i+ | sssd-tools          | Commandline tools for sssd                                 | package
       | sssd-wbclient       | SSSD's implementation of the Winbind pipe protocol         | package
       | sssd-wbclient-devel | Development files for SSSD winbind                         | package
       | sssd-winbind-idmap  | Idmap backend for Winbind                                  | package
    

    This is the output of ~# zypper search sssd

    `Following packages were found in following modules:

    Package Module or Repository SUSEConnect Activation Command


    python3-sssd-config Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    python3-sssd-config-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-32bit Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-32bit-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-ad Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-ad-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-dbus Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-dbus-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-debugsource Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-ipa Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-ipa-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-krb5 Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-krb5-common Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-krb5-common-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-krb5-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-ldap Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-ldap-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-proxy Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-proxy-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-tools Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-tools-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-wbclient-debuginfo Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64
    sssd-winbind-idmap Basesystem Module (sle-module-basesystem/15.2/x86_64) SUSEConnect --product sle-module-basesystem/15.2/x86_64

    To activate the respective module or product, use SUSEConnect --product.

    Use SUSEConnect --help for more details.`

    But I get these failures continuously:

    > SLED15:/home/hans-christoph # journalctl -f -b
    

    -- Logs begin at Sat 2020-09-12 08:17:23 CEST. --
    Sep 13 18:00:22 SLED15 nmbd[929]: This response was from IP 10.0.25.118, reporting an IP address of 10.0.25.118.
    Sep 13 18:00:25 SLED15 [sssd[ldap_child[3576]: Failed to initialize credentials using keytab [MEMORY:/etc/krb5.keytab]: Client 'host/sled15.hcpi.hq@HCPI.HQ' not found in Kerberos database. Unable to create GSSAPI-encrypted LDAP connection.
    Sep 13 18:00:25 SLED15 [sssd[ldap_child[3579]: Failed to initialize credentials using keytab [MEMORY:/etc/krb5.keytab]: Client 'host/sled15.hcpi.hq@HCPI.HQ' not found in Kerberos database. Unable to create GSSAPI-encrypted LDAP connection

    .....

    Sep 13 18:01:53 SLED15 [sssd[ldap_child[3844]: Failed to initialize credentials using keytab [MEMORY:/etc/krb5.keytab]: Client 'host/sled15.hcpi.hq@HCPI.HQ' not found in Kerberos database. Unable to create GSSAPI-encrypted LDAP connection.

    Sep 13 18:01:53 SLED15 [sssd[ldap_child[3845]: Failed to initialize credentials using keytab [MEMORY:/etc/krb5.keytab]: Client 'host/sled15.hcpi.hq@HCPI.HQ' not found in Kerberos database. Unable to create GSSAPI-encrypted LDAP connection

    This get repeated continuously
    In different to past, service manager show sssd running. .

Sign In or Register to comment.