Problem after group resources in Pacemaker Cluster

Operating System: Suse Linux for SAP Applications 12 SP4

Number of Cluster Nodes: 2


We have two resources pri_apache2_1 & ip_apache2_1_132, these two resources are running fine. But When I group them to one with Pacemaker and trying to start them, then I am getting following errors

pri_apache2_2_start_0 on slesdbpcs02 'unknown error' (1): call=180, status=Timed Out, exitreason='',
last-rc-change='Sat Apr 11 03:25:38 2020', queued=0ms, exec=40004ms
* pri_apache2_2_start_0 on slesdbpcs01 'unknown error' (1): call=202, status=Timed Out, exitreason='',
last-rc-change='Sat Apr 11 03:24:58 2020', queued=0ms, exec=40006ms

Logs show:

2020-04-11T03:25:15.159297+05:30 slesdbpcs01 apache(pri_apache2_2)[110725]: INFO: waiting for apache /etc/apache2/httpd_2.conf to come up
2020-04-11T03:25:16.195409+05:30 slesdbpcs01 apache(pri_apache2_2)[110725]: INFO: waiting for apache /etc/apache2/httpd_2.conf to come up
2020-04-11T03:25:17.270873+05:30 slesdbpcs01 apache(pri_apache2_2)[110725]: INFO: waiting for apache /etc/apache2/httpd_2.conf to come up
2020-04-11T03:25:18.317998+05:30 slesdbpcs01 apache(pri_apache2_2)[110725]: INFO: waiting for apache /etc/apache2/httpd_2.conf to come up
2020-04-11T03:25:19.359485+05:30 slesdbpcs01 apache(pri_apache2_2)[110725]: INFO: waiting for apache /etc/apache2/httpd_2.conf to come up
2020-04-11T03:25:20.406012+05:30 slesdbpcs01 apache(pri_apache2_2)[110725]: INFO: waiting for apache /etc/apache2/httpd_2.conf to come up
2020-04-11T03:25:21.444691+05:30 slesdbpcs01 apache(pri_apache2_2)[110725]: INFO: waiting for apache /etc/apache2/httpd_2.conf to come up

Configuration:

slesdbpcs01:/etc/apache2 # crm configure show pri_apache2_1
primitive pri_apache2_1 apache \
op start timeout=120 interval=0 \
op stop timeout=160 interval=0 \
op monitor interval=10 timeout=20 \
params configfile="/etc/apache2/httpd_1.conf" \
meta target-role=Started
slesdbpcs01:/etc/apache2 # crm configure show ip_apache2_1_132
primitive ip_apache2_1_132 IPaddr2 \
params ip=192.168.1.132 cidr_netmask=24 nic=eth0 \
op monitor interval=0
slesdbpcs01:/etc/apache2 #
slesdbpcs01:/etc/apache2 #
slesdbpcs01:/etc/apache2 # crm resource locate pri_apache2_1 ip_apache2_1_132
resource pri_apache2_1 is running on: slesdbpcs01
resource ip_apache2_1_132 is running on: slesdbpcs01
slesdbpcs01:/etc/apache2 #

Comments

  • johngoutbeckjohngoutbeck Established Member
    Hello;

    Its complaining about 'pri_apache2_2'.

    Do you have a resource called 'pri_apache2_2'? Does it have a separate httpd_2.conf for this resource?

    The resources for apache should have different httpxx.conf files

    Hope this helps
  • strahil-nikolov-dxcstrahil-nikolov-dxc Established Member
    It seems the logs are showing pacemaker having a problem to find the config ( /etc/apache2/httpd_2.conf) for pri_apache_2_2.
    Do you have any ordering or colocation rules involving pri_apache_2_2 resource ?
  • RameshRamesh New or Quiet Member

    Now this is resolved. Even I don't remember how did i fix this as this happened 2 week back and also forgot to take notes immediately. Till now i have taken notes on the stuff i remember. Find the attachment for the same. I remember problem is with PID.


Sign In or Register to comment.