Using the `HOST` environment variable to specify the IP is deprecated...

Hi everybody.
When I work with Rails, I get this error...

rails s
DEPRECATION WARNING: Using the `HOST` environment variable to specify the IP is deprecated and will be removed in Rails 6.1. Please use `BINDING` environment variable instead. (called from <top (required)> at /home/alex/.disk_a/Rails/GitHub/test_oblako_Github/bin/rails:9)
=> Booting Puma
=> Rails 6.0.2.2 application starting in development 
=> Run `rails server --help` for more startup options
Puma starting in single mode...
* Version 4.3.3 (ruby 2.6.4-p104), codename: Mysterious Traveller
* Min threads: 5, max threads: 5
* Environment: development
* Listening on tcp://127.0.0.1:3000

Please tell me how to solve this?

cat /etc/os-release
NAME="openSUSE Leap"
VERSION="15.1"
ID="opensuse-leap"
ID_LIKE="suse opensuse"
VERSION_ID="15.1"
PRETTY_NAME="openSUSE Leap 15.1"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:15.1"

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi and welcome to the SUSE Forum :)
    Unfortunately this is for the Enterprise release, you need to head over to https://forums.opensuse.org (same username/password).

  • excuse me...
    :(

  • malcolmlewismalcolmlewis Knowledge Partner
    edited May 18

    Hi
    It's not a problem, just you will get better replies to your question over there since it's for openSUSE releases (eg openSUSE Leap 15.1) which is what you are running not SLED or SLES ;)

  • I do not think so.
    'HTTP ERROR 500' after entering login / password.
    Unfortunately.
    I'll be back later when they fix it .... alas, there is no time.

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    There was an issue with SSL this morning, can you try again?

Sign In or Register to comment.