Repository 'OpenStack (Devel) (SLE_15_SP1)' is invalid.

Hello *
recently I'm getting the message that one of the repositories is invalid.
It is giving me a 404 if I try to access it in a browser, but SLE_15_SP2 is accessible http://download.opensuse.org/repositories/Cloud:/OpenStack:/Master/SLE_15_SP2/

Can I just change it to the SLE_15_SP2, or is this a bad idea?

Git, python and some libraries were installed from that repository.

In the end, I want to update the machine and upgrade it to SP2 anyway.

g-icinga19:~ # sudo zypper refresh
Repository 'SLE-Module-Basesystem15-SP1-Pool' is up to date.
Repository 'SLE-Module-Basesystem15-SP1-Updates' is up to date.
Retrieving repository 'OpenStack (Devel) (SLE_15_SP1)' metadata .........................................................................................................................[error]
Repository 'OpenStack (Devel) (SLE_15_SP1)' is invalid.
[Cloud_OpenStack_Master|http://download.opensuse.org/repositories/Cloud:/OpenStack:/Master/SLE_15_SP1/] Valid metadata not found at specified URL
History:    
 - [Cloud_OpenStack_Master|http://download.opensuse.org/repositories/Cloud:/OpenStack:/Master/SLE_15_SP1/] Repository type can't be determined.

Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'OpenStack (Devel) (SLE_15_SP1)' because of the above error.
Repository 'SLE-Module-Desktop-Applications15-SP1-Pool' is up to date.
Repository 'SLE-Module-Desktop-Applications15-SP1-Updates' is up to date.
Repository 'SLE-Module-DevTools15-SP1-Pool' is up to date.
Repository 'SLE-Module-DevTools15-SP1-Updates' is up to date.
Repository 'SLE-Module-Legacy15-SP1-Pool' is up to date.
Repository 'SLE-Module-Legacy15-SP1-Updates' is up to date.
Repository 'SLE-Product-SLES15-SP1-Pool' is up to date.
Repository 'SLE-Product-SLES15-SP1-Updates' is up to date.
Repository 'SLE-Module-Packagehub-Subpackages15-SP1-Pool' is up to date.
Repository 'SLE-Module-Packagehub-Subpackages15-SP1-Updates' is up to date.
Repository 'SUSE-PackageHub-15-SP1-Backports-Pool' is up to date.
Repository 'SUSE-PackageHub-15-SP1-Pool' is up to date.
Repository 'SLE-Module-Server-Applications15-SP1-Pool' is up to date.
Repository 'SLE-Module-Server-Applications15-SP1-Updates' is up to date.
Repository 'SLE-Module-Web-Scripting15-SP1-Pool' is up to date.
Repository 'SLE-Module-Web-Scripting15-SP1-Updates' is up to date.
Repository 'various programming languages (SLE_15_SP1)' is up to date.
Repository 'perl modules (SLE_15_SP1)' is up to date.
Repository 'ICINGA (stable release for SUSE 15.1)' is up to date.
Repository 'Server Monitoring Software (SLE_15_SP1)' is up to date.
Repository 'Veeam Backup for GNU/Linux - x86_64' is up to date.
Some of the repositories have not been refreshed because of an error.
g-icinga19:~ #

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Yes it looks like you need to upgrade and add the new repository....

Sign In or Register to comment.