Problem: nothing provides libclang6 needed by clang6-6.0.1-43.25.sles12.x86_64 when installing PG

Hello!
I want to install PostgreSQL 11 (through Ansible), but I get an error when doing this:
Problem: nothing provides libclang6 needed by clang6-6.0.1-43.25.sles12.x86_64
Solution 1: do not install postgresql11-devel-11.9-1PGDG.sles12.x86_64
Solution 2: break clang6-6.0.1-43.25.sles12.x86_64 by ignoring some of its dependencies

My OS:
$ cat /etc/os-release
NAME="SLES"
VERSION="12-SP5"
VERSION_ID="12.5"
PRETTY_NAME="SUSE Linux Enterprise Server 12 SP5"

My ansible-playbook:

  • name: install the repository ZYPPER for PostgreSQL
    zypper_repository:
    repo: 'https://download.postgresql.org/pub/repos/zypp/repo/pgdg-sles-11.repo'

  • name: install PostgreSQL 11 on SUSE
    zypper:
    name: [ 'postgresql11-server', 'postgresql11-contrib', 'postgresql11-devel',
    'postgresql11-pltcl', 'postgresql11-libs', 'python2-psycopg2' ]
    state: present
    disable_gpg_check: yes
    update_cache: yes

My repos:
$ zypper repos
Repository priorities are without effect. All enabled repositories share the same priority.

№ | Alias | Name | Enabled | GPG Check | Refresh
---+----------------------------------------------------------------------------------------------+---------------------------------------------------------+---------+-----------+--------
1 | SLES12-SP5-12.5-0 | SLES12-SP5-12.5-0 | Yes | (r ) Yes | No
2 | SUSE_Linux_Enterprise_Server_12_SP5_x86_64:SLES12-SP5-Debuginfo-Pool | SLES12-SP5-Debuginfo-Pool | Yes | (r ) Yes | No
3 | SUSE_Linux_Enterprise_Server_12_SP5_x86_64:SLES12-SP5-Debuginfo-Updates | SLES12-SP5-Debuginfo-Updates | Yes | (r ) Yes | Yes
4 | SUSE_Linux_Enterprise_Server_12_SP5_x86_64:SLES12-SP5-Pool | SLES12-SP5-Pool | Yes | (r ) Yes | No
5 | SUSE_Linux_Enterprise_Server_12_SP5_x86_64:SLES12-SP5-Source-Pool | SLES12-SP5-Source-Pool | Yes | (r ) Yes | No
6 | SUSE_Linux_Enterprise_Server_12_SP5_x86_64:SLES12-SP5-Updates | SLES12-SP5-Updates | Yes | (r ) Yes | Yes
7 | SUSE_Linux_Enterprise_Software_Development_Kit_12_SP5_x86_64:SLE-SDK12-SP5-Debuginfo-Pool | SLE-SDK12-SP5-Debuginfo-Pool | No | ---- | ----
8 | SUSE_Linux_Enterprise_Software_Development_Kit_12_SP5_x86_64:SLE-SDK12-SP5-Debuginfo-Updates | SLE-SDK12-SP5-Debuginfo-Updates | No | ---- | ----
9 | SUSE_Linux_Enterprise_Software_Development_Kit_12_SP5_x86_64:SLE-SDK12-SP5-Pool | SLE-SDK12-SP5-Pool | Yes | (r ) Yes | No
10 | SUSE_Linux_Enterprise_Software_Development_Kit_12_SP5_x86_64:SLE-SDK12-SP5-Source-Pool | SLE-SDK12-SP5-Source-Pool | No | ---- | ----
11 | SUSE_Linux_Enterprise_Software_Development_Kit_12_SP5_x86_64:SLE-SDK12-SP5-Updates | SLE-SDK12-SP5-Updates | Yes | (r ) Yes | Yes
12 | SUSE_Package_Hub_12_SP5_x86_64:SUSE-PackageHub-12-SP5-Debuginfo | SUSE-PackageHub-12-SP5-Debuginfo | No | ---- | ----
13 | SUSE_Package_Hub_12_SP5_x86_64:SUSE-PackageHub-12-SP5-Pool | SUSE-PackageHub-12-SP5-Pool | Yes | (r ) Yes | No
14 | SUSE_Package_Hub_12_SP5_x86_64:SUSE-PackageHub-12-SP5-Standard-Pool | SUSE-PackageHub-12-SP5-Standard-Pool | Yes | (r ) Yes | No
15 | Web_and_Scripting_Module_12_x86_64:SLE-Module-Web-Scripting12-Debuginfo-Pool | SLE-Module-Web-Scripting12-Debuginfo-Pool | Yes | (r ) Yes | No
16 | Web_and_Scripting_Module_12_x86_64:SLE-Module-Web-Scripting12-Debuginfo-Updates | SLE-Module-Web-Scripting12-Debuginfo-Updates | Yes | (r ) Yes | Yes
17 | Web_and_Scripting_Module_12_x86_64:SLE-Module-Web-Scripting12-Pool | SLE-Module-Web-Scripting12-Pool | Yes | (r ) Yes | No
18 | Web_and_Scripting_Module_12_x86_64:SLE-Module-Web-Scripting12-Source-Pool | SLE-Module-Web-Scripting12-Source-Pool | Yes | (r ) Yes | No
19 | Web_and_Scripting_Module_12_x86_64:SLE-Module-Web-Scripting12-Updates | SLE-Module-Web-Scripting12-Updates | Yes | (r ) Yes | Yes
20 | pgdg-11 | PostgreSQL 11 SLES 12.5 - x86_64 | Yes | (r ) Yes | Yes
21 | pgdg-11-srpm | PostgreSQL 11 SLES 12.5 - x86_64 | No | ---- | ----
22 | pgdg-11-srpm-updates-testing | PostgreSQL 11 SLES 12.5 - x86_64 - SRPM Updates testing | No | ---- | ----
23 | pgdg-11-updates-testing | PostgreSQL 11 SLES 12.5 - x86_64 - Updates testing | No | ---- | ----

$ SUSEConnect --status-text

Installed Products:

SUSE Linux Enterprise Software Development Kit 12 SP5
(sle-sdk/12.5/x86_64)

Registered


SUSE Package Hub 12
(PackageHub/12.5/x86_64)

Registered


SUSE Linux Enterprise Server 12 SP5
(SLES/12.5/x86_64)

Registered

Subscription:

Regcode: hide
Starts at: 2020-08-20 00:00:00 UTC
Expires at: 2020-10-20 00:00:00 UTC
Status: ACTIVE
Type: evaluation

$ zypper search libclang6
Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP5_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12_SP5_x86_64'.
Refreshing service 'Web_and_Scripting_Module_12_x86_64'.
Loading repository data...
Reading installed packages...
No matching items found.

$ zypper search libclang
Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP5_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12_SP5_x86_64'.
Refreshing service 'Web_and_Scripting_Module_12_x86_64'.
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
--+-----------+--------------------------------+--------
| libclang | Library files needed for clang | package
| libclang7 | Library files needed for clang | package

Please tell me how to solve the problem with the missing package libclang6?

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi and welcome to the Forum :)
    Why are you using a SLE 11 repository? There is no libclang6 available for some time?

  • Thanks for the kind welcome
    No, I am not using SLE 11 repo.
    Above, I brought the repositories in the system. There are no repositories from suse 11 repo, only 12.

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Ahh ok, well you might have to talk with the postgre folks as it needs to be built against clang7 for SLE 12+...

  • hi
    i have problem for automate install a package in SLES 15 sp1
    i cant auto select number of solution
    what i do???
    can i help me

  • malcolmlewismalcolmlewis Knowledge Partner

    @ali Hi, seems you have posted in an existing thread, can you please start a new thread on your issue.

Sign In or Register to comment.