i have problem for automate instalation

i want install docker in SLES 15 sp1 and this is work with anisble or Dockerfile

but I get the following message during installation:

Problem: nothing provides apparmor-parser needed by docker-19.03.12_ce-375.6.x86_64
Solution 1: do not install docker-19.03.12_ce-375.6.x86_64
Solution 2: break docker-19.03.12_ce-375.6.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c):

=======================

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi and welcome to the Forum :)
    apparmor-parser should be available via the Basesystem module, is the system registered and update repositories added?

  • thanks
    My problem is that messages like the one above are displayed to install almost any package
    What should I do if I want to set the default option myself?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    So is the system registered? Can you show the active repositories?

    zypper lr -E
    
  • zypper lr -E
    Repository priorities are without effect. All enabled repositories share the same priority.

    | Alias | Name | Enabled | GPG Check | Refresh

    --+------------------------------+------------------------------+---------+-----------+--------
    2 | apache2 | apache2 | Yes | ( p) Yes | No
    3 | containerd | containerd | Yes | ( p) Yes | No
    4 | docker-compose | docker-compose | Yes | ( p) Yes | No
    5 | docker-distribution-registry | docker-distribution-registry | Yes | ( p) Yes | No
    6 | docker-sles15 | docker-sles15 | Yes | ( p) Yes | No
    7 | jalilzadeh | jalilzadeh | Yes | ( p) Yes | No
    8 | local | local | Yes | ( p) Yes | No

  • I just want this question not to be asked or I have chosen the right option before asking this question
    As I said, I want these steps to be done automatically by ansible

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    So you using third party repositories and not SLE repositories? If you download the SLES 13 SP1 Full packages DVD (SLE-15-SP1-Packages-x86_64-GM-DVD1.iso) from https://www.suse.com/download/sles/ not the QU4 one as I imagine this system has not been updated/registered. You can add the iso image as a local repository and apparmor-parser should be available. Or can just mount the iso image as a loop device and grab the rpm's you need. I suspect there will be further conflicts since your using third party repos...

  • Will updating solve this problem?
    Is this possible to automate the installation process and no longer display this message?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    It should sort out the issue if you get the correct packages installed.

  • My server does not have access to the Internet, will connecting the image solve this problem?
    I want to run tools with this operating system and all these processes should be automated, so this will not be a problem for me anymore?

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Yes, if you have the iso image as a local repository (YaST Software repositories) or an internal http/https server you can connect to as a local repository.

  • I did this now but only this file libapparmor1-2.12.3-7.20.1.x86_64.rpm exists in

  • I get an error when I try to create a dock file

    Problem retrieving the repository index file for service 'container-suseconnect-zypp':
    [container-suseconnect-zypp|file:/usr/lib/zypp/plugins/services/container-suseconnect-zypp]
    Warning: Skipping service 'container-suseconnect-zypp' because of the above error.
    All services have been refreshed.
    Warning: There are no enabled repositories defined.
    Use 'zypper addrepo' or 'zypper modifyrepo' commands to add or enable repositories.
    The command '/bin/bash -c zypper ref -s && zypper --non-interactive in docker' returned a non-zero code: 6

  • I wanted to update apparmor-parser, now it shows this error but this package does not exist on your site

    Problem: nothing provides insserv needed by apparmor-parser-2.10.3-2.1.x86_64
    Solution 1: do not install apparmor-parser-2.10.3-2.1.x86_64
    Solution 2: break apparmor-parser-2.10.3-2.1.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or cancel [1/2/c/d/?] (c):

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Version 2.10 of apparmor-parser is not in SLE 15 SP1 or SLE 15? Can you show the output from;

    cat /etc/os-release
    zypper if apparmor-parser
    

    Seems you setup is a mish-mash or packages from different release.

  • cat /etc/os-release
    NAME="SLES"
    VERSION="15-SP1"
    VERSION_ID="15.1"
    PRETTY_NAME="SUSE Linux Enterprise Server 15 SP1"
    ID="sles"
    ID_LIKE="suse"
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:suse:sles:15:sp1"

  • zypper if apparmor-parser
    Loading repository data...
    Reading installed packages...

    Information for package apparmor-parser:

    Repository : apparmor-parser
    Name : apparmor-parser
    Version : 2.10.3-2.1
    Arch : x86_64
    Vendor : obs://build.opensuse.org/Cloud:Platform:SUSE-Stemcell
    Support Level : unknown
    Installed Size : 1.8 MiB
    Installed : No
    Status : not installed
    Source package : apparmor-2.10.3-2.1.src
    Summary : AppArmor userlevel parser utility
    Description :
    The AppArmor Parser is a userlevel program that is used to load in
    program profiles to the AppArmor Security kernel module.

    This package is part of a suite of tools that used to be named
    SubDomain.
    
  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    You need to grab the relevant files from https://download.opensuse.org/repositories/Cloud:/Platform:/SUSE-Stemcell/SLE_15_SP1/ eg apparmor-parser so it all matches...

  • Can't you guide me how I can change the default option for this type of message so that I can do my own work automatically?

  • aliali
    edited August 25

    I downloaded all the files of this link, but it still shows the same errors

  • malcolmlewismalcolmlewis Knowledge Partner

    @ali did you add the files as a local repository on the system?

  • yes
    zypper lr -E
    Repository priorities are without effect. All enabled repositories share the same priority.

    | Alias | Name | Enabled | GPG Check | Refresh

    ---+------------------------------+------------------------------+---------+-----------+--------
    1 | SLES15-SP1_15.1-0_1 | SLES15-SP1 15.1-0 | Yes | (r ) Yes | No
    3 | apache2 | apache2 | Yes | ( p) Yes | No
    4 | apparmor-parser | apparmor-parser | Yes | ( p) Yes | No
    5 | containerd | containerd | Yes | ( p) Yes | No
    6 | docker-compose | docker-compose | Yes | ( p) Yes | No
    7 | docker-distribution-registry | docker-distribution-registry | Yes | ( p) Yes | No
    8 | docker-sles15 | docker-sles15 | Yes | ( p) Yes | No
    9 | jalilzadeh | jalilzadeh | Yes | ( p) Yes | No
    10 | local | local | Yes | ( p) Yes | No

  • malcolmlewismalcolmlewis Knowledge Partner

    @ali so the files are in repository number 10? Can you now show the output from zypper se insserv as I'm assuming this is the error your still seeing?

  • zypper se insserv
    Loading repository data...
    Reading installed packages...
    No matching items found.

    For an extended search including not yet activated remote resources you may run 'zypper
    search-packages' at any time.
    Do you want to run 'zypper search-packages' now? [yes/no/always/never] (no): yes

  • I downloaded all the required ramps and built a repository called apparmor as shown in the list

  • Can you just advise how I can choose solution 2 and do it with a script.

    Just say that, I will solve my problem

Sign In or Register to comment.