Uyuni Installation

Trying to finish installing/configuring a new Uyuni box to move away from Spacewalk. Having issues with SSL cert. Says to check /var/log/rhn/rhn_installation.log for more info, all I can find is this:

Exception type

Exception Handler Information
Traceback (most recent call last):
File "/usr/lib/python3.6/site-packages/spacewalk/server/rhnSQL/init.py", line 53, in __init__DB
my_db = __DB
NameError: name '__DB' is not defined

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/lib/python3.6/site-packages/spacewalk/satellite_tools/rhn_ssl_dbstore.py", line 55, in processCommandline
rhnSQL.initDB()
File "/usr/lib/python3.6/site-packages/spacewalk/server/rhnSQL/init.py", line 110, in initDB
init__DB(backend, host, port, username, password, database, sslmode, sslrootcert)
File "/usr/lib/python3.6/site-packages/spacewalk/server/rhnSQL/__init
.py", line 55, in init__DB
db_class = dbi.get_database_class(backend=backend)
File "/usr/lib/python3.6/site-packages/spacewalk/server/rhnSQL/dbi.py", line 47, in get_database_class
module = get_database_module(backend=backend)
File "/usr/lib/python3.6/site-packages/spacewalk/server/rhnSQL/dbi.py", line 37, in get_database_module
module = __import
(driver_dir, globals(), locals(), [driver_mod])
File "/usr/lib/python3.6/site-packages/spacewalk/server/rhnSQL/driver_postgresql.py", line 23, in
import psycopg2
ModuleNotFoundError: No module named 'psycopg2'

#

I've installed python-psycopg2, and tried to launch YaST Uyuni Setup again, but it fails out with the same error. What am I missing? Any help would be appreciated.

Comments

Sign In or Register to comment.