Claws mail

I tried to install claws mail but I can't because I don't resolve the dependencies in particular one library I can't resolve and the repository is the right one can someone help me? Thanks

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    @spardini Hi and welcome to the Forum :)
    Perhaps some more details (you have posted in general discussion) on what release of SLE your running cat /etc/os-release? Also what is the error you see?

  • NAME="SLED"
    VERSION="15-SP2"

  • malcolmlewismalcolmlewis Knowledge Partner
    edited November 6

    @spardini Hi, is this the error you see?
    Problem: nothing provides libusb-0.1.so.4()(64bit) needed by libpisock9-0.12.5-bp152.3.19.x86_64 Solution 1: do not install claws-mail-3.17.8-bp152.3.6.1.x86_64 Solution 2: break libpisock9-0.12.5-bp152.3.19.x86_64 by ignoring some of its dependencies

    If so and your not syncing to a PALM device, then select solution 2....

    Choose from above solutions by number or cancel [1/2/c/d/?] (c): 2
    Resolving dependencies...
    Resolving package dependencies...
    
    The following 5 NEW packages are going to be installed:
      claws-mail compface libetpan20 libpisock9 pinentry-gtk2
    
    The following package is recommended, but will not be installed due to conflicts or dependency issues:
      claws-mail-lang
    
    The following 3 packages have no support information from their vendor:
      claws-mail libetpan20 libpisock9
    
    The following package is not supported by its vendor:
      pinentry-gtk2
    
    5 new packages to install.
    Overall download size: 3.9 MiB. Already cached: 0 B. After the operation, additional 12.6 MiB will be used.
    Continue? [y/n/v/...? shows all options] (y):
    
  • Not, is this...
    zypper install claws-mail-3.17.6-bp152.3.3.1
    Refreshing service 'Basesystem_Module_15_SP2_x86_64'.
    Refreshing service 'Desktop_Applications_Module_15_SP2_x86_64'.
    Refreshing service 'Development_Tools_Module_15_SP2_x86_64'.
    Refreshing service 'Python_2_Module_15_SP2_x86_64'.
    Refreshing service 'SUSE_Cloud_Application_Platform_Tools_Module_15_SP2_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Desktop_15_SP2_x86_64'.
    Refreshing service 'SUSE_Linux_Enterprise_Workstation_Extension_15_SP2_x86_64'.
    Refreshing service 'SUSE_Package_Hub_15_SP2_x86_64'.
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    Problem: nothing provides libusb-0.1.so.4()(64bit) needed by libpisock9-0.12.5-bp152.3.19.x86_64
    Solution 1: do not install claws-mail-3.17.6-bp152.3.3.1.x86_64
    Solution 2: break libpisock9-0.12.5-bp152.3.19.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or cancel [1/2/c/d/?] (c): d
    Problem: nothing provides libusb-0.1.so.4()(64bit) needed by libpisock9-0.12.5-bp152.3.19.x86_64
    Detailed information:
    claws-mail-3.17.6-bp152.3.3.1.x86_64 requires libpisock.so.9()(64bit), but this requirement cannot be provided
    nothing provides libusb-0.1.so.4()(64bit) needed by libpisock9-0.12.5-bp152.3.19.x86_64
    Solution 1: do not install claws-mail-3.17.6-bp152.3.3.1.x86_64
    Solution 2: break libpisock9-0.12.5-bp152.3.19.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or cancel [1/2/c/d/?] (c): ^Chomenet:/home/stefano #

  • as you can see the repository is correct but it can't resolve the library dependencies

  • I use the mutt client for many years but i need to install claws-mail...

  • malcolmlewismalcolmlewis Knowledge Partner
    edited November 6

    @spardini you need to refresh your repositories... you should be seeing claws-mail-3.17.8-bp152.3.6.1.x86_64 your showing claws-mail-3.17.6-bp152.3.3.1.x86_64.

    Information for package claws-mail:
    -----------------------------------
    Repository     : SUSE-PackageHub-15-SP2-Backports-Pool
    Name           : claws-mail
    Version        : 3.17.8-bp152.3.6.1
    

    Try zypper ref -f then zypper in claws-mail then select Solution 2.

  • sorry but forcing the installation is not a solution I don't understand why it doesn't have to resolve dependencies if the repository is correctly set up it should provide the libraries

  • malcolmlewismalcolmlewis Knowledge Partner

    Hi
    Because the missing library is only available in SLES...

    Like I indicated, only for palm devices, if you have access to the above, a manual download/install will work... YMMV.

  • ok, I've never had these problems with Debian, I like this sled, it's well done, stable and has a lot of useful features but probably not good for me, so I guess I'll go back to my Debian. Thanks for the help

Sign In or Register to comment.