MD5 warning message using host, dig, nslookup (bind-utils) on SLES 12 SP5 with FIPS enabled.

Hi. I have noticed that whenever I use any of the bind-utils (host, dig, nslookup) on a patched version of SLES 12 SP5 with FIPS enabled, I receive the following warning message.
jlutz@testsles12:~> host 192.168.1.1
hmac_link.c:350: FIPS mode is 1: MD5 is only supported if the value is 0.
Please disable either FIPS mode or MD5.
1.1.168.192.in-addr.arpa domain name pointer www.routerlogin.com.

I am wondering how one can disable MD5 in order to get rid of this message. We are not able to disable FIPS as it's required within our environment. The version of bind-utils that created this message is 'bind-utils-9.11.22-3.22.1.x86_64'. Thanks.

Comments

Sign In or Register to comment.