Can´t install rpm-build needed by SAP Bussines One

Hello everyone,
I´m from a SAP partner and we are installing a SBO 10 for Hana test enviroment. We have no much experience on SLES
When we try to install SBO 10, we get and error that we need rpm-build.
We havé tried to installa rpm-build but has a dependency of gcc
When trying to install gcc we have a dependency from libc-devel but we can´t continue.
Here are screenshots for the output.



Thank you very much.

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    @Juan_artesap Hi and welcome to the Forum :)
    Here I see;

    zypper se glibc-devel
    ...
    Reading installed packages...
    
    S | Name               | Summary                                               | Type
    --+--------------------+-------------------------------------------------------+--------
      | glibc-devel        | Include Files and Libraries Mandatory for Development | package
      | glibc-devel-32bit  | Include Files and Libraries Mandatory for Development | package
      | glibc-devel-static | C library static libraries for -static linking        | package
      | linux-glibc-devel  | Linux headers for userspace development               | package
    
    zypper if glibc-devel
    Information for package glibc-devel:
    ------------------------------------
    Repository     : SLE-Module-Basesystem15-SP1-Updates
    Name           : glibc-devel
    Version        : 2.26-13.51.1
    
    zypper in gcc10
    The following 10 NEW packages are going to be installed:
      cpp10 gcc10 glibc-devel libasan6 libatomic1 libitm1 liblsan0 libtsan0 libubsan1 linux-glibc-devel
    
    The following 2 packages are suggested, but will not be installed:
      gcc10-info gcc10-locale
    
    10 new packages to install.
    

    Can you ensure all the update repositories are present?

    zypper ref -f
    zypper lr -E
    
  • Thank you for your response @malcolmlewis
    Listing repositories, I´ve seen that I don´t have SLE-Module-Basesystem15-SP1-Updates.
    I´ve SLES 15 SP1 and I´ve register the version and I can see it using Yast in Extension and Modules
    I added repository with command.
    SUSEConnect -p sle-module-basesystem/15.1/x86_64
    Now I can see glibc-devel package information
    After that, I can install rpm-build
    Thank your very much for your help.

Sign In or Register to comment.