Gnome Graphical Console will not start at boot

I have the "Use graphical console" option checked under Boot Loader Settings > Kernel Parameters. However when I boot my SLES15SP2 virtual machine it will not start the graphical console. I can log into the console and start it with "init 3" then "init 5". Any help appreciated.

Comments

  • malcolmlewismalcolmlewis Knowledge Partner

    @Jamie Hi and welcome to the Forum :)
    That option is for GRUB graphical, not the desktop, by default SLES will boot to the tty/console (runlevel 3), for graphical (runlevel 5) target, you need to set this option as follows;

    Runlevel 5
    systemctl set-default graphical.target
    Runlevel 3
    systemctl set-default multi-user.target
    
  • This did not help unfortunately. Is there a log that would indicate what is happening?

  • malcolmlewismalcolmlewis Knowledge Partner

    @Jamie Hi, so what does the output show from systemctl get-default?
    Logs for Xorg should be down in /var/log to see what is what.

  • I think I see my error now. I was following your reply "system set-default graphical.target" then "systemctl set-default multi-user.target". So it works if I use the graphical.target parameter only. Thanks for the help.

Sign In or Register to comment.