Apache server upgradation- 139574 - Apache 2.4.x < 2.4.46 Multiple Vulnerabilities

Team,
We are supposed to upgrade Apache as per Multiple Vulnerabilities.
Therefore,. please suggest us to fix the same with downloading link for the apache RPM.
Synopsis
The remote web server is affected by multiple vulnerabilities.
Description
The version of Apache httpd installed on the remote host is prior to 2.4.46. It is, therefore, affected by multiple vulnerabilities as referenced in the 2.4.46 advisory.

  • Apache HTTP server 2.4.32 to 2.4.44 mod_proxy_uwsgi info disclosure and possible RCE (CVE-2020-11984)
  • Apache HTTP Server versions 2.4.20 to 2.4.43 When trace/debug was enabled for the HTTP/2 module and on certain traffic edge patterns, logging statements were made on the wrong connection, causing concurrent use of memory pools. Configuring the LogLevel of mod_http2 above info will mitigate this vulnerability for unpatched servers. (CVE-2020-11993)
  • Apache HTTP Server versions 2.4.20 to 2.4.43. A specially crafted value for the 'Cache-Digest' header in a HTTP/2 request would result in a crash when the server actually tries to HTTP/2 PUSH a resource afterwards.
    Configuring the HTTP/2 feature via H2Push off will mitigate this vulnerability for unpatched servers.
    (CVE-2020-9490)
    Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.
    Solution
    Upgrade to Apache version 2.4.46 or later.
    Risk Factor
    High

Thanks,
Harish T

Comments

Sign In or Register to comment.