ASK: Setting up SLES HA with OCFS2

Hallo,

I am sorry if this question already been posted. I am looking for the same thread but still don't find the answer.
I am setting 2 node SLES (version 11SP3) HA with OCFS2 with these steps:
1. From node A, I partition the disk (SAN) to be STONITH and later to be OCFS volume
2. Setting SLES HA in the first node (A).
- Doing sleha-init. NTP configured
- Format disk to be OCFS volume
- Restart openais
- crm_mon shows not error . First node(A) is online and stonith-sbd started A.
- The SAN disk mounted as i wish in node A.
3. Setting node B in the cluster.
- Doing sleha-join to IP address of node A. NTP configured.
- Restart openais.
- crm_mon shows no error. Online: node A and node B). Stonith-sbd:started node A.
- The same SAN disk is mounted in node B.

When one node down (it is same for A or B), the mounting disconnected. The mounting only work, if both node A and B online.
What i expect is when node A down, B can still use the disk. When node B down, node A can still use the disk.
What step that i missing to achieve my expectation?
Please advice

Thanks..

Comments

  • Automatic ReplyAutomatic Reply No Reply Posting Bot
    lunetta,

    It appears that in the past few days you have not received a response to your
    posting. That concerns us, and has triggered this automated reply.

    These forums are peer-to-peer, best effort, volunteer run and that if your issue
    is urgent or not getting a response, you might try one of the following options:

    - Visit http://www.suse.com/support and search the knowledgebase and/or check all
    the other support options available.
    - Open a service request: https://www.suse.com/support
    - You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.suse.com)

    Be sure to read the forum FAQ about what to expect in the way of responses:
    http://forums.suse.com/faq.php

    If this is a reply to a duplicate posting or otherwise posted in error, please
    ignore and accept our apologies and rest assured we will issue a stern reprimand
    to our posting bot..

    Good luck!

    Your SUSE Forums Team
    http://forums.suse.com
  • jmozdzenjmozdzen Knowledge Partner
    Hi lunetta,

    sorry for the late reply.

    > SLES (version 11SP3)

    do you have any driving need to use that out-of-date version, rather than SP4?

    > What i expect is when node A down, B can still use the disk. When node B down, node A can still use the disk.
    > What step that i missing to achieve my expectation?

    how did you set up the cluster regarding quorum and how to react to a no-quorum situation?

    Regards,
    J
Sign In or Register to comment.