SLES12SP5 VM stuck at GRUB when booting

AleksandarAleksandar New or Quiet Member

I have a SLES12SP5 VM in VMware ESXi 6.5 that I ran zypper patch on and then rebooted.
Now it's stuck on "GRUB" in the upper left corner of the screen when booting.
I can boot from a SLES DVD and then select Boot Linux System and start the OS that way.
The information I found about repairing GRUB is focused on SLES10 or 11.

Any tips on how to fix this?



  • malcolmlewismalcolmlewis Knowledge Partner
    edited June 2020

    Have you tried making a change in YaST bootloader so it rebuilds grub or from the cli;

    grub2-mkconfig -o /boot/grub2/grub.cfg

    Do you get errors? Does the GRUB_CMDLINE_LINUX_DEFAULT look ok in /etc/default/grub
    Is /boot a separate partition?

  • AndreasAndreas Senior Member
  • AleksandarAleksandar New or Quiet Member

    I booted from the ISO and did an "upgrade" over the current installation and that fixed it :smile:
    Thanks for the tips.

Sign In or Register to comment.