PDA

View Full Version : SLES 11 SP3 Touch doesnt work Posiflex TM3114



Moratorro
28-Sep-2017, 14:22
Hi to all the experts:

IM trying to install a TM3114E touch screen from posiflex on SLES 11 sp3 , and lucky me the touch doesnt work ( i had other touch and didnt work either)
i dont know what could be wrong. im sure that if i install this screen on ubuntu-gnome it will work right away( thats what happened witha greentouch screen a month ago)


can you help me please?

let me know what info you need

regards

malcolmlewis
28-Sep-2017, 14:33
Hi
Do you have a link to the device specifications? Is it connected via USB? Have you tried setting it up via Sax2 from the command line?

Moratorro
29-Sep-2017, 01:10
HI

http://www.posiflex.com/en-global/product/index/POS-Monitor/Standalone/TM-3114E
yes its connected through USB
SAX2 doesnt do anything

lsusb output

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 046d:c063 Logitech, Inc. DELL Laser Mouse
Bus 001 Device 003: ID 413c:1010 Dell Computer Corp.
Bus 001 Device 004: ID 045b:022b Hitachi, Ltd
Bus 003 Device 002: ID 8087:8008 Intel Corp.
Bus 004 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 005: ID 413c:2110 Dell Computer Corp.
Bus 001 Device 006: ID 2149:36b3

there is one line with nothing, dont know why

let me know what output you need

regards

malcolmlewis
29-Sep-2017, 03:29
Hi
You not having much luck with these screens... :( I can only see windows drivers for that screen.

So, if you unplug the usb connection and replug and then run dmesg what does it show?

I'm guessing it is the 2149:36b3 line.

Moratorro
29-Sep-2017, 16:21
HI
here is the output

[ 3.341522] usb 1-9.3: new full-speed USB device number 7 using xhci_hcd
[ 3.359075] usb 1-9.3: New USB device found, idVendor=2149, idProduct=36b3
[ 3.359116] usb 1-9.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 3.359153] usb 1-9.3: Product: weid
[ 3.359188] usb 1-9.3: Manufacturer: Weid
[ 3.361513] input: Weid weid as /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9.3/1-9.3:1.0/input/input6
[ 3.361597] generic-usb 0003:2149:36B3.0004: input,hidraw3: USB HID v1.10 Device [Weid weid] on usb-0000:00:14.0-9.3/input0
[ 5.550028] Initializing USB Mass Storage driver...
[ 5.550121] scsi4 : usb-storage 1-1:1.0
[ 5.550224] usbcore: registered new interface driver usb-storage
[ 5.550266] USB Mass Storage support registered.
[ 948.783716] usb 1-9: USB disconnect, device number 5
[ 948.783724] usb 1-9.3: USB disconnect, device number 7
[ 990.832867] usb 1-9: new high-speed USB device number 8 using xhci_hcd
[ 990.849073] usb 1-9: New USB device found, idVendor=045b, idProduct=022b
[ 990.849080] usb 1-9: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 990.849645] hub 1-9:1.0: USB hub found
[ 991.136697] usb 1-9.3: new full-speed USB device number 9 using xhci_hcd
[ 991.154189] usb 1-9.3: New USB device found, idVendor=2149, idProduct=36b3
[ 991.154197] usb 1-9.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 991.154202] usb 1-9.3: Product: weid
[ 991.154205] usb 1-9.3: Manufacturer: Weid
[ 991.157871] input: Weid weid as /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9.3/1-9.3:1.0/input/input14
[ 991.158063] generic-usb 0003:2149:36B3.0005: input,hidraw3: USB HID v1.10 Device [Weid weid] on usb-0000:00:14.0-9.3/input0
[ 1144.621499] usb 1-9: USB disconnect, device number 8
[ 1144.621507] usb 1-9.3: USB disconnect, device number 9
[ 1160.660497] usb 1-9: new high-speed USB device number 10 using xhci_hcd
[ 1160.676658] usb 1-9: New USB device found, idVendor=045b, idProduct=022b
[ 1160.676666] usb 1-9: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 1160.677221] hub 1-9:1.0: USB hub found
[ 1160.964326] usb 1-9.3: new full-speed USB device number 11 using xhci_hcd
[ 1160.981853] usb 1-9.3: New USB device found, idVendor=2149, idProduct=36b3
[ 1160.981861] usb 1-9.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1160.981866] usb 1-9.3: Product: weid
[ 1160.981869] usb 1-9.3: Manufacturer: Weid
[ 1160.985618] input: Weid weid as /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9.3/1-9.3:1.0/input/input15
[ 1160.985812] generic-usb 0003:2149:36B3.0006: input,hidraw3: USB HID v1.10 Device [Weid weid] on usb-0000:00:14.0-9.3/input0

and i was trying to install the xinput calibrator(which might help to calibrate the screen under linux) from a tarball( no package for suse it seems) and i cant install it.
im lost with ./configure, then make and install

regards

malcolmlewis
30-Sep-2017, 05:19
Hi
Well it seems to be recognized as a HID device. So nothing in Sax2 for the mouse device?

Here is a build for your package;
https://build.opensuse.org/package/show/home:malcolmlewis:SLE_11_General/xinput_calibrator

Download from here and install manually;
https://download.opensuse.org/repositories/home:/malcolmlewis:/SLE_11_General/SLE_11_SP3/x86_64/

Moratorro
02-Oct-2017, 21:11
HI Again:

I've checked the SAx2 utility and it only sees one mouse (dell)
about thee packages: the first one is to build it froms scratch? so i need to use the /autogen, make and all that?

the second link, i tried to install the RPM but i get this error

libX11.so.6()(64bit) is needed by xinput_calibrator-0.7.5+git20140213-2.2.x86_64

and may other dependencies missing. I can install them , no problem on that, but the OS its 32bits , so it might be a problem to install the 64bit versions

thanks for all the help, waiting for your reply

regards

malcolmlewis
02-Oct-2017, 21:26
HI Again:

I've checked the SAx2 utility and it only sees one mouse (dell)
about thee packages: the first one is to build it froms scratch? so i need to use the /autogen, make and all that?

the second link, i tried to install the RPM but i get this error

libX11.so.6()(64bit) is needed by xinput_calibrator-0.7.5+git20140213-2.2.x86_64

and may other dependencies missing. I can install them , no problem on that, but the OS its 32bits , so it might be a problem to install the 64bit versions

thanks for all the help, waiting for your reply

regards
Hi
32 bit was there, just a different directory ;)
https://download.opensuse.org/repositories/home:/malcolmlewis:/SLE_11_General/SLE_11_SP3/i586/xinput_calibrator-0.7.5+git20140213-2.2.i586.rpm

Try that one.

Moratorro
04-Oct-2017, 03:05
HI

Thanks, i had a little brain fart jaja.

i was able to install the rpm, but ruuning the app i get this:

DEBUG: Skipping virtual master devices and devices without axis valuators.
DEBUG: Skipping device 'Mouse[1]' id=3, does not report Absolute events.
Error: No calibratable devices found.

FYI im waiting for new drivers so maybe we will have better luck with them

regards