PDA

View Full Version : Unable to register servers with SMT - Download Failed. Abort



postaszewski
01-May-2012, 21:06
I have followed everything to the T. Can't seem to get any of the servers (oes11 or oes10) to register with the SMT server.

I try to run the clientSetup4SMT.sh on the server as so: ./clientSetup4SMT.sh https://smt.skokie68.org/center/regsvc and I get "download failed. abort."

I tried doing ./clientSetup4SMT.sh --host smt.skokie68.org and still got "download failed. abort."

I'm able to browse the "http://smt.skokie68.org/repo/tools/ClientSetup4SMT.sh" URL and download the clientSetup4SMT.sh file to each of my servers with no issue. My problem is registering my SLES11 and SLES10 servers to the SMT server.

We do not have a proxy, nor do we have to use one to reach the server.

I tried looking over the content of this TID but did not find anything that pertains to my issue: http://www.novell.com/support/kb/doc.php?id=7004748

The only thing i noticed when I ran rcsmt status i get:

Using apache2 conf plugin /etc/apache2/conf.d/nu_server.conf
Using apache2 conf plugin /etc/apache2/conf.d/smt_mod_perl.conf
Using apache2 conf plugin /etc/apache2/conf.d/smt_support.conf
Not using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf (SMT not enabled)
Using cron plugin /etc/cron.d/novell.com-smt
Checking for httpd2: running
Checking for service MySQL: running
Checking for Cron: running

The only part that doesn't look right is: Not using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf (SMT not enabled)

The TID link shows this in its example: using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf

I'm not sure why it wouldn't be using the vhost plugin... How do you go about enabling SMT to use the vhost plugin? Why didn't the installation enable it? Is this the cause of my problem?

Nothing else on that page helped me or looked to be the reason to my "download failed. abort." error.

I've tried going into yast, http server, and turning on ssl from the modules list but that didn't help.

I downloaded SMT right off the novell site. In the notes I read, it requires SLES 11 sp2. I took a server, completely wiped it clean. I then booted off the SLES 11 sp2 dvd and began the OS install. When it gave me the option for "add on products" i put in the SMT cd in and it went from there. I did nothing custom and followed the SMT pdf step by step and it did not work right out of the box.

Anyone have this issue and know how I can fix it?

Thanks,

-Paul

malcolmlewis
01-May-2012, 23:06
I have followed everything to the T. Can't seem to get any of the
servers (oes11 or oes10) to register with the SMT server.

I try to run the clientSetup4SMT.sh on the server as so:
/clientSetup4SMT.sh https://smt.skokie68.org/center/regsvc and I get
"download failed. abort."

I tried doing ./clientSetup4SMT.sh --host smt.skokie68.org and still
got "download failed. abort."

I'm able to browse the
"http://smt.skokie68.org/repo/tools/ClientSetup4SMT.sh" URL and download
the clientSetup4SMT.sh file to each of my servers with no issue. My
problem is registering my SLES11 and SLES10 servers to the SMT server.

We do not have a proxy, nor do we have to use one to reach the server.

I tried looking over the content of this TID but did not find anything
that pertains to my issue:
http://www.novell.com/support/kb/doc.php?id=7004748

The only thing i noticed when I ran rcsmt status i get:

Using apache2 conf plugin /etc/apache2/conf.d/nu_server.conf
Using apache2 conf plugin /etc/apache2/conf.d/smt_mod_perl.conf
Using apache2 conf plugin /etc/apache2/conf.d/smt_support.conf
Not using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf
(SMT not enabled)
Using cron plugin /etc/cron.d/novell.com-smt
Checking for httpd2: running
Checking for service MySQL: running
Checking for Cron: running

The only part that doesn't look right is: Not using apache2 vhosts
plugin /etc/apache2/vhosts.d/vhost-ssl.conf (SMT not enabled)

The TID link shows this in its example: using apache2 vhosts plugin
/etc/apache2/vhosts.d/vhost-ssl.conf

I'm not sure why it wouldn't be using the vhost plugin... How do you go
about enabling SMT to use the vhost plugin? Why didn't the installation
enable it? Is this the cause of my problem?

Nothing else on that page helped me or looked to be the reason to my
"download failed. abort." error.

I've tried going into yast, http server, and turning on ssl from the
modules list but that didn't help.

I downloaded SMT right off the novell site. In the notes I read, it
requires SLES 11 sp2. I took a server, completely wiped it clean. I then
booted off the SLES 11 sp2 dvd and began the OS install. When it gave me
the option for "add on products" i put in the SMT cd in and it went from
there. I did nothing custom and followed the SMT pdf step by step and it
did not work right out of the box.

Anyone have this issue and know how I can fix it?

Thanks,

-Paul



Hi
Known issue and being worked on, don't have an ETA yet.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
up 2 days 17:23, 5 users, load average: 0.00, 0.01, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

malcolmlewis
02-May-2012, 05:19
I have followed everything to the T. Can't seem to get any of the
servers (oes11 or oes10) to register with the SMT server.

I try to run the clientSetup4SMT.sh on the server as so:
/clientSetup4SMT.sh https://smt.skokie68.org/center/regsvc and I get
"download failed. abort."

I tried doing ./clientSetup4SMT.sh --host smt.skokie68.org and still
got "download failed. abort."

I'm able to browse the
"http://smt.skokie68.org/repo/tools/ClientSetup4SMT.sh" URL and download
the clientSetup4SMT.sh file to each of my servers with no issue. My
problem is registering my SLES11 and SLES10 servers to the SMT server.

We do not have a proxy, nor do we have to use one to reach the server.

I tried looking over the content of this TID but did not find anything
that pertains to my issue:
http://www.novell.com/support/kb/doc.php?id=7004748

The only thing i noticed when I ran rcsmt status i get:

Using apache2 conf plugin /etc/apache2/conf.d/nu_server.conf
Using apache2 conf plugin /etc/apache2/conf.d/smt_mod_perl.conf
Using apache2 conf plugin /etc/apache2/conf.d/smt_support.conf
Not using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf
(SMT not enabled)
Using cron plugin /etc/cron.d/novell.com-smt
Checking for httpd2: running
Checking for service MySQL: running
Checking for Cron: running

The only part that doesn't look right is: Not using apache2 vhosts
plugin /etc/apache2/vhosts.d/vhost-ssl.conf (SMT not enabled)

The TID link shows this in its example: using apache2 vhosts plugin
/etc/apache2/vhosts.d/vhost-ssl.conf

I'm not sure why it wouldn't be using the vhost plugin... How do you go
about enabling SMT to use the vhost plugin? Why didn't the installation
enable it? Is this the cause of my problem?

Nothing else on that page helped me or looked to be the reason to my
"download failed. abort." error.

I've tried going into yast, http server, and turning on ssl from the
modules list but that didn't help.

I downloaded SMT right off the novell site. In the notes I read, it
requires SLES 11 sp2. I took a server, completely wiped it clean. I then
booted off the SLES 11 sp2 dvd and began the OS install. When it gave me
the option for "add on products" i put in the SMT cd in and it went from
there. I did nothing custom and followed the SMT pdf step by step and it
did not work right out of the box.

Anyone have this issue and know how I can fix it?

Thanks,

-Paul



Hi
Known issue and being worked on, don't have an ETA yet.


Hi
Should all be working now, can you confirm?

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
up 2 days 23:36, 4 users, load average: 0.00, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

postaszewski
02-May-2012, 14:37
It's still not working.

escfs:/tmp # ./clientSetup4SMT.sh --host smt.skokie68.org --regcert http://smt.skokie68.org/smt.crt
Download failed. Abort.
escfs:/tmp #

postaszewski
02-May-2012, 14:49
Just tried another server just now and it went a little further, but errored out.

Do you accept this certificate? [y/n] y
Client setup finished.
Start the registration now? [y/n] y
/usr/bin/suse_register -i -L /root/.suse_register.log
Execute curl command failed with '7':
curl: (7) couldn't connect to host

postaszewski
02-May-2012, 15:03
I just tried a third (sles 10 sp4) and it did exactly the same as the one prior.

postaszewski
02-May-2012, 15:37
Tried my mobility server (sles 11 sp2) and got this:

Do you accept this certificate? [y/n] y
Client setup finished.
Start the registration now? [y/n] y
/usr/bin/suse_register -i -L /root/.suse_register.log
Refreshing service 'nu_novell_com'.
All services have been refreshed.
Repository 'SLE11-SMT-SP2-Updates' is up to date.
Repository 'SLE11-SP2-Debuginfo-Core' is up to date.
Repository 'SLE11-SP2-Debuginfo-Updates' is up to date.
Repository 'SLE11-WebYaST-SP2-Pool' is up to date.
Repository 'SLE11-WebYaST-SP2-Updates' is up to date.
Repository 'SLES11-SP1-Pool' is up to date.
Repository 'SLES11-SP1-Updates' is up to date.
Building repository 'SLES11-SP1-Updates' cache [done]
Repository 'SLES11-SP2-Core' is up to date.
Repository 'SLES11-SP2-Extension-Store' is up to date.
Repository 'SLES11-SP2-Updates' is up to date.
All repositories have been refreshed.
ERROR: Couldn't connect to server: (7)
(2)
ERROR: Couldn't connect to server: (7)
(2)

postaszewski
02-May-2012, 16:48
None of the servers are showing up under SMT Management > Client status on the SMT server.

postaszewski
04-May-2012, 14:57
Can anyone help me with this issue?

nafab
11-May-2012, 08:03
be sure that your https is up! the suse_register script tries to download all data from https://smt...

check that your server certificat match your smt service name: http://www.novell.com/support/kb/doc.php?id=7006024

check /etc/sysconfig/apache2: 'ssl' must be listed in APACHE_MODULES and APACHE_SERVER_FLAGS must contain 'SSL'.

'smt-list-registrations' on the server will show you your current regstrations... you don't need this 'yast' thing all the time ;-)

you could also edit /usr/bin/suse_register and set 'my $debug = 1' and rerun the clientSetup4SMT.sh.
In our case it was all the time enough to run 'sh clientSetup4SMT.sh --host <smt.host.tld>'
if your smt setup is correct you needn't to name a certificate in this command...

BTW: did you have a look in your /roo/.suse_register.log?

postaszewski
11-May-2012, 14:40
be sure that your https is up! the suse_register script tries to download all data from https://smt...

check that your server certificat match your smt service name: http://www.novell.com/support/kb/doc.php?id=7006024

check /etc/sysconfig/apache2: 'ssl' must be listed in APACHE_MODULES and APACHE_SERVER_FLAGS must contain 'SSL'.

'smt-list-registrations' on the server will show you your current regstrations... you don't need this 'yast' thing all the time ;-)

you could also edit /usr/bin/suse_register and set 'my $debug = 1' and rerun the clientSetup4SMT.sh.
In our case it was all the time enough to run 'sh clientSetup4SMT.sh --host <smt.host.tld>'
if your smt setup is correct you needn't to name a certificate in this command...

BTW: did you have a look in your /roo/.suse_register.log?

Thank you for your response!

I will give this all a go and get back to you. I'm not the greatest with linux, and it seems that NOTHING ever goes as planned with Novell on Linux. I'm about out of SR's and didn't want to waste one on this. I don't understand why, when you follow everything exactly like they say to in the documentation... it NEVER works. It's so frustrating.

jmozdzen
11-May-2012, 16:45
Hi Paul,


Tried my mobility server (sles 11 sp2) and got this:

Do you accept this certificate? [y/n] y
Client setup finished.
Start the registration now? [y/n] y
/usr/bin/suse_register -i -L /root/.suse_register.log
[...]
All repositories have been refreshed.
ERROR: Couldn't connect to server: (7)
(2)
ERROR: Couldn't connect to server: (7)
(2)


Can anyone help me with this issue?

Have you had a look at the log file? Any hints there why the download failed?

Regards,
Jens

postaszewski
11-May-2012, 16:48
TBH, I had no idea where to look. I'm new to linux and learning as I go. I'm slammed at the moment, so I can't get to this right now. I'll try these suggestions after lunch.

postaszewski
16-May-2012, 17:20
be sure that your https is up! the suse_register script tries to download all data from https://smt...

check that your server certificat match your smt service name: http://www.novell.com/support/kb/doc.php?id=7006024

check /etc/sysconfig/apache2: 'ssl' must be listed in APACHE_MODULES and APACHE_SERVER_FLAGS must contain 'SSL'.

'smt-list-registrations' on the server will show you your current regstrations... you don't need this 'yast' thing all the time ;-)

you could also edit /usr/bin/suse_register and set 'my $debug = 1' and rerun the clientSetup4SMT.sh.
In our case it was all the time enough to run 'sh clientSetup4SMT.sh --host <smt.host.tld>'
if your smt setup is correct you needn't to name a certificate in this command...

BTW: did you have a look in your /roo/.suse_register.log?


OMG! You are a savior! I recreated the cert and added in the code where you suggested and everything is working perfectly!

Thank you sooooooo much for your help!

-Paul

wdiana
09-Aug-2013, 19:43
Hi,

Check if yo dont have the PROXY configured (type yast proxy from prompt and disable it). That was my solution, then restart ssh, and relogin, and try again.

Good look.!



I have followed everything to the T. Can't seem to get any of the servers (oes11 or oes10) to register with the SMT server.

I try to run the clientSetup4SMT.sh on the server as so: ./clientSetup4SMT.sh https://smt.skokie68.org/center/regsvc and I get "download failed. abort."

I tried doing ./clientSetup4SMT.sh --host smt.skokie68.org and still got "download failed. abort."

I'm able to browse the "http://smt.skokie68.org/repo/tools/ClientSetup4SMT.sh" URL and download the clientSetup4SMT.sh file to each of my servers with no issue. My problem is registering my SLES11 and SLES10 servers to the SMT server.

We do not have a proxy, nor do we have to use one to reach the server.

I tried looking over the content of this TID but did not find anything that pertains to my issue: http://www.novell.com/support/kb/doc.php?id=7004748

The only thing i noticed when I ran rcsmt status i get:

Using apache2 conf plugin /etc/apache2/conf.d/nu_server.conf
Using apache2 conf plugin /etc/apache2/conf.d/smt_mod_perl.conf
Using apache2 conf plugin /etc/apache2/conf.d/smt_support.conf
Not using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf (SMT not enabled)
Using cron plugin /etc/cron.d/novell.com-smt
Checking for httpd2: running
Checking for service MySQL: running
Checking for Cron: running

The only part that doesn't look right is: Not using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf (SMT not enabled)

The TID link shows this in its example: using apache2 vhosts plugin /etc/apache2/vhosts.d/vhost-ssl.conf

I'm not sure why it wouldn't be using the vhost plugin... How do you go about enabling SMT to use the vhost plugin? Why didn't the installation enable it? Is this the cause of my problem?

Nothing else on that page helped me or looked to be the reason to my "download failed. abort." error.

I've tried going into yast, http server, and turning on ssl from the modules list but that didn't help.

I downloaded SMT right off the novell site. In the notes I read, it requires SLES 11 sp2. I took a server, completely wiped it clean. I then booted off the SLES 11 sp2 dvd and began the OS install. When it gave me the option for "add on products" i put in the SMT cd in and it went from there. I did nothing custom and followed the SMT pdf step by step and it did not work right out of the box.

Anyone have this issue and know how I can fix it?

Thanks,

-Paul

jmozdzen
13-Aug-2013, 18:35
Hi wdiana,

it was a certificate problem, and solved about 15 months ago ;)


I recreated the cert and added in the code where you suggested and everything is working perfectly!

Regards,

Jens