PDA

View Full Version : SLES10SP3 and Attansic EtherContr: Class 0200, 1969:1083



skoltogyan
08-May-2012, 10:33
I have new hardware with onboard Ethernet Card:
02:00.0 Ethernet controller [Class 0200]: Attansic Technology Corp. Device [1969:1083] (rev c0 )

My SLES10SP3 - can not use this Ethernet Card (Kernel 2.6.16.6--0.54.5)...

Please, help to find drivers for this network interface card for sles10sp3.


Serg

malcolmlewis
08-May-2012, 15:10
Hi
To be honest you probably better off to find an older model PCI card (e1000 etc) and use that.....

Can you post the output from;


hwinfo --netcard

skoltogyan
08-May-2012, 15:25
21: PCI 200.0: 0200 Ethernet controller
[Created at pci.322]
UDI: /org/freedesktop/Hal/devices/pci_1969)1083
Unique ID: B35A.+tssbzsWE78
Parent ID: QSNP.x+BsDO9g5H0
SysFS ID: /device/pci0000:00/0000:00:1c.4/0000:02:00.0
SysFS BusID: 0000:02:00.0
Hardware Class: network
Model: "Attansic Ethernet controller"
Vendor: pci 0x1969 "Attansic Technologu Corp."
Device: pci 0x1083
SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
SubDevice: pci 0x7680
Revision: 0xc0
Memory Range: 0xfe400000-0xfe43ffff (rw,non-prefetchable)
I/O Ports: 0xe000-0xefff (rw)
IRQ: 11 (no events)
Module Alias: "pci:v00001969d00001083sv00001462sd00007680bc02sc00 i00"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #16 (PCI bridge)

My motherboard without pci-slot for add EthernetLanCard.

Serg

malcolmlewis
08-May-2012, 15:55
Hi
So the driver for that card is the atl1c

Can you check if it's there;


/sbin/modinfo atl1c

skoltogyan
10-May-2012, 06:35
Hi
So the driver for that card is the atl1c

Can you check if it's there;


/sbin/modinfo atl1c


sles10sp4 - without this module.

Serg

enovaklbank
10-May-2012, 08:38
It seems you have to upgrade to SLES11 (SP2) in order to use this nic. I don't have any experiences with it though.

skoltogyan
10-May-2012, 12:06
Ok.
At this time use opensuse12.1 for test..

Serg

ciriarte
12-May-2012, 12:46
SLES11 SP2 doesn't include atl1c module...

ciriarte
12-May-2012, 13:10
SLES11 SP2 doesn't include atl1c module...

Well, it's included in the SLES11-Extras repo, not on the original media...

malcolmlewis
12-May-2012, 13:14
SLES11 SP2 doesn't include atl1c module...



Hi
You need to enable the SLES11-Extras repository and install the
kernel-{flavor}-extras package, eg for my system;


zypper if kernel-pae-extra

Information for package kernel-pae-extra:

Repository: SLES11-Extras
Name: kernel-pae-extra
Version: 3.0.26-0.7.6

/sbin/modinfo atl1c
filename: /lib/modules/3.0.26-0.7-pae/kernel/drivers/net/atl1c/atl1c.ko
version: 1.0.1.0-NAPI
license: GPL
description: Atheros 1000M Ethernet Network Driver
author: Jie Yang <jie.yang@atheros.com>
srcversion: 9D861EC4CB57F0850891733
alias: pci:v00001969d00001083sv*sd*bc*sc*i*


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
up 16:22, 4 users, load average: 0.02, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU