PDA

View Full Version : ncpmount sles10



tolikk
11-May-2012, 06:53
Hi,

server sles10sp3
client sles10sp3

for client:

ncpmount -A 10.55.55.55 -U ap -P xxxxxxxxxxxxxxxxxxx 10.55.55.55 /mnt/s_mnt

cd /mnt/s_mnt/Common

s2:/mnt/s_mnt/Common # ls
[0411][0430][043d][043a] [043f][0440][0430][0432][043e][0432][044b][0445] [0430][043a][0442][043e][0432]
[0420][0435][0433][0438][043e][043d][0430][043b][044c][043d][044b][0435] [0430][043d][0442][0438][043d][0430][0440][043a][043e][0442][0438][0447][0435][0441][043a][0438][0435] [043f][0440][043e][0433][0440][0430][043c][043c][044b]
s2:/mnt/s_mnt/Common #

codepage?
iocharset?

more?

Magic31
14-May-2012, 09:00
Hi,

server sles10sp3
client sles10sp3

for client:

ncpmount -A 10.55.55.55 -U ap -P xxxxxxxxxxxxxxxxxxx 10.55.55.55 /mnt/s_mnt

cd /mnt/s_mnt/Common

s2:/mnt/s_mnt/Common # ls
[0411][0430][043d][043a] [043f][0440][0430][0432][043e][0432][044b][0445] [0430][043a][0442][043e][0432]
[0420][0435][0433][0438][043e][043d][0430][043b][044c][043d][044b][0435] [0430][043d][0442][0438][043d][0430][0440][043a][043e][0442][0438][0447][0435][0441][043a][0438][0435] [043f][0440][043e][0433][0440][0430][043c][043c][044b]
s2:/mnt/s_mnt/Common #

codepage?
iocharset?

more?

Hi,

I take it the "server sles10sp3" is running OES2 SP3 on top?

I think there is also a 10.55.55.55 to many in your ncpmount command, have you tried it like:

ncpmount -A 10.55.55.55 -U ap -P xxxxxxxxxxxxxxxxxxx ] /mnt/s_mnt

Also please post the output out 'mount' (with the ncpmount active)

Cheers,
Willem

tolikk
15-May-2012, 04:59
Yes, server sles10sp3 & OES2sp2a (sorry)

Command
ncpmount -A 10.55.55.55 -U ap -P xxxxxxxxxxxxxxxxxxx /mnt/s_mnt
not worked, error
ncpmount: Unknown user (0x89FC) in find_conn_spec

Worked command
ncpmount -A 10.55.55.55 -U ap -P xxxxxxxxxxxxxxxxxxx 10.55.55.55 /mnt/s_mnt

s2:~/bin # mount
/dev/xvda1 on / type reiserfs (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/xvda3 on /var type reiserfs (rw,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw)
10.55.55.55/AP on /mnt/s_mnt type ncpfs (rw)
s2:~/bin #

tolikk
15-May-2012, 05:15
s2:~/bin # rpm -qf /usr/bin/ncpmount
ncpfs-2.2.6-24.10

enovaklbank
16-May-2012, 14:19
So you use the address as a servername? Try -S servername instead.

tolikk
17-May-2012, 02:17
ncpmount -A 10.55.55.55 -S s -U ap -P xxxxxxxxxxxxxxxxxxx 10.55.55.55 /mnt/s_mnt

s2:~ # mount
/dev/xvda1 on / type reiserfs (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/xvda3 on /var type reiserfs (rw,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw)
S/AP on /mnt/s_mnt type ncpfs (rw)
s2:~ #

Мount is fine.
Problem is encoded for client in Cyrillic in file names and directories on server.

s2:~ # ls -la /mnt/s_mnt/COMMON
total 861
drwxr-xr-x 1 root root 512 Oct 14 2011 .
drwxr-xr-x 1 root root 512 Jan 1 1986 ..
-rwxr-xr-x 1 root root 876796 Jan 12 2007 7z444a2.exe
drwxr-xr-x 1 root root 512 Oct 14 2011 [0411][0430][043d][043a] [043f][0440][0430][0432][043e][0432][044b][0445] [0430][043a][0442][043e][0432]
drwxr-xr-x 1 root root 512 Oct 14 2011 [0420][0435][0433][0438][043e][043d][0430][043b][044c][043d][044b][0435] [0430][043d][0442][0438][043d][0430][0440][043a][043e][0442][0438][0447][0435][0441][043a][0438][0435] [043f][0440][043e][0433][0440][0430][043c][043c][044b]
drwxr-xr-x 1 root root 512 Oct 14 2011 dump
drwxr-xr-x 1 root root 512 Oct 14 2011 otchet
s2:~ #

Magic31
17-May-2012, 07:37
Мount is fine.
Problem is encoded for client in Cyrillic in file names and directories on server.


Ok, got a chance to dive into some old notes (thank god for the search feature in Vibe :P)

There I found the following command that I once needed to properly mount to a NetWare Cluster node (I think it was something a derived from an old CoolSolution article... anyway):



mount -t ncp -o tcp,ipserver=[servername],codepage=cp850,passwd=***,noupcasepasswd,volume=[volume name], [servername]/[user].[context] /[mountpoint]


As it contains a codepage entry... it might be what you are looking for. Could be the codepage set on your Novell server is different and you need to match it.

Cheers,
Willem

tolikk
17-May-2012, 08:56
Mount Novell Netware 5.1 - 6.5 - codepage is known
command
ncpmount -A 10.44.44.44 -U ap -P xxxxxxxxxxxxxxxxxxxxxxxxxx -o iocharset=utf8,owner=root,uid=root,gid=root,
filemode=666,dirmode=777,codepage=cp866,multiple 10.44.44.44 /mnt/nw_mnt
it work (and cyrillic filenames and directories)

ncpmount SLES10sp3&OES2sp2a codepage - problem
ncpmount -A 10.55.55.55 -U ap -P xxxxxxxxxxxxxxxxxxxxxxxxxx -o iocharset=utf8,owner=root,uid=root,gid=root,
filemode=666,dirmode=777,codepage=utf8,multiple 10.55.55.55 /mnt/s_mnt
cyrillic filenames and directories - ... [0411][0430][043d][043a] [043f][0440][0430][0432][043e][0432][044b][0445] [0430][043a][0442][043e][0432] ...

iocharset=?
codepage=?

Magic31
17-May-2012, 09:27
No idea what happened to your post.... Don't understand fully... but it seems the utf8 encoding is messing stuff up?

What OS and patchlevel is the Novell server you are mounting to? If it's pre 6.0 and latest patches have not been applied... could be something there.

Also see this TID that might be related: http://www.novell.com/support/kb/doc.php?id=7001283

Curios, why are you using code page 866? The default code pages on NetWare can be (depending on version) 437 (older) and 850 (newer) IIRC.

Cheers,
Willem

tolikk
17-May-2012, 10:17
client computer - several linux (and SLES10sp3), server - Novell NetWare 6.5 (old server); ncpmount - not problem for command: ncpmount ... -o codepage=cp866 ...


client computer - several linux and SLES10sp3, server - SLES10sp3&OES2sp2a (new test server); ncpmount - problem view for Cyrillic filenames and directories

tolikk
17-May-2012, 10:23
Is there another way to connect Linux computers to the server SLES10&OES2 except the ncpmount?

Magic31
17-May-2012, 14:51
Is there another way to connect Linux computers to the server SLES10&OES2 except the ncpmount?

Sure & good question: NFS, CIFS/Samba, SFTP (over SSH), FTP being the ones that come to mind directly... depends on what you are planning to do with the data on the OES server.

From all the options configuring CIFS on the OES server would be the simplest in my mind, as also file locking (and cross protocol locking, when talking a recent OES version) mechanisms are in place which is usually a good idea to have.
If your data is on NSS volumes, having CIFS means transparent access as the login and rights granted on the CIFS share are equal to those you would get when logged in and coming from NCP side (Novell Client).

Cheers,
Willem

tolikk
18-May-2012, 01:28
Thank you, I will try alternative ways to mount volumes OES2 server

Magic31
18-May-2012, 06:29
What OS and patchlevel is the Novell server you are mounting to? If it's pre 6.0 and latest patches have not been applied... could be something there.

Duh... sorry about that question, as you had already stated that in the opening post :) Got my wires crossed with the NetWare bits posted....

Let us know how you go with the alternatives.

Cheers,
Willem

tolikk
21-May-2012, 08:10
I am install novell-client 2.0.1

Mount:
nwlogin -u ap -p xxxxxxxxxxxxxxxxx -t 10.55.55.55 -s 10.55.55.55 -c sys

Mount and codepage - OK.

List of rights from mount directory drwx------, files rwx------.
question: how to set a list of rights to mount catalogs of 770 (rwxrwx---)?