PDA

View Full Version : solved: SLES 11 sp2 probing edd hang



duanev22
21-May-2012, 18:38
The SLES 11 sp2 autoyast install reboots more than once. Although edd=off can be added to the initial pxelinux kernel command line, this parameter is not forwarded to the intermediate boots before the final system bring up. On a certain Dell 12G PowerEdge servers the system will hang when probing EDD during these intermediate reboots. The following workaround allows an autoyast based install to complete in this situation:

<scripts>
<chroot-scripts config:type="list">
<script>
<interpreter>shell</interpreter>
<filename>eddoff.sh</filename>
<notification>Appending kernel command line parameters ... </notification>
<source><![CDATA[
#!/bin/bash
sed -e '/root=/s/$/ edd=off/' < /mnt/boot/grub/menu.lst > /tmp/menu.lst
cp /tmp/menu.lst /mnt/boot/grub/menu.lst
]]>
</source>
</script>
</chroot-scripts>
</scripts>

Automatic reply
31-May-2012, 13:30
duanev22,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com