PDA

View Full Version : Errors restoring repository configuration



casem
08-Jun-2012, 00:14
Hello there. When I open YaST and launch the "Software Repositories" tool, I get the following message:



There were errors while restoring the repository configuration.
Parse error: repoindex.xml[15] Opening and ending tag mismatch: link line 12 and head

Not sure if this is helpful, but when I run the following command:

zypper lr -d

I get this output:


# | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
--+---------------------------------------+---------------------------------------+---------+---------+----------+----------+----------------------------------------------------------------------------------+--------
1 | HP-Education Updates | HP-Education Updates | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/isv://hp://education/SLE_11 |
2 | Mozilla | Mozilla | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.1/ |
3 | PK_TMP_DIR | PK_TMP_DIR | Yes | Yes | 99 | plaindir | dir:///var/tmp/TmpDir.tYSCMX |
4 | SLED-11-SP2-DVD1 | SLED-11-SP2-DVD1 | Yes | Yes | 99 | yast2 | iso:///?iso=SLED-11-SP2-DVD-x86_64-GM-DVD1.iso&url=file:///home/casem/yastrepos/ |
5 | SLED-11-SP2-DVD2 | SLED-11-SP2-DVD2 | Yes | Yes | 99 | yast2 | iso:///?iso=SLED-11-SP2-DVD-x86_64-GM-DVD2.iso&url=file:///home/casem/yastrepos/ |
6 | SUSE-Linux-Enterprise-Desktop-11 11-0 | SUSE-Linux-Enterprise-Desktop-11 11-0 | No | No | 99 | yast2 | hd:///sled11.00?device=/dev/sda1&filesystem=auto |
7 | nVidia-Driver-SLE11-SP1 | nVidia-Driver-SLE11-SP1 | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/novell/sle11sp1

How can I fix this error?

malcolmlewis
08-Jun-2012, 00:32
Hello there. When I open YaST and launch the "Software Repositories"
tool, I get the following message:

>
> There were errors while restoring the repository configuration.
> Parse error: repoindex.xml[15] Opening and ending tag mismatch: link
> line 12 and head

Not sure if this is helpful, but when I run the following command:
> zypper lr -d

I get this output:
>
> # | Alias |
> Name | Enabled | Refresh | Priority | Type | URI
> | Service
> --+---------------------------------------+---------------------------------------+---------+---------+----------+----------+----------------------------------------------------------------------------------+--------
> 1 | HP-Education Updates | HP-Education
> Updates | Yes | Yes | 99 | rpm-md |
> http://download.opensuse.org/repositories/isv://hp://education/SLE_11
> |
> 2 | Mozilla |
> Mozilla | Yes | Yes | 99 | rpm-md |
> http://download.opensuse.org/repositories/mozilla/openSUSE_11.1/
> |
> 3 | PK_TMP_DIR |
> PK_TMP_DIR | Yes | Yes | 99 | plaindir |
> dir:///var/tmp/TmpDir.tYSCMX
> |
> 4 | SLED-11-SP2-DVD1 |
> SLED-11-SP2-DVD1 | Yes | Yes | 99 | yast2 |
> iso:///?iso=SLED-11-SP2-DVD-x86_64-GM-DVD1.iso&url=file:///home/casem/yastrepos/
> |
> 5 | SLED-11-SP2-DVD2 |
> SLED-11-SP2-DVD2 | Yes | Yes | 99 | yast2 |
> iso:///?iso=SLED-11-SP2-DVD-x86_64-GM-DVD2.iso&url=file:///home/casem/yastrepos/
> |
> 6 | SUSE-Linux-Enterprise-Desktop-11 11-0 |
> SUSE-Linux-Enterprise-Desktop-11 11-0 | No | No | 99 |
> yast2 |
> hd:///sled11.00?device=/dev/sda1&filesystem=auto |
> 7 | nVidia-Driver-SLE11-SP1 |
> nVidia-Driver-SLE11-SP1 | Yes | Yes | 99 | rpm-md |
> http://download.nvidia.com/novell/sle11sp1

How can I fix this error?



Hi
Delete the tmp repository and remove the system from the Novell
Customer Center and re-register it.

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
up 5:12, 4 users, load average: 0.02, 0.14, 0.47
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

casem
08-Jun-2012, 21:22
Thanks for your help!

I ran into some issues while trying to re-register, but I came across this article which was also helpful: http://www.novell.com/support/kb/doc.php?id=3303599