PDA

View Full Version : how to install apache mpm-itk from build service?



raphael01
10-Jun-2012, 02:40
Hi All,

I want to run Apache2 with the itk mpm instead of prefork; I'm running SLES 11 SP2 on amazon EC2. I noticed the itk package wasn't in the yast default software repo so I did a search and it turned up at http://software.opensuse.org/package/apache2-itk If you scroll down the page, there is a version built for SLES 11 SP2.

The problem is, currently the version of apache used by SLES 11 SP2 is apache 2.2.12, and the mpm-itk package is for apache 2.2.22.

Is there way to get mpm-itk installed on my system without replacing the entire apache, mod_php, etc with the 2.2.22 versions from the build service? Maybe a way I can get the build service to build against apache 2.2.12?

Otherwise I suppose I can download the apache 2.2.12 source rpm, apply the itk patches, and enjoy... right?

malcolmlewis
10-Jun-2012, 03:43
Hi All,

I want to run Apache2 with the itk mpm instead of prefork; I'm running
SLES 11 SP2 on amazon EC2. I noticed the itk package wasn't in the yast
default software repo so I did a search and it turned up at
http://software.opensuse.org/package/apache2-itk If you scroll down the
page, there is a version built for SLES 11 SP2.

The problem is, currently the version of apache used by SLES 11 SP2 is
apache 2.2.12, and the mpm-itk package is for apache 2.2.22.

Is there way to get mpm-itk installed on my system without replacing
the entire apache, mod_php, etc with the 2.2.22 versions from the build
service? Maybe a way I can get the build service to build against
apache 2.2.12?

Otherwise I suppose I can download the apache 2.2.12 source rpm, apply
the itk patches, and enjoy... right?



Hi
Since 'The "ITK" MPM (Multi-Processing Module) is experimental and NOT
officially endorsed by the Apache Software Foundation, so it may or may
not work as expected.'

You might as well upgrade to 2.2.22? Just add the apache repository?
http://download.opensuse.org/repositories/Apache/SLE_11_SP2/

YMMV with respect to security fixes...

--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
up 6:01, 3 users, load average: 0.06, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

raphael01
10-Jun-2012, 06:20
Thanks, that worked nicely and solved all the dependencies with no headaches. Next question: how did you know the url of the apache repository? Does one just browse around at http://download.opensuse.org/repositories/ until they find their desired software and platform?

malcolmlewis
10-Jun-2012, 06:47
Thanks, that worked nicely and solved all the dependencies with no
headaches. Next question: how did you know the url of the apache
repository? Does one just browse around at
http://download.opensuse.org/repositories/ until they find their desired
software and platform?



Hi
Just knowledge of the Open Build Service (I do a little bit of
packaging/maintaining on the openSUSE side).

If you use the search feature here and select your distribution
(little spanner to the right of search) and click on the 'show unstable
packages'.

Then click on the Apache name and it will take you to the
Open Build Service project for that package.

Check the package information for the "Devel package for
openSUSE:Factory" this will ensure it's maintained.... ;)

Then in the 'Build Results' to the right click on the distribution name
eg SLE_11_SP2 and this will take you to the list of rpms built, but it
also has a link at the top 'Go to download repository' which will give
you the URL to add as a repository.

I would recommend this way rather that just a 1-click install....


--
Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.1 (x86_64) Kernel 3.1.10-1.9-desktop
up 8:58, 3 users, load average: 0.10, 0.06, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

raphael01
11-Jun-2012, 18:59
Thanks for the info.

Unfortunately, apache from the build service won't run, it says there is an undefined symbol 'apr_list_maintain'.

So, it looks like there is an apache recompile in my future, regardless if I use mpm-itk or suexec :(

Thank you for your help, maybe I'll add it to the build service if I'm successful