PDA

View Full Version : SLES 11 SP3 Upgrading glibc in SLES 11



pcperera
18-Feb-2018, 03:46
Hi all,

We have SLES 11 (x86_64) patch = 3.

We have a requirement to install an application which links glibc-2.15.

Is it safe to upgrade glibc to 2-15 ? What's the procedure to follow ? Will there be any backward compatibility issues ?

Thanks
Priyanka

smflood
18-Feb-2018, 22:42
pcperera Wrote in message:

> We have SLES 11 (x86_64) patch = 3.
>
> We have a requirement to install an application which links glibc-2.15.
>
> Is it safe to upgrade glibc to 2-15 ? What's the procedure to follow ?
> Will there be any backward compatibility issues ?

Firstly note that SLES11 SP3 is now out of support with SLES11 SP4
the latest release of SLES11 available.

However both SLES11 SP3 and SP4 include glibc-2.11. If you want
glibc >= 2.15 you should upgrade to SLES12 with SLES12 SP3 being
the latest SLES12 available. You will have problems if you try to
upgrade glibc in SLES11 SP3 to a version later than is available
from SUSE.

HTH.
--
Simon Flood
SUSE Knowledge Partner


----Android NewsGroup Reader----
http://usenet.sinaapp.com/