PDA

View Full Version : SLED 12 SP3 Can no longer run latest R lang



susegecko111
19-Feb-2018, 21:41
Followed the instructions, from here to install the latest R: https://cran.rstudio.com/bin/linux/suse/

Basically:



sudo zypper addrepo -f \
http://download.opensuse.org/repositories/devel:/languages:/R:/patched/SLE_12/ \
R-base
sudo zypper in R-base


Unfortunately, as of today 2/19/2018, this command no longer works. It is looking for a new xdg-utils



Problem: nothing provides xdg-utils needed by R-patched-3.4.3-798.1.x86_64
Solution 1: do not ask to install a solvable providing R-base
Solution 2: break R-patched-3.4.3-798.1.x86_64 by ignoring some of its dependencies


Installing `R-core` is also broken. It is looking for libcairo:



Problem: nothing provides libcairo.so.2()(64bit) needed by R-core-3.4.3-798.1.x86_64
Solution 1: do not install R-core-3.4.3-798.1.x86_64
Solution 2: break R-core-3.4.3-798.1.x86_64 by ignoring some of its dependencies

malcolmlewis
20-Feb-2018, 02:22
Hi
You would need to take it up with the OBS maintainers for R....
https://build.opensuse.org/project/users/devel:languages:R:patched

I don't see an R-base being built either?
https://build.opensuse.org/package/binaries/devel:languages:R:patched/R?repository=SLE_12

They should be building against SLE 12 Backports as well, this may resolve the issue...