PDA

View Full Version : SLES 11 SP4 please clean your RPM directory



MelD
22-Feb-2018, 02:49
Hi,

I am getting the following error while trying to install SAP Business One Server Tools on Suse 11, PL4:

"More than one version of rpm files detected in RPM directory 9.3012002-0 , please clean your RPM directory.


I caused this problem because I needed to install python-crypto and python-ssl and I followed this instructions at this link:

https://www.suse.com/support/kb/doc/?id=7015337

This python-crypto now seems to be installed in YaST2 but I don't see the python-ssl.

Does anyone know how to "clean your RPM directory".

Thanks for any help.

malcolmlewis
22-Feb-2018, 04:58
On Thu 22 Feb 2018 01:54:01 AM CST, MelD wrote:

Hi,

I am getting the following error while trying to install SAP Business
One Server Tools on Suse 11, PL4:

"More than one version of rpm files detected in RPM directory
9.3012002-0 , please clean your RPM directory.


I caused this problem because I needed to install python-crypto and
python-ssl and I followed this instructions at this link:

https://www.suse.com/support/kb/doc/?id=7015337

This python-crypto now seems to be installed in YaST2 but I don't see
the python-ssl.

Does anyone know how to "clean your RPM directory".

Thanks for any help.




Hi
Maybe rebuild that rpm and zypper databases?



rpm --rebuilddb
zypper clean -a


--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.3|GNOME 3.20.2|4.4.114-42-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

smflood
22-Feb-2018, 12:18
On 22/02/18 01:54, MelD wrote:

> I am getting the following error while trying to install SAP Business
> One Server Tools on Suse 11, PL4:
>
> "More than one version of rpm files detected in RPM directory
> 9.3012002-0 , please clean your RPM directory.

Are you trying to install on "regular" SLES11 SP4 or SLES for SAP
Applications 11 SP4? Please can you post the output from "cat
/etc/*release".

> I caused this problem because I needed to install python-crypto and
> python-ssl and I followed this instructions at this link:
>
> https://www.suse.com/support/kb/doc/?id=7015337
>
> This python-crypto now seems to be installed in YaST2 but I don't see
> the python-ssl.

It's my understanding that SLES for SAP Applications provides everything
needed to install SAP software on SLES.

Please also note that there is dedicated SUSE forum for issues relating
to SLES for SAP Applications at
https://forums.suse.com/forumdisplay.php?41-SLES-SAP-Applications .

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

Jee1971
12-Nov-2018, 10:48
On 22/02/18 01:54, MelD wrote:

> I am getting the following error while trying to install SAP Business
> One Server Tools on Suse 11, PL4:
>
> "More than one version of rpm files detected in RPM directory
> 9.3012002-0 , please clean your RPM directory.

Are you trying to install on "regular" SLES11 SP4 or SLES for SAP
Applications 11 SP4? Please can you post the output from "cat
/etc/*release".

> I caused this problem because I needed to install python-crypto and
> python-ssl and I followed this instructions at this link:
>
> https://www.suse.com/support/kb/doc/?id=7015337
>
> This python-crypto now seems to be installed in YaST2 but I don't see
> the python-ssl.

It's my understanding that SLES for SAP Applications provides everything
needed to install SAP software on SLES.

Please also note that there is dedicated SUSE forum for issues relating
to SLES for SAP Applications at
https://forums.suse.com/forumdisplay.php?41-SLES-SAP-Applications .

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

I'm afraid there is a small misunderstanding, the question is about SAP Business One. For Business One, the SLES for SAP applications in not applicable. I understand this is very confusing.

SAP Business One can be installed on regular SLES environment or with SLES with SAP Business One Installer (slesb1hana).

Unfortunately I never ran into this issue, but it looks like Malcolms answer could help. Can TS react on that?

Jeroen van de Waart
Channel Enablement & Solution Expert SAP Business One
Benelux