PDA

View Full Version : SLES 11 SP3 Patching best practices - when upgrading SP level



kjhurni
02-Mar-2018, 20:28
Let's say I have a bunch of SLES 11 SP3 XEN Dom0 (hosts)
That are running a bunch of SLES 11 SP3 paravirtualized DomU (guests)

I *thought* (but can't seem to find either way) that if you want to patch to SLES 11 SP4 (for example) that you should do the Dom0 (host) first and then the guests?

Or is it the other way around?

Or doesn't it matter? (from an official support perspective that is).

I vaguely recall one time I did a DomU first (SLES 10 mind you) and it went horrible and wouldn't boot until I upgraded the host. But that was SLES 10

KBOYLE
07-Mar-2018, 20:40
kjhurni wrote:

> Let's say I have a bunch of SLES 11 SP3 XEN Dom0 (hosts)
> That are running a bunch of SLES 11 SP3 paravirtualized DomU (guests)
>
> I thought (but can't seem to find either way) that if you want to
> patch to SLES 11 SP4 (for example) that you should do the Dom0 (host)
> first and then the guests?

Hi Kevin,

That is the way it has always been done:
- Update Dom0 first then DomUs
- DomU cannot be a newer SLES version that used for Dom0

Please check but I believe that rule has now been relaxed. I'm not sure
which SLES11 SP (3 or 4?) first provided this capability.
For example, I believe a SLES11 SP4 Dom0 cam now run a SLES12 DomU.


--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below this post.
Thank you.

kjhurni
09-Mar-2018, 16:13
kjhurni wrote:

> Let's say I have a bunch of SLES 11 SP3 XEN Dom0 (hosts)
> That are running a bunch of SLES 11 SP3 paravirtualized DomU (guests)
>
> I thought (but can't seem to find either way) that if you want to
> patch to SLES 11 SP4 (for example) that you should do the Dom0 (host)
> first and then the guests?

Hi Kevin,

That is the way it has always been done:
- Update Dom0 first then DomUs
- DomU cannot be a newer SLES version that used for Dom0

Please check but I believe that rule has now been relaxed. I'm not sure
which SLES11 SP (3 or 4?) first provided this capability.
For example, I believe a SLES11 SP4 Dom0 cam now run a SLES12 DomU.


--
Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below this post.
Thank you.

Thanks Kevin.

I did find in the docs under "supported guests", so it basically implied that you would have to upgrade the Host first (at least for the SLES11 SPxx stuff)

For example, the SLES11 SP2 docs stated that you could only run a SLES 11 SP2 guest (and not higher), and then if you looked at the SLES11 SP4, it listed SLES11 SP4 guests (among others).

Thanks again!