PDA

View Full Version : SLES 12 SP3 Autofs - USB automount file permissions incorrect



sdrake1
07-Mar-2018, 17:21
On SLES12 SP3 automount is on by default. When I insert a DVD containing HP Proliant Service Pack, the dvd is auto mounted, I can change to the /run/media/root/SPP<version> directory and execute launch_sum.sh since its permissions are 744. In fact all files on the DVD have permissions 744 and all directories are 777. The same iso (HP Service Pack) on a USB Stick (written via HP USB Drive Key Utililty) also will automount. But the file permissions for launch_sum.sh are 644 and will not execute (permission denied). All files on the USB device have permissions 644 except for launch_sum.bat which is 755 (this is the start script for use on windows systems). The mount command shows the USB stick is mounted with fmask=0022 and dmask=0077 but those values seem to be ignored. If I unmount the usb device, then manually mount it: mount /dev/sdc /mnt then the permissions are as expected and launch_sum.sh can be executed. I've been trying to use /etc/auto.master and /etc/auto.misc to control autofs but have had no success. I removed the mount entry for the cd in auto.misc but it seemed to have no effect and I suspect not even being used. The Admin Guide has lots of information on autofs, but nothing dealing specifically with usb devices. Has anyone tried changing usb automount behavior and succeeded?

Automatic Reply
12-Mar-2018, 05:30
sdrake1,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- Open a service request: https://www.suse.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot..

Good luck!

Your SUSE Forums Team
http://forums.suse.com

sdrake1
12-Mar-2018, 18:52
Getting closer. Found that by creating 99-udisk2.rules in /etc/udev/rules.d/ I can alter the location of the usb automount from /run/media/<user>/ to somewhere else, i.e. /media/. Just have to figure out how to change the file permissions of this automount, MODE=0777 has no effect.

jmozdzen
22-Mar-2018, 18:09
Hi,

have you checked if the "noexec" option is set for those auto-mounted file systems?

Regards,
J

sdrake1
30-Mar-2018, 19:33
Yes, noexec is on for the automounts. Can't find anyway to disable it or affect the mount parameters in any way.