PDA

View Full Version : SLES 12 SP3 VLC Install fails



ronanb78
26-Mar-2018, 15:33
Hi,

I am trying to install VLC on SuSE 12 SP3 but i get the following error:

Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP3_x86_64'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libaa.so.1()(64bit) needed by vlc-2.2.4-238.1.x86_64
Solution 1: do not install vlc-2.2.4-238.1.x86_64
Solution 2: break vlc-2.2.4-238.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

Does anybody have any ideas on how to resolve this?

Thanks

malcolmlewis
26-Mar-2018, 17:21
Hi,

I am trying to install VLC on SuSE 12 SP3 but i get the following error:

Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP3_x86_64'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libaa.so.1()(64bit) needed by vlc-2.2.4-238.1.x86_64
Solution 1: do not install vlc-2.2.4-238.1.x86_64
Solution 2: break vlc-2.2.4-238.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

Does anybody have any ideas on how to resolve this?

Thanks
Hi and welcome to the Forum :)
Where are you trying to install VLC from?

Can you show the list of configured repositories with;


zypper lr -d

ronanb78
27-Mar-2018, 12:18
Thank you for replying :)
Sorry, I was not very clear with providing all the information. I am trying to install it from http://download.videolan.org/pub/vlc/SuSE/SLE12

# zypper lr -d
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
--+-------------------------------------------------------------------------+------------------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+-------------------------------------------
1 | SLES12-SP3-12.3-0 | SLES12-SP3-12.3-0 | Yes | (r ) Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-VMware_Virtual_SATA_CDRW_Drive_0000000000000000000 1 |
2 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Pool | SLES12-SP3-Debuginfo-Pool | No | ---- | ---- | 99 | NONE | https://updates.suse.com/SUSE/Products/SLE-SERVER/12-SP3/x86_64/product_debug?NTR4Y0W-s0CdGDX3RPBSIRsEAtD2pkBEiK2zxkmeuKJdRq7L2dAFmgxtR9 _KKa5pPoGIIasLXy5Z-osBFTtZiqCQKHpRHlMnGf3BOmR8SKsArY5HHNruY0OlTAERTlX bPMUv-6b79NZBrcStK5KF0CKtQA | SUSE_Linux_Enterprise_Server_12_SP3_x86_64
3 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Updates | SLES12-SP3-Debuginfo-Updates | No | ---- | ---- | 99 | NONE | https://updates.suse.com/SUSE/Updates/SLE-SERVER/12-SP3/x86_64/update_debug?bQwBnUjWokcAAAAAXpqTn5gOuw9XZqJB8H3hD xFrAHX-dFUbAeMQ4_R5gD5DHh4npYl8P9wsQ6y5LzX6ptRD-gNKakpRFcKSYRFGrd4dsIkkwc6JPFw7bGWL9moNKJptDYZ6d0z yeadLdG51mM1t1Wo | SUSE_Linux_Enterprise_Server_12_SP3_x86_64
4 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Pool | SLES12-SP3-Pool | Yes | (r ) Yes | No | 99 | rpm-md | https://updates.suse.com/SUSE/Products/SLE-SERVER/12-SP3/x86_64/product?IqrTEkc2q0i1yY7lwNGX0QPyIwxaU02LrWtz5wq9ET nUPAB57Q9pm7pnL0E1_ZawqxAL2k_OD0ac0KIzK-MTcLVzYndx_bObSql9DgHTo0Q-YI7fjP6ZYPpyajly7Ni8WhC_DI_s-7zD4ju16Q | SUSE_Linux_Enterprise_Server_12_SP3_x86_64
5 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Source-Pool | SLES12-SP3-Source-Pool | No | ---- | ---- | 99 | NONE | https://updates.suse.com/SUSE/Products/SLE-SERVER/12-SP3/x86_64/product_source?SS5hcSkcsjS7h-V9C3mtLAHTRV63QGuwKapUdn-RuBAiPum6iTeiywar3lq536sUpTuLslFhGe_SeRgRaoImSdEgq P3Y4yDc_F1VqoU4tal9ZzD2u_nHGReg4-5Gh4rX3le_fXlleEp1cs8P9Q8Ox4ShRWw | SUSE_Linux_Enterprise_Server_12_SP3_x86_64
6 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Updates | SLES12-SP3-Updates | Yes | (r ) Yes | Yes | 99 | rpm-md | https://updates.suse.com/SUSE/Updates/SLE-SERVER/12-SP3/x86_64/update?ZEDMoC94h3niPpUcbYzic8GLapCJg-zCKIwCJ44Lzx2IrqIuMDWYqpwZMbs7cz7cqq3D2peeRBLM-LHNyQwryQEbwY_3zb19nO44bH1GNCcAu_J7tVaUk8hENhrYau-ojdnXxnGuHihiA58 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64
7 | VLC | VLC | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.videolan.org/pub/vlc/SuSE/SLE12 |
8 | science | Software for Scientists and Engineers (SLE_12) | Yes | (r ) Yes | No | 99 | rpm-md | http://download.opensuse.org/repositories/science/SLE_12/ |
#


# cat /etc//SuSE-release
SUSE Linux Enterprise Server 12 (x86_64)
VERSION = 12
PATCHLEVEL = 3
# This file is deprecated and will be removed in a future service pack or release.
# Please check /etc/os-release for details about this release.
#

malcolmlewis
27-Mar-2018, 13:26
Hi
You need to add the free SLE SDK repository to get libaa1;


SUSEConnect --list-extensions

SUSEConnect -p sle-sdk/12.3/x86_64


You might want to add the Videolan repo (temporarily) as well as it may want a few packages from there.

ronanb78
27-Mar-2018, 14:16
Hi,

It looks like the SDK is already installed:

# SUSEConnect --list-extensions
AVAILABLE EXTENSIONS AND MODULES


FREE EXTENSIONS

Web and Scripting Module 12 x86_64
Install with: SUSEConnect -p sle-module-web-scripting/12/x86_64

SUSE Cloud Application Platform Tools Module 12 x86_64
Install with: SUSEConnect -p sle-module-cap-tools/12/x86_64

SUSE Linux Enterprise Software Development Kit 12 SP3 x86_64 (Installed)
De-Install with: SUSEConnect -d -p sle-sdk/12.3/x86_64

Public Cloud Module 12 x86_64
Install with: SUSEConnect -p sle-module-public-cloud/12/x86_64

SUSE Package Hub 12 SP3 x86_64
Install with: SUSEConnect -p PackageHub/12.3/x86_64

Advanced Systems Management Module 12 x86_64
Install with: SUSEConnect -p sle-module-adv-systems-management/12/x86_64

Legacy Module 12 x86_64
Install with: SUSEConnect -p sle-module-legacy/12/x86_64

HPC Module 12 x86_64
Install with: SUSEConnect -p sle-module-hpc/12/x86_64

Containers Module 12 x86_64
Install with: SUSEConnect -p sle-module-containers/12/x86_64

Toolchain Module 12 x86_64 (Installed)
De-Install with: SUSEConnect -d -p sle-module-toolchain/12/x86_64


PAID EXTENSIONS

SUSE Manager for Retail 3.1 x86_64
Install with: SUSEConnect -p suse-manager-retail/3.1/x86_64 -r REGCODE

SUSE Linux Enterprise Live Patching 12 SP3 x86_64
Install with: SUSEConnect -p sle-live-patching/12.3/x86_64 -r REGCODE

SUSE Manager Server 3.1 x86_64
Install with: SUSEConnect -p SUSE-Manager-Server/3.1/x86_64 -r REGCODE

SUSE OpenStack Cloud 8 x86_64 (BETA)
Install with: SUSEConnect -p suse-openstack-cloud/8/x86_64 -r REGCODE

SUSE Enterprise Storage 5 x86_64
Install with: SUSEConnect -p ses/5/x86_64 -r REGCODE

SUSE Manager Proxy 3.2 x86_64 (BETA)
Install with: SUSEConnect -p SUSE-Manager-Proxy/3.2/x86_64 -r REGCODE

SUSE OpenStack Cloud Crowbar 8 x86_64 (BETA)
Install with: SUSEConnect -p suse-openstack-cloud-crowbar/8/x86_64 -r REGCODE

SUSE Linux Enterprise Workstation Extension 12 SP3 x86_64
Install with: SUSEConnect -p sle-we/12.3/x86_64 -r REGCODE

SUSE Manager Proxy 3.1 x86_64
Install with: SUSEConnect -p SUSE-Manager-Proxy/3.1/x86_64 -r REGCODE

SUSE Linux Enterprise Server BCL 12 SP3 x86_64
Install with: SUSEConnect -p SLES-BCL/12.3/x86_64 -r REGCODE

SUSE Manager Server 3.2 x86_64 (BETA)
Install with: SUSEConnect -p SUSE-Manager-Server/3.2/x86_64 -r REGCODE

HPE Helion OpenStack Cloud 8 x86_64 (BETA)
Install with: SUSEConnect -p hpe-helion-openstack-cloud/8/x86_64 -r REGCODE

SUSE Linux Enterprise High Availability Extension 12 SP3 x86_64
Install with: SUSEConnect -p sle-ha/12.3/x86_64 -r REGCODE

SUSE Linux Enterprise High Availability GEO Extension 12 SP3 x86_64
Install with: SUSEConnect -p sle-ha-geo/12.3/x86_64 -r REGCODE

SUSE Manager Server 3.0 x86_64
Install with: SUSEConnect -p SUSE-Manager-Server/3.0/x86_64 -r REGCODE

SUSE Manager Proxy 3.0 x86_64
Install with: SUSEConnect -p SUSE-Manager-Proxy/3.0/x86_64 -r REGCODE

SUSE Linux Enterprise Real Time 12 SP3 x86_64
Install with: SUSEConnect -p SUSE-Linux-Enterprise-RT/12.3/x86_64 -r REGCODE


MORE INFORMATION

You can find more information about available modules here:
https://www.suse.com/products/server/features/modules.html

#



Any ideas?

Rgds

malcolmlewis
27-Mar-2018, 14:55
Hi,

It looks like the SDK is already installed:

# SUSEConnect --list-extensions
AVAILABLE EXTENSIONS AND MODULES


FREE EXTENSIONS

Web and Scripting Module 12 x86_64
Install with: SUSEConnect -p sle-module-web-scripting/12/x86_64

SUSE Cloud Application Platform Tools Module 12 x86_64
Install with: SUSEConnect -p sle-module-cap-tools/12/x86_64

SUSE Linux Enterprise Software Development Kit 12 SP3 x86_64 (Installed)
De-Install with: SUSEConnect -d -p sle-sdk/12.3/x86_64

Public Cloud Module 12 x86_64
Install with: SUSEConnect -p sle-module-public-cloud/12/x86_64

SUSE Package Hub 12 SP3 x86_64
Install with: SUSEConnect -p PackageHub/12.3/x86_64

Advanced Systems Management Module 12 x86_64
Install with: SUSEConnect -p sle-module-adv-systems-management/12/x86_64

Legacy Module 12 x86_64
Install with: SUSEConnect -p sle-module-legacy/12/x86_64

HPC Module 12 x86_64
Install with: SUSEConnect -p sle-module-hpc/12/x86_64

Containers Module 12 x86_64
Install with: SUSEConnect -p sle-module-containers/12/x86_64

Toolchain Module 12 x86_64 (Installed)
De-Install with: SUSEConnect -d -p sle-module-toolchain/12/x86_64


PAID EXTENSIONS

SUSE Manager for Retail 3.1 x86_64
Install with: SUSEConnect -p suse-manager-retail/3.1/x86_64 -r REGCODE

SUSE Linux Enterprise Live Patching 12 SP3 x86_64
Install with: SUSEConnect -p sle-live-patching/12.3/x86_64 -r REGCODE

SUSE Manager Server 3.1 x86_64
Install with: SUSEConnect -p SUSE-Manager-Server/3.1/x86_64 -r REGCODE

SUSE OpenStack Cloud 8 x86_64 (BETA)
Install with: SUSEConnect -p suse-openstack-cloud/8/x86_64 -r REGCODE

SUSE Enterprise Storage 5 x86_64
Install with: SUSEConnect -p ses/5/x86_64 -r REGCODE

SUSE Manager Proxy 3.2 x86_64 (BETA)
Install with: SUSEConnect -p SUSE-Manager-Proxy/3.2/x86_64 -r REGCODE

SUSE OpenStack Cloud Crowbar 8 x86_64 (BETA)
Install with: SUSEConnect -p suse-openstack-cloud-crowbar/8/x86_64 -r REGCODE

SUSE Linux Enterprise Workstation Extension 12 SP3 x86_64
Install with: SUSEConnect -p sle-we/12.3/x86_64 -r REGCODE

SUSE Manager Proxy 3.1 x86_64
Install with: SUSEConnect -p SUSE-Manager-Proxy/3.1/x86_64 -r REGCODE

SUSE Linux Enterprise Server BCL 12 SP3 x86_64
Install with: SUSEConnect -p SLES-BCL/12.3/x86_64 -r REGCODE

SUSE Manager Server 3.2 x86_64 (BETA)
Install with: SUSEConnect -p SUSE-Manager-Server/3.2/x86_64 -r REGCODE

HPE Helion OpenStack Cloud 8 x86_64 (BETA)
Install with: SUSEConnect -p hpe-helion-openstack-cloud/8/x86_64 -r REGCODE

SUSE Linux Enterprise High Availability Extension 12 SP3 x86_64
Install with: SUSEConnect -p sle-ha/12.3/x86_64 -r REGCODE

SUSE Linux Enterprise High Availability GEO Extension 12 SP3 x86_64
Install with: SUSEConnect -p sle-ha-geo/12.3/x86_64 -r REGCODE

SUSE Manager Server 3.0 x86_64
Install with: SUSEConnect -p SUSE-Manager-Server/3.0/x86_64 -r REGCODE

SUSE Manager Proxy 3.0 x86_64
Install with: SUSEConnect -p SUSE-Manager-Proxy/3.0/x86_64 -r REGCODE

SUSE Linux Enterprise Real Time 12 SP3 x86_64
Install with: SUSEConnect -p SUSE-Linux-Enterprise-RT/12.3/x86_64 -r REGCODE


MORE INFORMATION

You can find more information about available modules here:
https://www.suse.com/products/server/features/modules.html

#



Any ideas?

Rgds
Hi
It's not in your list of repositories... try de-installing and readding the SDK, but needs to appear in the zypper lr output....

ronanb78
27-Mar-2018, 15:16
Hi,

I am unable to de-install the SDK:

AMS01-VMLZ-0033:~ # SUSEConnect -d -p sle-sdk/12.3/x86_64
Error: SCC returned 'SUSE Linux Enterprise Software Development Kit is not yet activated on the system.' (422)
AMS01-VMLZ-0033:~ #

If I run "SUSEConnect -s", I can see that the SDK is unregistered:

{"identifier":"sle-sdk","version":"12.3","arch":"x86_64","status":"Not Registered"},

Is that the cause of my problem with the VLC install, do you think?

Rgds

malcolmlewis
27-Mar-2018, 15:31
Hi,

I am unable to de-install the SDK:

AMS01-VMLZ-0033:~ # SUSEConnect -d -p sle-sdk/12.3/x86_64
Error: SCC returned 'SUSE Linux Enterprise Software Development Kit is not yet activated on the system.' (422)
AMS01-VMLZ-0033:~ #

If I run "SUSEConnect -s", I can see that the SDK is unregistered:

{"identifier":"sle-sdk","version":"12.3","arch":"x86_64","status":"Not Registered"},

Is that the cause of my problem with the VLC install, do you think?

Rgds
Hi
It would appear so, try a clean up and see if that helps;


zypper clean -a
zypper ref -f
zypper lr

Does the SDK pool and update repos appear?

ronanb78
27-Mar-2018, 15:42
Hi,

I tried the clean up but the SDK repo still does not appear:

# zypper clean -a
All repositories have been cleaned up.
# zypper ref -f
Forcing raw metadata refresh
Retrieving repository 'SLES12-SP3-12.3-0' metadata .................................................. .................................................. .................................................[done]
Forcing building of repository cache
Building repository 'SLES12-SP3-12.3-0' cache .................................................. .................................................. .................................................. ....[done]
Forcing raw metadata refresh
Retrieving repository 'SLES12-SP3-Pool' metadata .................................................. .................................................. .................................................. .[done]
Forcing building of repository cache
Building repository 'SLES12-SP3-Pool' cache .................................................. .................................................. .................................................. ......[done]
Forcing raw metadata refresh
Retrieving repository 'SLES12-SP3-Updates' metadata .................................................. .................................................. ................................................[done]
Forcing building of repository cache
Building repository 'SLES12-SP3-Updates' cache .................................................. .................................................. .................................................. ...[done]
Forcing raw metadata refresh
Retrieving repository 'VLC' metadata .................................................. .................................................. .................................................. .............[done]
Forcing building of repository cache
Building repository 'VLC' cache .................................................. .................................................. .................................................. ..................[done]
Forcing raw metadata refresh
Retrieving repository 'Software for Scientists and Engineers (SLE_12)' metadata .................................................. .................................................. ....................[done]
Forcing building of repository cache
Building repository 'Software for Scientists and Engineers (SLE_12)' cache .................................................. .................................................. .........................[done]
All repositories have been refreshed.
# zypper lr
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias | Name | Enabled | GPG Check | Refresh
--+-------------------------------------------------------------------------+------------------------------------------------+---------+-----------+--------
1 | SLES12-SP3-12.3-0 | SLES12-SP3-12.3-0 | Yes | (r ) Yes | No
2 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Pool | SLES12-SP3-Debuginfo-Pool | No | ---- | ----
3 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Updates | SLES12-SP3-Debuginfo-Updates | No | ---- | ----
4 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Pool | SLES12-SP3-Pool | Yes | (r ) Yes | No
5 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Source-Pool | SLES12-SP3-Source-Pool | No | ---- | ----
6 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Updates | SLES12-SP3-Updates | Yes | (r ) Yes | Yes
7 | VLC | VLC | Yes | (r ) Yes | Yes
8 | science | Software for Scientists and Engineers (SLE_12) | Yes | (r ) Yes | No
#

Is there an eval licence i can get, in order to register the SDK?

Rgds

malcolmlewis
27-Mar-2018, 15:56
Hi,

I tried the clean up but the SDK repo still does not appear:

# zypper clean -a
All repositories have been cleaned up.
# zypper ref -f
Forcing raw metadata refresh
Retrieving repository 'SLES12-SP3-12.3-0' metadata .................................................. .................................................. .................................................[done]
Forcing building of repository cache
Building repository 'SLES12-SP3-12.3-0' cache .................................................. .................................................. .................................................. ....[done]
Forcing raw metadata refresh
Retrieving repository 'SLES12-SP3-Pool' metadata .................................................. .................................................. .................................................. .[done]
Forcing building of repository cache
Building repository 'SLES12-SP3-Pool' cache .................................................. .................................................. .................................................. ......[done]
Forcing raw metadata refresh
Retrieving repository 'SLES12-SP3-Updates' metadata .................................................. .................................................. ................................................[done]
Forcing building of repository cache
Building repository 'SLES12-SP3-Updates' cache .................................................. .................................................. .................................................. ...[done]
Forcing raw metadata refresh
Retrieving repository 'VLC' metadata .................................................. .................................................. .................................................. .............[done]
Forcing building of repository cache
Building repository 'VLC' cache .................................................. .................................................. .................................................. ..................[done]
Forcing raw metadata refresh
Retrieving repository 'Software for Scientists and Engineers (SLE_12)' metadata .................................................. .................................................. ....................[done]
Forcing building of repository cache
Building repository 'Software for Scientists and Engineers (SLE_12)' cache .................................................. .................................................. .........................[done]
All repositories have been refreshed.
# zypper lr
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias | Name | Enabled | GPG Check | Refresh
--+-------------------------------------------------------------------------+------------------------------------------------+---------+-----------+--------
1 | SLES12-SP3-12.3-0 | SLES12-SP3-12.3-0 | Yes | (r ) Yes | No
2 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Pool | SLES12-SP3-Debuginfo-Pool | No | ---- | ----
3 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Updates | SLES12-SP3-Debuginfo-Updates | No | ---- | ----
4 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Pool | SLES12-SP3-Pool | Yes | (r ) Yes | No
5 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Source-Pool | SLES12-SP3-Source-Pool | No | ---- | ----
6 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Updates | SLES12-SP3-Updates | Yes | (r ) Yes | Yes
7 | VLC | VLC | Yes | (r ) Yes | Yes
8 | science | Software for Scientists and Engineers (SLE_12) | Yes | (r ) Yes | No
#

Is there an eval licence i can get, in order to register the SDK?

Rgds
Hi
None is needed, it's a free extension, part of your existing license.

You have the existing registration key handy? If so, I would look at de-registering the system and cleanup via the SUSEConnect commands (SUSEConnect --help) then re-register the system and re-add the SDK.

ronanb78
28-Mar-2018, 16:19
I was able to register the SDK and then i tried the install again but it fails specifying a different library?
I feel like that i am nearly there...? What do i need to do next?

# SUSEConnect -p sle-sdk/12.3/x86_64
Registered sle-sdk 12.3 x86_64
To server: https://scc.suse.com

# SUSEConnect -s
[{"identifier":"SLES","version":"12.3","arch":"x86_64","status":"Registered","regcode":"BLANKED OUT THE KEY!!!!!","starts_at":"2018-03-01 00:00:00 UTC","expires_at":"2018-04-30 00:00:00 UTC","subscription_status":"ACTIVE","type":"evaluation"},{"identifier":"sle-sdk","version":"12.3","arch":"x86_64","status":"Registered"},{"identifier":"sle-module-toolchain","version":"12","arch":"x86_64","status":"Not Registered"}]

# zypper in vlc
Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP3_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12 _SP3_x86_64'.
Retrieving repository 'SLES12-SP3-Updates' metadata .................................................. .......................................[done]
Building repository 'SLES12-SP3-Updates' cache .................................................. ............................................[done]
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libcddb.so.2()(64bit) needed by vlc-noX-2.2.4-238.1.x86_64
Solution 1: do not install vlc-2.2.4-238.1.x86_64
Solution 2: break vlc-noX-2.2.4-238.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):


# zypper lr
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias | Name | Enabled | GPG Check | Refresh
---+----------------------------------------------------------------------------------------------+------------------------------------------------+---------+-----------+--------
1 | SLES12-SP3-12.3-0 | SLES12-SP3-12.3-0 | Yes | (r ) Yes | No
2 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Pool | SLES12-SP3-Debuginfo-Pool | No | ---- | ----
3 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Updates | SLES12-SP3-Debuginfo-Updates | No | ---- | ----
4 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Pool | SLES12-SP3-Pool | Yes | (r ) Yes | No
5 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Source-Pool | SLES12-SP3-Source-Pool | No | ---- | ----
6 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Updates | SLES12-SP3-Updates | Yes | (r ) Yes | Yes
7 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Debuginfo-Pool | SLE-SDK12-SP3-Debuginfo-Pool | No | ---- | ----
8 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Debuginfo-Updates | SLE-SDK12-SP3-Debuginfo-Updates | No | ---- | ----
9 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Pool | SLE-SDK12-SP3-Pool | Yes | (r ) Yes | No
10 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Source-Pool | SLE-SDK12-SP3-Source-Pool | No | ---- | ----
11 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Updates | SLE-SDK12-SP3-Updates | Yes | (r ) Yes | Yes
12 | VLC | VLC | Yes | (r ) Yes | Yes
13 | science | Software for Scientists and Engineers (SLE_12) | Yes | (r ) Yes | No
#

malcolmlewis
28-Mar-2018, 17:04
Hi
Looks like you will need to add the multimedia libs (unsupported) repository as well if you want the command line version of vlc?
https://download.opensuse.org/repositories/multimedia:/libs/SLE_12_SP3/

ronanb78
29-Mar-2018, 08:43
Hi,

Ok. Thanks.
How do i go about doing this? What commands do i need to run?
Is there any associated risk of doing this? i.e Installing unsupported OpenSuSe libraries on a SuSE platform?

ronanb78
29-Mar-2018, 09:03
Also..

I see that some of the SDK repos are marked as "not enabled" in the 'zypper lr' output:

zypper lr
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias | Name | Enabled | GPG Check | Refresh
---+----------------------------------------------------------------------------------------------+------------------------------------------------+---------+-----------+--------
1 | SLES12-SP3-12.3-0 | SLES12-SP3-12.3-0 | Yes | (r ) Yes | No
2 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Pool | SLES12-SP3-Debuginfo-Pool | No | ---- | ----
3 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Updates | SLES12-SP3-Debuginfo-Updates | No | ---- | ----
4 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Pool | SLES12-SP3-Pool | Yes | (r ) Yes | No
5 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Source-Pool | SLES12-SP3-Source-Pool | No | ---- | ----
6 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Updates | SLES12-SP3-Updates | Yes | (r ) Yes | Yes
7 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Debuginfo-Pool | SLE-SDK12-SP3-Debuginfo-Pool | No | ---- | ----
8 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Debuginfo-Updates | SLE-SDK12-SP3-Debuginfo-Updates | No | ---- | ----
9 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Pool | SLE-SDK12-SP3-Pool | Yes | (r ) Yes | No
10 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Source-Pool | SLE-SDK12-SP3-Source-Pool | No | ---- | ----
11 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Updates | SLE-SDK12-SP3-Updates | Yes | (r ) Yes | Yes
12 | VLC | VLC | Yes | (r ) Yes | Yes
13 | science | Software for Scientists and Engineers (SLE_12) | Yes | (r ) Yes | No
#

Do they need to be enabled?

malcolmlewis
29-Mar-2018, 13:08
Hi,

Ok. Thanks.
How do i go about doing this? What commands do i need to run?
Is there any associated risk of doing this? i.e Installing unsupported OpenSuSe libraries on a SuSE platform?
Hi
Well you VLC and Science repos are unsupported, the packages are built for SLE ;)

Use zypper to add;


zypper ar -f -g -n "Multimedia:Libs" https://download.opensuse.org/repositories/multimedia:/libs/SLE_12_SP3/ Multimedia:Libs

malcolmlewis
29-Mar-2018, 13:10
Also..

I see that some of the SDK repos are marked as "not enabled" in the 'zypper lr' output:

zypper lr
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias | Name | Enabled | GPG Check | Refresh
---+----------------------------------------------------------------------------------------------+------------------------------------------------+---------+-----------+--------
1 | SLES12-SP3-12.3-0 | SLES12-SP3-12.3-0 | Yes | (r ) Yes | No
2 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Pool | SLES12-SP3-Debuginfo-Pool | No | ---- | ----
3 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Updates | SLES12-SP3-Debuginfo-Updates | No | ---- | ----
4 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Pool | SLES12-SP3-Pool | Yes | (r ) Yes | No
5 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Source-Pool | SLES12-SP3-Source-Pool | No | ---- | ----
6 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Updates | SLES12-SP3-Updates | Yes | (r ) Yes | Yes
7 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Debuginfo-Pool | SLE-SDK12-SP3-Debuginfo-Pool | No | ---- | ----
8 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Debuginfo-Updates | SLE-SDK12-SP3-Debuginfo-Updates | No | ---- | ----
9 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Pool | SLE-SDK12-SP3-Pool | Yes | (r ) Yes | No
10 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Source-Pool | SLE-SDK12-SP3-Source-Pool | No | ---- | ----
11 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Updates | SLE-SDK12-SP3-Updates | Yes | (r ) Yes | Yes
12 | VLC | VLC | Yes | (r ) Yes | Yes
13 | science | Software for Scientists and Engineers (SLE_12) | Yes | (r ) Yes | No
#

Do they need to be enabled?
Hi
No, these are debug and source (rpms) packages, not needed for normal day to day use, only for fault finding and need the debug packages, or if you want to rebuild something against the source.

ronanb78
29-Mar-2018, 14:08
Will try that zypper command - Thanks.

What do you mean by "Well you VLC and Science repos are unsupported, the packages are built for SLE" ?
The OS i have is SLE and so I would assume the packages are supported????

# cat /etc/SuSE-release
SUSE Linux Enterprise Server 12 (x86_64)
VERSION = 12
PATCHLEVEL = 3
# This file is deprecated and will be removed in a future service pack or release.
# Please check /etc/os-release for details about this release.
#

smflood
29-Mar-2018, 14:42
On 29/03/18 14:14, ronanb78 wrote:

> What do you mean by "Well you VLC and Science repos are unsupported, the
> packages are built for SLE" ?
> The OS i have is SLE and so I would assume the packages are
> supported????

Yes SUSE Linux Enterprise Server is supported by SUSE for the packages
which they provide, either on the distribution media and/or in the
online channels but they don't support any packages obtained from
third-parties (which includes the openSUSE Build Service*).

HTH.

* any repo added to SLE which is hosted at https://download.opensuse.org
is openSUSE Build Service and so not supported by SUSE
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

ronanb78
03-Apr-2018, 10:27
Hi,

I installed the multimedia libs but now i get a new dependency error when i try to install VLC:

# zypper ar -f -g -n "Multimedia:Libs" https://download.opensuse.org/repositories/multimedia:/libs/SLE_12_SP3/ Multimedia:Libs
Adding repository 'Multimedia:Libs' .................................................. .................................................. .................................................. ..............................................[done]
Repository 'Multimedia:Libs' successfully added

URI : https://download.opensuse.org/repositories/multimedia:/libs/SLE_12_SP3/
Enabled : Yes
GPG Check : Yes
Autorefresh : Yes
Priority : 99 (default priority)

Repository priorities are without effect. All enabled repositories share the same priority.
# zypper lr
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias | Name | Enabled | GPG Check | Refresh
---+----------------------------------------------------------------------------------------------+------------------------------------------------+---------+-----------+--------
1 | Multimedia:Libs | Multimedia:Libs | Yes | ( p) Yes | Yes
2 | SLES12-SP3-12.3-0 | SLES12-SP3-12.3-0 | Yes | (r ) Yes | No
3 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Pool | SLES12-SP3-Debuginfo-Pool | No | ---- | ----
4 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Updates | SLES12-SP3-Debuginfo-Updates | No | ---- | ----
5 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Pool | SLES12-SP3-Pool | Yes | (r ) Yes | No
6 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Source-Pool | SLES12-SP3-Source-Pool | No | ---- | ----
7 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Updates | SLES12-SP3-Updates | Yes | (r ) Yes | Yes
8 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Debuginfo-Pool | SLE-SDK12-SP3-Debuginfo-Pool | No | ---- | ----
9 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Debuginfo-Updates | SLE-SDK12-SP3-Debuginfo-Updates | No | ---- | ----
10 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Pool | SLE-SDK12-SP3-Pool | Yes | (r ) Yes | No
11 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Source-Pool | SLE-SDK12-SP3-Source-Pool | No | ---- | ----
12 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP3_x86_64:SLE-SDK12-SP3-Updates | SLE-SDK12-SP3-Updates | Yes | (r ) Yes | Yes
13 | VLC | VLC | Yes | (r ) Yes | Yes
14 | science
| Software for Scientists and Engineers (SLE_12) | Yes | (r ) Yes | No
# zypper in vlc
Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP3_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12 _SP3_x86_64'.
Retrieving repository 'Multimedia:Libs' metadata ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------[\]

New repository or package signing key received:

Repository: Multimedia:Libs
Key Name: multimedia OBS Project <multimedia@build.opensuse.org>
Key Fingerprint: 0E313DB7 936B4E76 E720065B 77EC2301 F23C6AA3
Key Created: Tue 21 Nov 2017 04:55:56 PM CET
Key Expires: Thu 30 Jan 2020 04:55:56 PM CET
Rpm Name: gpg-pubkey-f23c6aa3-5a144c8c


Do you want to reject the key, trust temporarily, or trust always? [r/t/a/? shows all options] (r): t
Retrieving repository 'Multimedia:Libs' metadata .................................................. .................................................. .................................................. .................................[done]
Building repository 'Multimedia:Libs' cache .................................................. .................................................. .................................................. ......................................[done]
Retrieving repository 'SLES12-SP3-Updates' metadata .................................................. .................................................. .................................................. ..............................[done]
Building repository 'SLES12-SP3-Updates' cache .................................................. .................................................. .................................................. ...................................[done]
Retrieving repository 'SLE-SDK12-SP3-Updates' metadata .................................................. .................................................. .................................................. ...........................[done]
Building repository 'SLE-SDK12-SP3-Updates' cache .................................................. .................................................. .................................................. ................................[done]
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libfreerdp-core.so.1.0()(64bit) needed by vlc-noX-2.2.4-238.1.x86_64
Solution 1: do not install vlc-2.2.4-238.1.x86_64
Solution 2: break vlc-noX-2.2.4-238.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

Any ideas?

malcolmlewis
03-Apr-2018, 14:23
Hi
So that's (freerdp) available in SLED, for SLES via the workstation extension.... the expectation is likely to run on a desktop rather than a server.....

You could pull the files from a SLED 12 SP3 iso image....?

ronanb78
03-Apr-2018, 14:25
ok.
Any ideas how? What commands?

malcolmlewis
03-Apr-2018, 15:01
Hi
Well the best way would be to just use Nautilus and the Archive Manager option if you right-click on the SLED 12 SP3 iso image, then just extract the freerdp rpm's to a local directory and manually install with zipper in <rpm1> <rpm2> etc.

You need freerdp, libfreerdp2

AndreasMeyer
07-Apr-2018, 22:01
The easier way is to buy a license for "Fluendo ONEPlay Codec Pack" and install the "Linux RPM" of "Fluendo ONEPlay Codec Pack". See:
https://forums.suse.com/showthread.php?10190-problem-with-playing-video-files