PDA

View Full Version : SLES 12 SP2 letsencrypt problem



RKAUGI
27-Mar-2018, 07:53
Hey,

I have an apache Webserver and want to use letsencrypt for https. I already tried alot but everytime I try to get the certificate with the letsencrypt-auto file it says
"Sorry, I don’t know how to bootstrap Certbot on your operating system! You will need to install OS dependencies, configure virtualenv, and run pip install manually.
Please see https://letsencrypt.readthedocs.org/en/latest/contributing.html#prerequisites for more info."

I tried like this https://community.letsencrypt.org/t/how-to-set-up-letsencrypt-on-opensuse-13-2-tutorial/5580

I use SLES 12 SP2, apache 2.4, python 2.7

Automatic Reply
02-Apr-2018, 05:30
RKAUGI,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- Open a service request: https://www.suse.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot..

Good luck!

Your SUSE Forums Team
http://forums.suse.com

ab
02-Apr-2018, 05:45
Could you show us your actual output from each step? openSUSE 13.x is a
fair bit older than SLES 12, so there may be some modifications needed to
get everything going.


--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.

rogerbycek
09-Apr-2018, 18:24
You might want to have a look at acme.sh (https://github.com/Neilpang/acme.sh) - it's the ACME client protocol done all in a bash script. I've had no issues running it under SLES 12 SP3.