PDA

View Full Version : Pending actions over 2 days



achinayoung_waubonsee
19-Apr-2018, 17:20
I am trying to bootstrap two servers with SUMA 3.1.4. I bootstrapped the systems by installing the requisite salt packages and then accepting the new entries that appeared in under the Salt menu. However, the following actions have been pending for two days now:
296

How can I find out why the actions are still pending?

kwk
20-Apr-2018, 07:28
You did accept the minion key, didn't you ?

achinayoung_waubonsee
20-Apr-2018, 16:01
You did accept the minion key, didn't you ?

Yes, under the salt menu, I accepted the key.

kwk
21-Apr-2018, 07:21
Is the minion running and reachable ? Try 'salt <fqdn.of.minion> test.ping'.
If test.ping doesn't work, can you ping it via network ('ping <fqdn.of.minion>') ?
If the network ping succeeds, ssh to the client and restart salt-minion via systemctl.

achinayoung_waubonsee
24-Apr-2018, 16:34
Is the minion running and reachable ? Try 'salt <fqdn.of.minion> test.ping'.
If test.ping doesn't work, can you ping it via network ('ping <fqdn.of.minion>') ?
If the network ping succeeds, ssh to the client and restart salt-minion via systemctl.

All of the above was done. No change. I upgraded the salt-minion client to the latest, still no change. I rebooted the SUMA server and that fixed the issue. Not really the way I would have liked to solve the problem though.

achinayoung_waubonsee
24-Apr-2018, 16:35
However, regardless of the reason for the failure, how is it even possible to determine what the communication failure is? If SUMA cannot talk to the salt minion on the client, how do you find this out? Is it logged somewhere? Nothing eventful is in /var/log/salt/master.

kwk
25-Apr-2018, 07:31
All of the above was done. No change. I upgraded the salt-minion client to the latest, still no change. I rebooted the SUMA server and that fixed the issue. Not really the way I would have liked to solve the problem though.

Good that your system is running again.

Next time, please open a support request and provide a 'supportconfig'. Then we can hopefully determine the root cause.