PDA

View Full Version : SLED 12 SP3 Gnome-shell error



marco_ferraresi
08-May-2018, 13:56
Hello
I have a problem with VNC. I have a Suse Linux Enterprise Server 12.3 and when I run the vncserver command in the log I have the following error


Tue May 8 14:32:13 2018
vncext: VNC extension running!
vncext: Listening for VNC connections on all interface(s), port 60502
vncext: Listening for HTTP connections on all interface(s), port 5802
vncext: created VNC server for screen 0
Failed to connect to bus: No such file or directory
/etc/X11/xim: Checking whether an input method should be started.
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale C.UTF-8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
gnome-session-is-accelerated: llvmpipe detected.
GNOME_KEYRING_CONTROL=/root/.cache/keyring-3B5ZIZ
GNOME_KEYRING_CONTROL=/root/.cache/keyring-3B5ZIZ
GNOME_KEYRING_CONTROL=/root/.cache/keyring-3B5ZIZ
SSH_AUTH_SOCK=/root/.cache/keyring-3B5ZIZ/ssh

(gnome-shell:15941): Gjs-WARNING **: JS ERROR: Error: Argument 'string' (type utf8) may not be null
_pack_variant@resource:///org/gnome/gjs/modules/overrides/GLib.js:104
_pack_variant@resource:///org/gnome/gjs/modules/overrides/GLib.js:151
@resource:///org/gnome/gjs/modules/overrides/GLib.js:261
_proxyInvoker@resource:///org/gnome/gjs/modules/overrides/Gio.js:78
_makeProxyMethod/<@resource:///org/gnome/gjs/modules/overrides/Gio.js:124
LoginManagerSystemd<.getCurrentSessionProxy@resource:///org/gnome/shell/misc/loginManager.js:120
wrapper@resource:///org/gnome/gjs/modules/lang.js:178
ScreenShield<._init@resource:///org/gnome/shell/ui/screenShield.js:542
wrapper@resource:///org/gnome/gjs/modules/lang.js:178
_Base.prototype._construct@resource:///org/gnome/gjs/modules/lang.js:110
Class.prototype._construct/newClass@resource:///org/gnome/gjs/modules/lang.js:213
_initializeUI@resource:///org/gnome/shell/ui/main.js:168
start@resource:///org/gnome/shell/ui/main.js:125
@<main>:1

** Message: Execution of main.js threw exception: JS_EvaluateScript() failed
gnome-session-binary[15884]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1

(gnome-shell:15971): Gjs-WARNING **: JS ERROR: Error: Argument 'string' (type utf8) may not be null
_pack_variant@resource:///org/gnome/gjs/modules/overrides/GLib.js:104
_pack_variant@resource:///org/gnome/gjs/modules/overrides/GLib.js:151
@resource:///org/gnome/gjs/modules/overrides/GLib.js:261
_proxyInvoker@resource:///org/gnome/gjs/modules/overrides/Gio.js:78
_makeProxyMethod/<@resource:///org/gnome/gjs/modules/overrides/Gio.js:124
LoginManagerSystemd<.getCurrentSessionProxy@resource:///org/gnome/shell/misc/loginManager.js:120
wrapper@resource:///org/gnome/gjs/modules/lang.js:178
ScreenShield<._init@resource:///org/gnome/shell/ui/screenShield.js:542
wrapper@resource:///org/gnome/gjs/modules/lang.js:178
_Base.prototype._construct@resource:///org/gnome/gjs/modules/lang.js:110
Class.prototype._construct/newClass@resource:///org/gnome/gjs/modules/lang.js:213
_initializeUI@resource:///org/gnome/shell/ui/main.js:168
start@resource:///org/gnome/shell/ui/main.js:125
@<main>:1

** Message: Execution of main.js threw exception: JS_EvaluateScript() failed
gnome-session-binary[15884]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
gnome-session-binary[15884]: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
Unable to init server: Could not connect: Connection refused

** (gnome-session-failed:15983): WARNING **: Cannot open display:
W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).

** (gnome-settings-daemon:15984): WARNING **: Schemas 'org.gnome.desktop.a11y' has not been setup
VNC not managed by vncmanager, quitting.

The result is that when I try to open a vnc client I have a black screen.
Can someone help me to debug the problem?
Thanks
Regards

Automatic Reply
14-May-2018, 05:30
marco,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- Open a service request: https://www.suse.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot..

Good luck!

Your SUSE Forums Team
http://forums.suse.com

smflood
14-May-2018, 22:01
marco ferraresi Wrote in message:

> I have a problem with VNC. I have a Suse Linux Enterprise Server 12.3

Since you have posted in a forum for issues relating to SUSE Linux
Enterprise Desktop (SLED) with a prefix of "SLED 12 SP3" please
can you clarify whether you are using SLED or SLES12 SP3? Please
post the output from "cat /etc/*release".

> and when I run the vncserver command in the log I have the following
> error
>
>
> Code:
> --------------------
> -Tue May 8 14:32:13 2018
> vncext: VNC extension running!
> vncext: Listening for VNC connections on all interface(s), port 60502
> vncext: Listening for HTTP connections on all interface(s), port 5802
> vncext: created VNC server for screen 0
> Failed to connect to bus: No such file or directory
> /etc/X11/xim: Checking whether an input method should be started.
> sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
> INPUT_METHOD is not set or empty (no user selected input method).
> Trying to start a default input method for the locale C.UTF-8 ...
> There is no default input method for the current locale.
> Dummy input method "none" (do not use any fancy input method by default)
> gnome-session-is-accelerated: llvmpipe detected.
> GNOME_KEYRING_CONTROL=/root/.cache/keyring-3B5ZIZ
> GNOME_KEYRING_CONTROL=/root/.cache/keyring-3B5ZIZ
> GNOME_KEYRING_CONTROL=/root/.cache/keyring-3B5ZIZ
> SSH_AUTH_SOCK=/root/.cache/keyring-3B5ZIZ/ssh
>
> (gnome-shell:15941): Gjs-WARNING **: JS ERROR: Error: Argument 'string' (type utf8) may not be null
> _pack_variant@resource:///org/gnome/gjs/modules/overrides/GLib.js:104
> _pack_variant@resource:///org/gnome/gjs/modules/overrides/GLib.js:151
> @resource:///org/gnome/gjs/modules/overrides/GLib.js:261
> _proxyInvoker@resource:///org/gnome/gjs/modules/overrides/Gio.js:78
> _makeProxyMethod/<@resource:///org/gnome/gjs/modules/overrides/Gio.js:124
> LoginManagerSystemd<.getCurrentSessionProxy@resource:///org/gnome/shell/misc/loginManager.js:120
> wrapper@resource:///org/gnome/gjs/modules/lang.js:178
> ScreenShield<._init@resource:///org/gnome/shell/ui/screenShield.js:542
> wrapper@resource:///org/gnome/gjs/modules/lang.js:178
> _Base.prototype._construct@resource:///org/gnome/gjs/modules/lang.js:110
> Class.prototype._construct/newClass@resource:///org/gnome/gjs/modules/lang.js:213
> _initializeUI@resource:///org/gnome/shell/ui/main.js:168
> start@resource:///org/gnome/shell/ui/main.js:125
> @<main>:1
>
> ** Message: Execution of main.js threw exception: JS_EvaluateScript() failed
> gnome-session-binary[15884]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
>
> (gnome-shell:15971): Gjs-WARNING **: JS ERROR: Error: Argument 'string' (type utf8) may not be null
> _pack_variant@resource:///org/gnome/gjs/modules/overrides/GLib.js:104
> _pack_variant@resource:///org/gnome/gjs/modules/overrides/GLib.js:151
> @resource:///org/gnome/gjs/modules/overrides/GLib.js:261
> _proxyInvoker@resource:///org/gnome/gjs/modules/overrides/Gio.js:78
> _makeProxyMethod/<@resource:///org/gnome/gjs/modules/overrides/Gio.js:124
> LoginManagerSystemd<.getCurrentSessionProxy@resource:///org/gnome/shell/misc/loginManager.js:120
> wrapper@resource:///org/gnome/gjs/modules/lang.js:178
> ScreenShield<._init@resource:///org/gnome/shell/ui/screenShield.js:542
> wrapper@resource:///org/gnome/gjs/modules/lang.js:178
> _Base.prototype._construct@resource:///org/gnome/gjs/modules/lang.js:110
> Class.prototype._construct/newClass@resource:///org/gnome/gjs/modules/lang.js:213
> _initializeUI@resource:///org/gnome/shell/ui/main.js:168
> start@resource:///org/gnome/shell/ui/main.js:125
> @<main>:1
>
> ** Message: Execution of main.js threw exception: JS_EvaluateScript() failed
> gnome-session-binary[15884]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
> gnome-session-binary[15884]: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
> Unable to init server: Could not connect: Connection refused
>
> ** (gnome-session-failed:15983): WARNING **: Cannot open display:
> W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
>
> ** (gnome-settings-daemon:15984): WARNING **: Schemas 'org.gnome.desktop.a11y' has not been setup
> VNC not managed by vncmanager, quitting.-
> --------------------
>
>
> The result is that when I try to open a vnc client I have a black
> screen.
> Can someone help me to debug the problem?

How have you configured VNC?

Which VNC client are you using? From which OS?

HTH.
--
Simon Flood
SUSE Knowledge Partner


----Android NewsGroup Reader----
http://usenet.sinaapp.com/

marco_ferraresi
15-May-2018, 08:53
Hello Simon
Thanks for your answer.
Here is the output of the release command



cat /etc/*release
SUSE Linux Enterprise Server 12 (x86_64)
VERSION = 12
PATCHLEVEL = 3
# This file is deprecated and will be removed in a future service pack or release.
# Please check /etc/os-release for details about this release.
NAME="SLES"
VERSION="12-SP3"
VERSION_ID="12.3"
PRETTY_NAME="SUSE Linux Enterprise Server 12 SP3"
ID="sles"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:suse:sles:12:sp3"


The only configuration that I made was to change the vnc port.
I use "VNC Viewer" and "TightVNC Viewer" on Windows 10, and both of them visualize a black screen.
Regards
Marco