PDA

View Full Version : SLED 12 SP3 Not booting to Hard disk after install



lollipop2185
23-May-2018, 02:47
I am having a problem with SP2 and SP3 installers.

After i installed (following instructions https://www.youtube.com/watch?v=66zw_YM2yY8 )

Suse does not boot straight to GRUB and will need the USB with DVD.iso again (using the "boot from hard disk" option) to boot Suse

Partitions were set as

/dev/nvem0n1p1 -> type BIOS boot (code EF02)
/dev/nvem0n1p2 -> swap ; type MS basic data (code 0700)
/dev/nvem0n1p3 and p4 type MS data (code 0700)

gdisk output is -> GPT fdisk (gdisk) version 0.8.8


I have tried a lot of different combinations during installation (partitions, check MBR option on booting, custom boot, secureboot etc. ) , but all have same output (does not boot)

If there are additional info needed for this please tell me. Ive been using suse with the USB drive plugged in since sunday just to make it work.

Hope someone helps

malcolmlewis
23-May-2018, 04:25
Hi
You need to set the efi partition type as ef00 formatted to vfat not ef02 for gpt booting, else if not using UEFI, set the disk back to dos type format for MBR and then you would just create a small /boot partition.

lollipop2185
23-May-2018, 05:09
Hi Malcolm

Thank you for your reply,

Changing type to EF00

"You need to set the efi partition type as ef00 formatted to vfat not ef02 for gpt booting"

Should setting efi partition to ef00 be during re-install or its ok to change it using "fdisk" and "t" command?

Will changing it without re-installing be ok?

Thanks!

lollipop2185
23-May-2018, 06:17
I have re-install Suse and set partition 1's file system ID as 0x00 EFI boot via expert partitioner during installation but problem is still happening

Partition 1 : /dev/nvme0n1 => code 0F00 EFI system

how should it be installed because it seems the video guide i was referring to for correct installation is not applicable

thank you

malcolmlewis
23-May-2018, 13:51
On Wed 23 May 2018 05:24:01 AM CDT, lollipop2185 wrote:

I have re-install Suse and set partition 1's file system ID as 0x00 EFI
boot via expert partitioner during installation but problem is still
happening

Partition 1 : /dev/nvme0n1 => code 0F00 EFI system

how should it be installed because it seems the video guide i was
referring to for correct installation is not applicable

thank you




Hi
So what is the hardware, is the system BIOS set to UEFI or Legacy boot,
that makes a big difference....

So, for MBR type you need to have the disk set to 'dos' type partitions
for swap are type 82, for the others type is 83. The tool to use is
fdisk.

For UEFI type you need to have the disk set to type 'gpt' a small
partition ~260MB set to type ef00 and formatted vfat, swap is type
8200 and others are type 8300. The tool to use for this is 'gdisk' not
fdisk.

I normally boot into a rescue USB device (openSUSE Tumbleweed) to
configure the drive before install.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 RC4 | GNOME Shell 3.26.2 | 4.12.14-18-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

lollipop2185
24-May-2018, 02:07
I have changed the partition code and set BIOS to UEFI first

Here are results:

gdisk ; command p
Here (https://drive.google.com/open?id=1E9MUPwsZdKkxkDvSgk1SUvMM6VxJuMe0)

parted -l
Here (https://drive.google.com/open?id=1yBznzdWZWxBDsoKWHlm3jmQ6eNFhzHo0)

also tried to turn off pmbr_boot, still same.

I apologize, i relatively new to Suse.

Please guide me as to what I still got wrong?

malcolmlewis
24-May-2018, 03:44
I have changed the partition code and set BIOS to UEFI first

Here are results:

gdisk ; command p
Here (https://drive.google.com/open?id=1E9MUPwsZdKkxkDvSgk1SUvMM6VxJuMe0)

parted -l
Here (https://drive.google.com/open?id=1yBznzdWZWxBDsoKWHlm3jmQ6eNFhzHo0)

also tried to turn off pmbr_boot, still same.

I apologize, i relatively new to Suse.

Please guide me as to what I still got wrong?
Hi
You need at least 100MB for the efi partition... and format to vfat, 7MB is too small...

You BIOS has pure UEFI or a CSM type boot?

lollipop2185
24-May-2018, 10:04
Hi

i have set partition size to more than 100MB and type is already FAT 16 [Also tried FAT32, tried to re-install and set to FAT and also just change to vFAT via mkfs.vfat -F 32 or 16) FAT32)

screenshot of Parted -l (https://drive.google.com/open?id=1Nv2lXcWJvxMeYOEQlBxIgRKazKjxK4zg)

1st try Boot was set to "Both"
and UEFI 1st :CSM support yes; same result

still doesnt boot (goes to USB with DVD iso or Boot manager) even if i change to :

1. Legacy only ; No CSM support
2. UEFI only ; No CSM support
3. UEFI only; Yes CSM support
4. Legacy only ; Yes CSM support
5. Both : Legacy first; Yes CSM support


-> Code is same EF00 , 8200 and 8300

Same result. Disk not booting

I am not sure what else is wrong. Thank you very much for the additional support

malcolmlewis
24-May-2018, 13:53
On Thu 24 May 2018 09:14:03 AM CDT, lollipop2185 wrote:

Hi

i have set partition size to more than 100MB and type is already FAT 16
[Also tried FAT32, tried to re-install and set to FAT and also just
change to vFAT via mkfs.vfat -F 32 or 16) FAT32)

'screenshot of Parted -l '
(https://drive.google.com/open?id=1Nv2lXcWJvxMeYOEQlBxIgRKazKjxK4zg)

1st try Boot was set to "Both"
and UEFI 1st :CSM support yes; same result

still doesnt boot (goes to USB with DVD iso or Boot manager) even if i
change to :

1. Legacy only ; No CSM support
2. UEFI only ; No CSM support
3. UEFI only; Yes CSM support
4. Legacy only ; Yes CSM support
5. Both : Legacy first; Yes CSM support


-> Code is same EF00 , 8200 and 8300

Same result. Disk not booting

I am not sure what else is wrong. Thank you very much for the additional
support




Hi
So if you boot in rescue mode from the install media and run the
command;


efibootmgr -v


If you press the system boot menu screen eg F12, F2 or F9 for your
system, can you select and efi file to boot from and then browse
to /boot/efi/EFI/sles/ and select grubx64.efi or shim.efi and boot the
system?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 RC4 | GNOME Shell 3.26.2 | 4.12.14-18-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

lollipop2185
25-May-2018, 07:33
Hi
So if you boot in rescue mode from the install media and run the
command;


efibootmgr -v


If you press the system boot menu screen eg F12, F2 or F9 for your
system, can you select and efi file to boot from and then browse
to /boot/efi/EFI/sles/ and select grubx64.efi or shim.efi and boot the
system?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 RC4 | GNOME Shell 3.26.2 | 4.12.14-18-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

When i input command:

efibootmgr -v
on rescue mode, output is:

EFI variables are not supported on this system


I also cannot select and boot efi file on boot manager. it is just PCI LAN, the USB drive with DVD.iso and the hard disk (nvme0n1)

malcolmlewis
31-May-2018, 15:57
On Fri 25 May 2018 06:34:02 AM CDT, lollipop2185 wrote:

malcolmlewis;52724 Wrote:
> Hi
> So if you boot in rescue mode from the install media and run the
> command;
> >
Code:
--------------------
> >
> efibootmgr -v
>
--------------------
> >
>
> If you press the system boot menu screen eg F12, F2 or F9 for your
> system, can you select and efi file to boot from and then browse
> to /boot/efi/EFI/sles/ and select grubx64.efi or shim.efi and boot
> the
> system?
>
> --
> Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
> SLES 15 RC4 | GNOME Shell 3.26.2 | 4.12.14-18-default
> If you find this post helpful and are logged into the web interface,
> please show your appreciation and click on the star below... Thanks!

When i input command:

Code:
--------------------
efibootmgr -v
--------------------

on rescue mode, output is:

Code:
--------------------
EFI variables are not supported on this system
--------------------



I also cannot select and boot efi file on boot manager. it is just PCI
LAN, the USB drive with DVD.iso and the hard disk (nvme0n1)




Hi
Apologies for the late reply, that would indicate the system is booting
in Legacy mode, not UEFI? Legacy won't boot with a gpt disk... Can you
confirm your BIOS settings...

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 RC4 | GNOME Shell 3.26.2 | 4.12.14-18-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!