PDA

View Full Version : Cannot back up PostgreSQL database with smdba



achinayoung_waubonsee
07-Jun-2018, 19:44
Running SUMA 3.1.5. I am getting an error when trying to back up the database:


# smdba backup-hot --enable=on --backup-dir=/var/spacewalk/db-backup
pg_basebackup: initiating base backup, waiting for checkpoint to complete
pg_basebackup: could not initiate base backup: ERROR: syntax error
INFO: Finished

Any ideas?

ab
08-Jun-2018, 13:35
Is this a new setup, or one that has been around for a while and upgrade?
A test setup or prod, and can you duplicate it anywhere else?

Does anything via the smdba command work, e.g.:



smdba db-stop #stopping the database
smdba db-start #restarting it


Is the /var/spacewalk/db-backup directly owned by, presumably, the
postgres user and group?

I do not know that it matters, but the database connection information in
etc/rhn/rhn.conf may be worth reviewing to see if anything is blatantly
incorrect. Presumable your SUSE Manager installation is working, so is
probably unlikely.


--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.

achinayoung_waubonsee
08-Jun-2018, 16:58
Is this a new setup, or one that has been around for a while and upgrade?

The system was originally installed with SUMA 3.0 and upgraded to 3.1.5.


A test setup or prod, and can you duplicate it anywhere else?

This is the only SUMA server we have so nothing else to test against.


Does anything via the smdba command work, e.g.:



smdba db-stop #stopping the database
smdba db-start #restarting it


I was able to run "smdba space-overview", "smdba db-status", and "smdba space-tables" without any problems.


Is the /var/spacewalk/db-backup directly owned by, presumably, the
postgres user and group?

Yes, permissions on /var/spacewalk/db-backup are ok.


I do not know that it matters, but the database connection information in
etc/rhn/rhn.conf may be worth reviewing to see if anything is blatantly
incorrect. Presumable your SUSE Manager installation is working, so is
probably unlikely.

The settings in /etc/rhn/rhn.conf look ok.