PDA

View Full Version : SLED 12 SP3 Using snaps on SUSE



BMX
09-Jun-2018, 22:15
I'm trying to install snaps via snapd end get such error message


griwa@linux-xmmp:~> sudo snap install vuze-vs
error: cannot perform the following tasks:
- Setup snap "core" (4650) security profiles (cannot setup apparmor for snap "core": cannot load apparmor profile "snap-update-ns.core": cannot load apparmor profile: exit status 1
apparmor_parser output:
mkstemp: No such file or directory
)
- Setup snap "core" (4650) security profiles (cannot load apparmor profile "snap-update-ns.core": cannot load apparmor profile: exit status 1
apparmor_parser output:
mkstemp: No such file or directory
)


zypper wp mkstemp says that nothing provides 'mkstemp'

How can I fix that?

malcolmlewis
11-Jun-2018, 02:11
I'm trying to install snaps via snapd end get such error message


griwa@linux-xmmp:~> sudo snap install vuze-vs
error: cannot perform the following tasks:
- Setup snap "core" (4650) security profiles (cannot setup apparmor for snap "core": cannot load apparmor profile "snap-update-ns.core": cannot load apparmor profile: exit status 1
apparmor_parser output:
mkstemp: No such file or directory
)
- Setup snap "core" (4650) security profiles (cannot load apparmor profile "snap-update-ns.core": cannot load apparmor profile: exit status 1
apparmor_parser output:
mkstemp: No such file or directory
)


zypper wp mkstemp says that nothing provides 'mkstemp'

How can I fix that?
Hi and welcome to the Forum :)
How did you install the non-standard (for SLED 12 SP3) application snapd?

smflood
12-Jun-2018, 16:45
On 09/06/18 22:24, BMX wrote:

> I'm trying to install snaps via snapd end get such error message
>
>
> Code:
> --------------------
> griwa@linux-xmmp:~> sudo snap install vuze-vs
> error: cannot perform the following tasks:
> - Setup snap "core" (4650) security profiles (cannot setup apparmor for snap "core": cannot load apparmor profile "snap-update-ns.core": cannot load apparmor profile: exit status 1
> apparmor_parser output:
> mkstemp: No such file or directory
> )
> - Setup snap "core" (4650) security profiles (cannot load apparmor profile "snap-update-ns.core": cannot load apparmor profile: exit status 1
> apparmor_parser output:
> mkstemp: No such file or directory
> )
>
> --------------------
>
>
> zypper wp mkstemp says that nothing provides 'mkstemp'
>
> How can I fix that?

The forum prefix indicates that you are using SLED12 SP3. Is this
correct? Please can you post the output from "cat /etc/*release".

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

BMX
14-Jun-2018, 16:38
Hi and welcome to the Forum :)
How did you install the non-standard (for SLED 12 SP3) application snapd?

I use repository for openSUSE Leap 42.1

Maybe the problem with Apparmor profiles?


griwa@linux-xmmp:~> sudo apparmor_status
apparmor module is loaded.
39 profiles are loaded.
39 profiles are in enforce mode.
/sbin/klogd
/sbin/syslog-ng
/sbin/syslogd
/usr/lib/apache2/mpm-prefork/apache2
/usr/lib/apache2/mpm-prefork/apache2//DEFAULT_URI
/usr/lib/apache2/mpm-prefork/apache2//HANDLING_UNTRUSTED_INPUT
/usr/lib/apache2/mpm-prefork/apache2//phpsysinfo
/usr/lib/colord
/usr/lib/dovecot/anvil
/usr/lib/dovecot/auth
/usr/lib/dovecot/config
/usr/lib/dovecot/deliver
/usr/lib/dovecot/dict
/usr/lib/dovecot/dovecot-auth
/usr/lib/dovecot/dovecot-lda
/usr/lib/dovecot/imap
/usr/lib/dovecot/imap-login
/usr/lib/dovecot/lmtp
/usr/lib/dovecot/log
/usr/lib/dovecot/managesieve
/usr/lib/dovecot/managesieve-login
/usr/lib/dovecot/pop3
/usr/lib/dovecot/pop3-login
/usr/lib/dovecot/ssl-params
/usr/sbin/avahi-daemon
/usr/sbin/dnsmasq
/usr/sbin/dovecot
/usr/sbin/identd
/usr/sbin/mdnsd
/usr/sbin/nmbd
/usr/sbin/nscd
/usr/sbin/ntpd
/usr/sbin/smbd
/usr/sbin/smbldap-useradd
/usr/sbin/smbldap-useradd///etc/init.d/nscd
/usr/sbin/winbindd
/usr/{sbin/traceroute,bin/traceroute.db}
/var/lib/snapd/apparmor/profiles/snap-update-ns.core
/{usr/,}bin/ping
0 profiles are in complain mode.
3 processes have profiles defined.
3 processes are in enforce mode.
/usr/lib/colord (1891)
/usr/sbin/avahi-daemon (1053)
/usr/sbin/nscd (1027)
0 processes are in complain mode.
0 processes are unconfined but have a profile defined.

BMX
14-Jun-2018, 16:41
On 09/06/18 22:24, BMX wrote:

> I'm trying to install snaps via snapd end get such error message
>
>
> Code:
> --------------------
> griwa@linux-xmmp:~> sudo snap install vuze-vs
> error: cannot perform the following tasks:
> - Setup snap "core" (4650) security profiles (cannot setup apparmor for snap "core": cannot load apparmor profile "snap-update-ns.core": cannot load apparmor profile: exit status 1
> apparmor_parser output:
> mkstemp: No such file or directory
> )
> - Setup snap "core" (4650) security profiles (cannot load apparmor profile "snap-update-ns.core": cannot load apparmor profile: exit status 1
> apparmor_parser output:
> mkstemp: No such file or directory
> )
>
> --------------------
>
>
> zypper wp mkstemp says that nothing provides 'mkstemp'
>
> How can I fix that?

The forum prefix indicates that you are using SLED12 SP3. Is this
correct? Please can you post the output from "cat /etc/*release".

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

Yes, you're right.

griwa@linux-xmmp:~> cat /etc/*release
NAME="SLED"
VERSION="12-SP3"
VERSION_ID="12.3"
PRETTY_NAME="SUSE Linux Enterprise Desktop 12 SP3"
ID="sled"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:suse:sled:12:sp3"
SUSE Linux Enterprise Desktop 12 (x86_64)
VERSION = 12
PATCHLEVEL = 3
# This file is deprecated and will be removed in a future service pack or release.
# Please check /etc/os-release for details about this release.

malcolmlewis
14-Jun-2018, 17:13
On Thu 14 Jun 2018 03:44:02 PM CDT, BMX wrote:

malcolmlewis;52991 Wrote:
> Hi and welcome to the Forum :)
> How did you install the non-standard (for SLED 12 SP3) application
> snapd?

I use repository for openSUSE Leap 42.1

Maybe the problem with Apparmor profiles?


Code:
--------------------
griwa@linux-xmmp:~> sudo apparmor_status
apparmor module is loaded.
39 profiles are loaded.
39 profiles are in enforce mode.
/sbin/klogd
/sbin/syslog-ng
/sbin/syslogd
/usr/lib/apache2/mpm-prefork/apache2
/usr/lib/apache2/mpm-prefork/apache2//DEFAULT_URI
/usr/lib/apache2/mpm-prefork/apache2//HANDLING_UNTRUSTED_INPUT
/usr/lib/apache2/mpm-prefork/apache2//phpsysinfo
/usr/lib/colord
/usr/lib/dovecot/anvil
/usr/lib/dovecot/auth
/usr/lib/dovecot/config
/usr/lib/dovecot/deliver
/usr/lib/dovecot/dict
/usr/lib/dovecot/dovecot-auth
/usr/lib/dovecot/dovecot-lda
/usr/lib/dovecot/imap
/usr/lib/dovecot/imap-login
/usr/lib/dovecot/lmtp
/usr/lib/dovecot/log
/usr/lib/dovecot/managesieve
/usr/lib/dovecot/managesieve-login
/usr/lib/dovecot/pop3
/usr/lib/dovecot/pop3-login
/usr/lib/dovecot/ssl-params
/usr/sbin/avahi-daemon
/usr/sbin/dnsmasq
/usr/sbin/dovecot
/usr/sbin/identd
/usr/sbin/mdnsd
/usr/sbin/nmbd
/usr/sbin/nscd
/usr/sbin/ntpd
/usr/sbin/smbd
/usr/sbin/smbldap-useradd
/usr/sbin/smbldap-useradd///etc/init.d/nscd
/usr/sbin/winbindd
/usr/{sbin/traceroute,bin/traceroute.db}
/var/lib/snapd/apparmor/profiles/snap-update-ns.core
/{usr/,}bin/ping
0 profiles are in complain mode.
3 processes have profiles defined.
3 processes are in enforce mode.
/usr/lib/colord (1891)
/usr/sbin/avahi-daemon (1053)
/usr/sbin/nscd (1027)
0 processes are in complain mode.
0 processes are unconfined but have a profile defined.

--------------------




Hi
Well aside from openSUSE Leap 42.1 is at End of Life (no longer
supported) for sometime and are not compatible with SLE, especially 12
SP3.

If your really wanting to use it, then I would suggest you ask the
maintainers to add SLE 12 backports and build against that;
https://build.opensuse.org/project/show/system:snappy

If built against backports then you could ask them to push into
Tubleweed, then it could end up in SUSE Package Hub.

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-23-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

smflood
14-Jun-2018, 22:44
BMX Wrote in message:

> I use repository for openSUSE Leap 42.1
>
> Maybe the problem with Apparmor profiles?

No the problem is with you enabling openSUSE repos on a SLED
machine - openSUSE and SUSE Linux Enterprise are not compatible
with each other, at least not until SLE12 SP3.

HTH.
--
Simon Flood
SUSE Knowledge Partner


----Android NewsGroup Reader----
http://usenet.sinaapp.com/