PDA

View Full Version : aarch64 subscription confusion



peterhurley
05-Aug-2018, 20:21
I'm struggling to understand SLES aarch64 options for the RPi. Hopefully someone can clear this up.

My subscription for SLES 12 SP2 expired.
How do i get extend/buy a new subscription?
AFAICT not through scc.suse.com and not here https://www.suse.com/shop/server/

I have developers subscriptions for SLES for ARM.
But I can't download the SLES 12 SP3 ARM iso nor the SLES 15 ARM or the SLES 15 ARM/Pi iso (both say "We're sorry, we are unable to complete the download at this time.")
Is the download server broken (for several days) or is there some issue with my SUSE account?

Thanks

malcolmlewis
05-Aug-2018, 20:54
Hi and welcome to the forum :)
You should be able to click on the shop link, top right of the page?

AFAIK it's not an upgrade, fresh install for SLES15 since SCC doesn't show the new repositories with a SLES 12 SP2 subscription.

If you have an active SLES 15 developer subscription for the RPi, you should be able to use SUSEConnect to deregister the system, then use your new code to register?

If this works, you should be able to use zypper migration to update the system?


Have you tried this download link;

https://download.suse.com/protected/Summary.jsp?buildid=FETaGhmHeBo~

If the above link doesn't work, you might try clearing out your browser cookies for SUSE and trying again.

smflood
06-Aug-2018, 12:00
On 05/08/18 20:24, peterhurley wrote:

> I'm struggling to understand SLES aarch64 options for the RPi. Hopefully
> someone can clear this up.
>
> My subscription for SLES 12 SP2 expired.
> How do i get extend/buy a new subscription?
> AFAICT not through scc.suse.com and not here
> https://www.suse.com/shop/server/

With SLES12 SP2 there was a later "for Raspberry Pi" release which had
it's own set of registration codes which were valid for a year. Now that
SLES12 SP3 and SLES15 are available those "for Raspberry Pi" codes no
longer appear to be available.

> I have developers subscriptions for SLES for ARM.

These should work for both SLES12 SP3 and SLES15 for ARM for Raspberry Pi.

> But I can't download the SLES 12 SP3 ARM iso nor the SLES 15 ARM or the
> SLES 15 ARM/Pi iso (both say "We're sorry, we are unable to complete the
> download at this time.")
> Is the download server broken (for several days) or is there some issue
> with my SUSE account?

I suspect, as Malcolm has already suggested, that this is a cookies
issue so clear your suse.com cookies then retry.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------