PDA

View Full Version : SLES 11 SP4 Package "yast2-migration" not available



AAEBHolding
06-Aug-2018, 23:33
I am trying to upgrade SLES 11 SP4 to SLES 12 according to this: https://www.suse.com/documentation/sles-12/book_sle_deployment/data/sec_update_migr_yast_onlinemigr.html

Point 5:
Install the package yast2-migration and its dependencies (in YaST under Software > Software Management).

My small problem is: The package yast2-migration is not available there.

What am I doing wrong, how can I install it?

smflood
07-Aug-2018, 13:12
On 06/08/18 23:34, AAEBHolding wrote:

> I am trying to upgrade SLES 11 SP4 to SLES 12 according to this:
> https://www.suse.com/documentation/sles-12/book_sle_deployment/data/sec_update_migr_yast_onlinemigr.html
>
> Point 5:
> Install the package yast2-migration and its dependencies (in YaST under
> Software > Software Management).
>
> My -small -problem is: The package yast2-migration is not available
> there.
>
> What am I doing wrong, how can I install it?

You are trying to follow the instructions for an online upgrade from an
earlier SLES12 Service Pack to SLES12 SP3.

From
https://www.suse.com/documentation/sles-12/book_sle_deployment/data/sec_update_sle_paths.html



Upgrading from SUSE Linux Enterprise 11 SP4

Upgrading from SLE 11 SP4 to SLE 12 SP3 is only supported via an offline
upgrade. Refer to Section 19.2, Online and Offline Upgrade for details.


Please see
https://www.suse.com/documentation/sles-12/book_sle_deployment/data/cha_update_offline.html

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

AAEBHolding
07-Aug-2018, 21:20
I apologize for my imprecise reading. I could now upgrade that far from SLES 11.4 to 12.3 but I have now this very serious issue:

https://forums.suse.com/showthread.php?12473-After-offline-upgrade-from-SLES-11-4-to-12-3-I-cannot-boot&p=53860#post53860

Any idea how to fix it? May be the problem is that the SLES 11.2 VM was originally created 4 years ago on a XS 6.2 with a SLES 11.2 template and now the template has a wrong entry regarding the boot loaded which changed due to the upgrade to SLES 12.3

AAEBHolding
08-Aug-2018, 06:14
Thank you Simon very much! I could finally fix all issues and the VM works and starts perfectly!

smflood
15-Aug-2018, 12:28
On 08/08/18 06:24, AAEBHolding wrote:

> Thank you Simon very much! I could finally fix all issues and the VM
> works and starts perfectly!

That's good to hear! Thanks for taking the time to report back.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

AAEBHolding
15-Aug-2018, 12:52
On 08/08/18 06:24, AAEBHolding wrote:

> Thank you Simon very much! I could finally fix all issues and the VM
> works and starts perfectly!

That's good to hear! Thanks for taking the time to report back.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

I wanted to thank you with the star but this forum software is somehow too restrictive and I have to "[I]spread" the star to somebody else first....
Please be aware of that I am very grateful for the support I get here. I am too small for a professional support and I love to maintain my infrastructure on my own because I find it very interesting!