PDA

View Full Version : SLES 12 SP3 Need help in configuring XRDP on SUSE Linux ESS 12 SP3



rickjackson257
08-Nov-2018, 10:30
Hello Everyone,

All these test activity I am carrying out on my AWS instance for my test purposes.

I am bit of new Linux playground and I needed your guys expertise for configuring it. I am trying to install & configuring SUSE Linux Enterprise Server 12 SP3 (HVM), SSD Volume Type on AWS & stuck up. So need your help. Actually I am trying to configure XRDP on the AWS instance.

I am trying to enable XRDP on my SUSE Linux Enterprise Server 12 SP3 (HVM), SSD Volume Type instance but I am not getting success for activating the same. I followed this tutorial but no success : https://www.suse.com/documentation/sles-for-sap-12/book_s4s/data/cha_s4s_configure_rdp.html'

Previously : All these options were pretty simple & straight forward on SUSE Linux Enterprise Server 11 SP4 (HVM), SSD Volume Type. Can anybody please through some light on this !! how to configure Linux instance so that I can continue with the installation of SAP B1 9.3.

Current Issue : Getting the logging screen & then everything is blank, I can do anything on the screen. No UI nothing, Even I tried setting the display to 16-bit or 24-bit only but no success.

So let me know your thoughts or suggest some document which explains how to configure Linux 12 for XRDP.

Thanks

Rahul Jain

jmozdzen
08-Nov-2018, 10:48
Hi Rahul,

I cannot be of much help regarding XRDP (gave it a try on a different platform and then put it on my personal blacklist, since I have X11 on all my clients), but since you ask for "thoughts" as well: I definitely avoid running X servers on our server systems, but use ssh connects instead. Much more easier to handle, less network demands, and if you're trying to use YaST2, it'll run without X, too.

If you absolutely need X11 tools, tunnel X11 through the ssh session and use some local X11 server. Easy on Linux clients, and available for those other platforms, too ;)

But keep in mind: That's my *opinion*, nothing more.

Regards,
J

rickjackson257
08-Nov-2018, 12:17
Thanks for your reply.

Anybody can please help out on this issue !!!

ab
08-Nov-2018, 16:51
I have not done so with an AWS instance, but I have setup xrdp on SLES and
openSUSE many times in the past and it was pretty easy. My notes for
doing so on SLES 12 SP2 (or later hopefully) follow:



zypper in xrdp
systemctl enable xrdp
systemctl start xrdp

#Configure Yast (firewall) to allow access to TCP 3389, if not forwarding
to that port via SSH as I do which is more secure:
yast firewall


That's about it, at least for me in the past with SLES 12.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.

rickjackson257
09-Nov-2018, 22:57
My issue has been solved !!!


Below are the steps I performed & it will be helpful for them who stumble upon the same issue.

# zypper update ( to update SUSE Linux Ent. Server)
# zypper install -t pattern gnome-basic
# zypper install xrdp

Enable VNC Remote Login
# Open yast, Select "Network Services", Select first entry "Remote Administration with VNC"
# Enable service

Configure Window Manager to use Gnome
Edit file /etc/sysconfig/windowmanager
Change entry DEFAULT_WM="" to DEFAULT_WM="gnome

Startup the RDP service and make it start automatically after Reboot
# service xrdp start
# chkconfig --set xrdp on

# systemctl start xrdp
# systemctl enable xrdp

Above are the steps which I performed to get the activate & use RDP session through my windows, If in-case anybody have any question let me know I will be happy to assist you.

Thanks again everyone for helping out.

Regards,
Rahul Jain

ab
10-Nov-2018, 13:59
Great information; the details you provided, and the comments with the
commands in particular, will likely help others, so thank-you for thinking
about that.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.