PDA

View Full Version : SLES15: screen does not know the HOME an END key



nntp-user
13-Nov-2018, 08:40
Hi,

I am use the terminal emulator screen at SLES15. But in this terminal
emulation the two keys HOME and END does not act as expected. When
pressed nothing happens :-(

Until SLES11 when pressed the cursor jump to the beginning or the end of
the line.

Is there a config file at the SLES15 to adjust this to get the same
behavior as at SLES11? And what are the correct settings?

Bernd

jmozdzen
13-Nov-2018, 12:46
Hi Bernd,

it might be a mismatch of terminal types (the one facilitated inside the "screen" environment, versus what you actual terminal program, i. e. "putty", is using).

Assuming that the special keys work before invoking "screen", could you please check how $TERM is set in the invoking shell, and it's value once inside the "screen" environment? "tset -r" should provide the same information, iirc.

Regards,
J

nntp-user
13-Nov-2018, 14:54
Am 13.11.18 um 12:54 schrieb jmozdzen:
(...)
> it might be a mismatch of terminal types (the one facilitated inside the
> "screen" environment, versus what you actual terminal program, i. e.
> "putty", is using).
>
> Assuming that the special keys work before invoking "screen", could you
> please check how $TERM is set in the invoking shell, and it's value once
> inside the "screen" environment? "tset -r" should provide the same
> information, iirc.

Screen shows
TERM=screen.xterm-256color

and the 'normal' terminal shows
TERM=xterm-256color

and in both cases tset -r shows this settings.

Ah ...

When change the keyboard setting of the terminal emulation from Standard
(XFree 4) to Linux-Konsole, then the misbehavior like with screen is in
the normal terminal, too.

But where is the keyboard setting for screen?


Bernd

jmozdzen
13-Nov-2018, 15:17
Hi Bernd,


Am 13.11.18 um 12:54 schrieb jmozdzen:
(...)
> it might be a mismatch of terminal types (the one facilitated inside the
> "screen" environment, versus what you actual terminal program, i. e.
> "putty", is using).
>
> Assuming that the special keys work before invoking "screen", could you
> please check how $TERM is set in the invoking shell, and it's value once
> inside the "screen" environment? "tset -r" should provide the same
> information, iirc.

Screen shows
TERM=screen.xterm-256color

and the 'normal' terminal shows
TERM=xterm-256color

and in both cases tset -r shows this settings.

Ah ...

When change the keyboard setting of the terminal emulation from Standard
(XFree 4) to Linux-Konsole, then the misbehavior like with screen is in
the normal terminal, too.

But where is the keyboard setting for screen?


Bernd

just for testing, please "export TERM=xterm-256color; tset" once you're in your "screen", and retest the keys.

I just compared to my non-SLES system, there TERM is set to "screen" inside the "screen" environment. Maybe that's an alternative value to test, if above doesn't help.

Regards,
J

nntp-user
13-Nov-2018, 16:24
Am 13.11.18 um 15:24 schrieb jmozdzen:
>
> Hi Bernd,
(...)
>
> just for testing, please "export TERM=xterm-256color; tset" once
> you're in your "screen", and retest the keys.
Unfortunately this does not change the behavior of the keys.

> I just compared to my non-SLES system, there TERM is set to "screen"
> inside the "screen" environment. Maybe that's an alternative value
> to test, if above doesn't help.Even if I use screen instead of screen.xterm-256color as $TERM the
behavior is the same.

Bernd

jmozdzen
16-Nov-2018, 14:39
Hi Bernd & all,

> Unfortunately this does not change the behavior of the keys.

maybe someone else can jump in and offer some advice? I know that terminal control sequence mapping can be a hassle, but maybe it's something that has changed either in the termcaps or the "screen" program shipped with SLE 15?

Regards,
J

malcolmlewis
16-Nov-2018, 15:04
On Tue 13 Nov 2018 07:40:35 AM CST, nntp-user wrote:

Hi,

I am use the terminal emulator screen at SLES15. But in this terminal
emulation the two keys HOME and END does not act as expected. When
pressed nothing happens :-(

Until SLES11 when pressed the cursor jump to the beginning or the end
of the line.

Is there a config file at the SLES15 to adjust this to get the same
behavior as at SLES11? And what are the correct settings?

Bernd


Hi
If you hold the ctrl key and then press home and end?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.25-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!