PDA

View Full Version : Confused: How does one upgrade from SLED 12 to SLED 15?



wylbur
11-Dec-2018, 01:51
Due to some tech difficulties I'm needing to upgrade from SLED 12 SP3 to SLED 15. :(

[I've already done that part so that my computers are running SLED15 -- that's not the problem -- Just wanna make sure one understands I see this as an SCC problem.]


The SCC system doesn't seem to have a way to get a computer upgraded. There isn't a specific path to get from one level of SLED (in my case) to another within SCC.

I have not found a way to do this -- apparently using the assigned registration codes for the two physical machines I have doesn't actually accomplish this. :confused:

I found this out on Sat Nite when I went to put on maintenance and started getting messages about logging on to repositories :confused:

So, what am I missing?

I don't want to go back to the "60" day trial registration code for both of those systems, but what choice do I have?

If one has to pay a new subscription fee, how about being real clear and upfront about it and say so? Give me a DO SOMETHING button so I can make something like this happen. :cool:

malcolmlewis
11-Dec-2018, 03:55
Hi
So your systems are at SLED 15, but you can't register against your registration codes? Under Base Extensions and Products it should list SLED 15?

wylbur
11-Dec-2018, 19:44
apparently using the assigned registration codes for the two physical machines I have doesn't actually accomplish this

Yes, registration codes were accepted that were used for SLED12 SP3. But a week later, can't get maint and I get some strange messages here is the first of several that are produced within a window titled "User Authentication":


URL: https://scc.suse.com/access/services/1561?cookies=0&credentials=Basesystem_Module_15_x86_64

Check that this system is known to the registration server.
Authentication required for 'https://scc.suse.com/access/services/1561?cookies=0&credentials=Basesystem_Module_15_x86_64'


And so it puts our a user name of my email address and asks for a password. Nothing I have looked at with SCC matches this. And looking at the systems and how they are viewed, it seems that the registration codes were accepted.

malcolmlewis
11-Dec-2018, 20:14
Yes, registration codes were accepted that were used for SLED12 SP3. But a week later, can't get maint and I get some strange messages here is the first of several that are produced within a window titled "User Authentication":




And so it puts our a user name of my email address and asks for a password. Nothing I have looked at with SCC matches this. And looking at the systems and how they are viewed, it seems that the registration codes were accepted.
Hi
It's looking for the SCC credentials (/etc/zypp/SCCredentials). But sounds like it needs a cleanup and re-register to populate the system stored mirror credentials.



SUSEConnect -d
SUSEConnect --cleanup
SUSEConnect -e <email> -r <reg_code>
SUSEConnect --list-extensions
SUSEConnect ... add in your desired products and codes as required

wylbur
03-Jan-2019, 00:12
I tried that and it kinda almost worked. :)

So I attempted an UPDATE install of SLED15 and that seemed to have fixed the repositories and SCC.

About a week later, the package hub got unregistered :confused: , and I had to re-register it. This command
SUSEConnect -d helped me find that problem. Which I just fixed.

At any rate, things seem to be working better on my desktop (which is a 2 core CPU) after adding 1 GB of RAM. 4GB was just not enough, taking it to 5GB made a large difference. :cool: