PDA

View Full Version : Nagios



naren_bishayee
22-Jul-2012, 03:20
Hi all,
I'm using SLED-11SP2 32 bit with gnome only. I already add SDK sp2 & using "zypper in nagios*" I installed Nagios 3.0.6.xx, but after start the nagios service (service nagios start), whenever i try to open 127.0.0.1/nagios it ask me username & password & i dont know the password. One more important thing is that, after start the the service using above command, i also checked the status & it say dead.

linux-nxk1:~ # service nagios start
Starting Nagios done
linux-nxk1:~ # service nagios status
Checking for Nagios dead
linux-nxk1:~ #

I also tried to compile & install nagios from source, but i failed due to some dependency/compatibility.


Can any one please help me to install/configure the Nagios on SLED11SP2 system.

Thanks.

naren_bishayee
22-Jul-2012, 09:25
Hi all,
I just download nagios core & compile & successfully installed, also start the nagios service, but whenever i tri to open http://localhost/nagios/ on a browser, it display the following error,
"Object not found!"

But during installation (make install) the URL to access nagios is http://localhost/nagios/

Even i also cheked the process is running or not


linux-nxk1:~ # service nagios start
Starting nagios: done.
linux-nxk1:~ # service nagios status
nagios (pid 5468) is running...
linux-nxk1:~ # /usr/local/nagios/bin/nagiostats

Nagios Stats 3.4.1
Copyright (c) 2003-2008 Ethan Galstad (www.nagios.org)
Last Modified: 05-11-2012
License: GPL

CURRENT STATUS DATA
------------------------------------------------------
Status File: /usr/local/nagios/var/status.dat
Status File Age: 0d 0h 0m 1s
Status File Version: 3.4.1

Program Running Time: 0d 0h 3m 41s
Nagios PID: 5468
Used/High/Total Command Buffers: 0 / 0 / 4096

Total Services: 8
Services Checked: 8
Services Scheduled: 8
Services Actively Checked: 8
Services Passively Checked: 0
Total Service State Change: 0.000 / 0.000 / 0.000 %
Active Service Latency: 0.054 / 0.163 / 0.100 sec
Active Service Execution Time: 0.006 / 0.011 / 0.007 sec
Active Service State Change: 0.000 / 0.000 / 0.000 %
Active Services Last 1/5/15/60 min: 1 / 5 / 5 / 5
Passive Service Latency: 0.000 / 0.000 / 0.000 sec
Passive Service State Change: 0.000 / 0.000 / 0.000 %
Passive Services Last 1/5/15/60 min: 0 / 0 / 0 / 0
Services Ok/Warn/Unk/Crit: 0 / 0 / 0 / 8
Services Flapping: 0
Services In Downtime: 0

Total Hosts: 1
Hosts Checked: 1
Hosts Scheduled: 1
Hosts Actively Checked: 1
Host Passively Checked: 0
Total Host State Change: 0.000 / 0.000 / 0.000 %
Active Host Latency: 0.029 / 0.029 / 0.029 sec
Active Host Execution Time: 0.006 / 0.006 / 0.006 sec
Active Host State Change: 0.000 / 0.000 / 0.000 %
Active Hosts Last 1/5/15/60 min: 0 / 1 / 1 / 1
Passive Host Latency: 0.000 / 0.000 / 0.000 sec
Passive Host State Change: 0.000 / 0.000 / 0.000 %
Passive Hosts Last 1/5/15/60 min: 0 / 0 / 0 / 0
Hosts Up/Down/Unreach: 0 / 1 / 0
Hosts Flapping: 0
Hosts In Downtime: 0

Active Host Checks Last 1/5/15 min: 0 / 1 / 1
Scheduled: 0 / 1 / 1
On-demand: 0 / 0 / 0
Parallel: 0 / 1 / 1
Serial: 0 / 0 / 0
Cached: 0 / 0 / 0
Passive Host Checks Last 1/5/15 min: 0 / 0 / 0
Active Service Checks Last 1/5/15 min: 1 / 5 / 5
Scheduled: 1 / 5 / 5
On-demand: 0 / 0 / 0
Cached: 0 / 0 / 0
Passive Service Checks Last 1/5/15 min: 0 / 0 / 0

External Commands Last 1/5/15 min: 0 / 0 / 0


linux-nxk1:~ #



So, can anyone help me to figure this out.

smflood
23-Jul-2012, 12:05
On 22/07/2012 09:34, naren bishayee wrote:

> So, can anyone help me to figure this out.

Do you have a web server (Apache) installed and running?

If so, are there any errors reported in it's error log file? With
Apache, by default the error log file is /var/log/apache2/error_log.

HTH.
--
Simon
Novell/SUSE/NetIQ Knowledge Partner

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------

naren_bishayee
26-Jul-2012, 08:04
Hi smflood,
I just checked the error_log & i found some thing,

[Thu Jul 26 12:29:45 2012] [warn] Init: Session Cache is not configured [hint: S
SLSessionCache]
[Thu Jul 26 12:29:46 2012] [notice] Apache/2.2.12 (Linux/SUSE) mod_ssl/2.2.12 Op
enSSL/0.9.8j-fips PHP/5.2.14 with Suhosin-Patch mod_mono/2.6.3 configured -- res
uming normal operations
[Thu Jul 26 12:30:10 2012] [error] [client 127.0.0.1] File does not exist: /srv/
www/htdocs/nagios
[Thu Jul 26 12:30:13 2012] [error] [client 127.0.0.1] File does not exist: /srv/
www/htdocs/nagios
[Thu Jul 26 12:30:16 2012] [error] [client 127.0.0.1] File does not exist: /srv/
www/htdocs/nagios3

/var/log/apache2/error_log lines 619-629/629 (END)


Can you please help me to figure this out.

smflood
26-Jul-2012, 14:46
On 26/07/2012 08:14, naren bishayee wrote:

> I just checked the error_log & i found some thing,
>
> [Thu Jul 26 12:29:45 2012] [warn] Init: Session Cache is not configured
> [hint: S
> SLSessionCache]
> [Thu Jul 26 12:29:46 2012] [notice] Apache/2.2.12 (Linux/SUSE)
> mod_ssl/2.2.12 Op
> enSSL/0.9.8j-fips PHP/5.2.14 with Suhosin-Patch mod_mono/2.6.3
> configured -- res
> uming normal operations
> [Thu Jul 26 12:30:10 2012] [error] [client 127.0.0.1] File does not
> exist: /srv/
> www/htdocs/nagios
> [Thu Jul 26 12:30:13 2012] [error] [client 127.0.0.1] File does not
> exist: /srv/
> www/htdocs/nagios
> [Thu Jul 26 12:30:16 2012] [error] [client 127.0.0.1] File does not
> exist: /srv/
> www/htdocs/nagios3
>
> /var/log/apache2/error_log lines 619-629/629 (END)
>
>
> Can you please help me to figure this out.

Okay so it looks like Apache is installed and running. The references to
/srv/www/htdocs/nagios and /srv/www/htdocs/nagios3 suggest that whilst
there is a /srv/www/htdocs directory there are not nagios and nagios3
sub-directories within?

What does 'ls -l /srv/www/htdocs' output?

I'm also slightly intrigued by the Apache/2.1.12 line - did you install
Apache as a package (perhaps from media or via channel) or compile it
(or any modules) yourself?

HTH.
--
Simon
Novell/SUSE/NetIQ Knowledge Partner

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------

naren_bishayee
27-Jul-2012, 19:25
Hello smflood,
I installed apache from packageManager (Yast-->Software Management)

naren_bishayee@linux-nxk1:~> ls -l /srv/www/htdocs/
total 96
-rw-r--r-- 1 root root 2434 Nov 26 2008 apache_pb2_ani.gif
-rw-r--r-- 1 root root 1797 Nov 26 2008 apache_pb2.gif
-rw-r--r-- 1 root root 1505 Nov 26 2008 apache_pb2.png
-rw-r--r-- 1 root root 2326 Nov 21 2004 apache_pb.gif
-rw-r--r-- 1 root root 2088 Nov 26 2008 apache_pb.png
drwxr-xr-x 9 naren_bishayee users 4096 May 3 03:55 drupal-7.14
-rw-r--r-- 1 root root 4637 Apr 26 13:11 esrealestate.php
-rw-r--r-- 1 root root 302 Jul 23 2008 favicon.ico
drwxr-xr-x 2 root root 4096 Sep 16 2011 gif
-rw-r--r-- 1 root root 44 Nov 21 2004 index.html
-rw-r--r-- 1 root root 2356 Feb 24 2009 info2html.css
drwxrwxr-x 11 naren_bishayee users 4096 Apr 24 17:43 phpldapadmin
drwxr-xr-x 9 root root 4096 Apr 24 20:38 phpmyadmin
-rw-r--r-- 1 root root 26 Nov 30 2011 robots.txt
-rw-r--r-- 1 root root 21143 Apr 30 16:00 settings.php
-rw-r--r-- 1 root root 437 Apr 25 18:52 test1.php
-rw-r--r-- 1 naren_bishayee users 942 May 24 19:12 test.php
drwxr-xr-x 5 33 video 4096 Jun 24 01:36 wordpress
naren_bishayee@linux-nxk1:~>

Magic31
31-Jul-2012, 21:50
Hello smflood,
I installed apache from packageManager (Yast-->Software Management)

naren_bishayee@linux-nxk1:~> ls -l /srv/www/htdocs/
total 96
-rw-r--r-- 1 root root 2434 Nov 26 2008 apache_pb2_ani.gif
-rw-r--r-- 1 root root 1797 Nov 26 2008 apache_pb2.gif
-rw-r--r-- 1 root root 1505 Nov 26 2008 apache_pb2.png
-rw-r--r-- 1 root root 2326 Nov 21 2004 apache_pb.gif
-rw-r--r-- 1 root root 2088 Nov 26 2008 apache_pb.png
drwxr-xr-x 9 naren_bishayee users 4096 May 3 03:55 drupal-7.14
-rw-r--r-- 1 root root 4637 Apr 26 13:11 esrealestate.php
-rw-r--r-- 1 root root 302 Jul 23 2008 favicon.ico
drwxr-xr-x 2 root root 4096 Sep 16 2011 gif
-rw-r--r-- 1 root root 44 Nov 21 2004 index.html
-rw-r--r-- 1 root root 2356 Feb 24 2009 info2html.css
drwxrwxr-x 11 naren_bishayee users 4096 Apr 24 17:43 phpldapadmin
drwxr-xr-x 9 root root 4096 Apr 24 20:38 phpmyadmin
-rw-r--r-- 1 root root 26 Nov 30 2011 robots.txt
-rw-r--r-- 1 root root 21143 Apr 30 16:00 settings.php
-rw-r--r-- 1 root root 437 Apr 25 18:52 test1.php
-rw-r--r-- 1 naren_bishayee users 942 May 24 19:12 test.php
drwxr-xr-x 5 33 video 4096 Jun 24 01:36 wordpress
naren_bishayee@linux-nxk1:~>


Hi Naren,

Instead of trying to get a mixture or SUSE packages and Nagios self compiled packages working, I find it much easier to have a look and see if the package is available through the openSUSE build service ( http://software.opensuse.org being one spot where you can search).

There is a monitoring repository that you can use, and currently it holds the 3.4 Nagios packages.

You can find it here : http://download.opensuse.org/repositories/server:/monitoring/SLE_11_SP2/

I'd opt to first try to clean up the configurations for apache and nagios you have created so far... and try with fresh rpm installs though YaST's Software Management tool after having added the monitoring repositorie(s) to you SLES 11 SP2 system.

Optionally it might be a good idea to setup a clean system to use with Nagios, as it seems to getting a bit messy with other apache configurations you have going on there.

Hope that helps,
Willem