PDA

View Full Version : Unsupported Modules on SELS11



suse9-pes
22-May-2009, 07:16
Hi,

I have few queries regarding support option available for SLES, before
I ask you the query let me give you the background of it. I was going
thru the release notes of SLES11 and in topic 9.4 Kernel Modules
observed the following line *-“Please remember that loading and running
unsupported modules will make the kernel and the whole system
unsupported by Novell.” -*

Now usually third party software/modules are not supported by Novell
and taint the kernel when loaded. Following are the queries:


*1) * Does this limitation applicable on SLES9 and SLES10? In my
knowledge it is not applicable and SLES9, 10 and in those cases
inserting unsupported modules *will not make entire system unsupported*.

*2) * In many situations it is required to insert an unsupported
module, so what could be the possible solution to overcome the
limitation.
*3) * How can a module made supported module or external module, so
that the above problem can be overcome.
*4) * To make a module supported by novell, who can be contacted and
what would be the process for getting that support.

Will appreciate quick responce

Thanks


--
suse9-pes
------------------------------------------------------------------------
suse9-pes's Profile: http://forums.novell.com/member.php?userid=17825
View this thread: http://forums.novell.com/showthread.php?t=373679

dhc5251
20-Jan-2010, 09:46
suse9-pes;1795774 Wrote:
> Hi,
>
> I have few queries regarding support option available for SLES, before
> I ask you the query let me give you the background of it. I was going
> thru the release notes of SLES11 and in topic 9.4 Kernel Modules
> observed the following line *-“Please remember that loading and running
> unsupported modules will make the kernel and the whole system
> unsupported by Novell.” -*
>
> Now usually third party software/modules are not supported by Novell
> and taint the kernel when loaded. Following are the queries:
>
>
> *1) * Does this limitation applicable on SLES9 and SLES10? In my
> knowledge it is not applicable and SLES9, 10 and in those cases
> inserting unsupported modules *will not make entire system unsupported*.
>
> *2) * In many situations it is required to insert an unsupported
> module, so what could be the possible solution to overcome the
> limitation.
> *3) * How can a module made supported module or external module, so
> that the above problem can be overcome.
> *4) * To make a module supported by novell, who can be contacted and
> what would be the process for getting that support.
>
> Will appreciate quick responce
>
> Thanks

Novell recommend to only use the modules support by Novell, he can't
warrant to any other 3rd party modules likes any other co or org.
You can find the module first in cd/iso.
if you know what you do and the usage, you can insert the unsopport
module,


--
dhc5251
------------------------------------------------------------------------
dhc5251's Profile: http://forums.novell.com/member.php?userid=76257
View this thread: http://forums.novell.com/showthread.php?t=373679