PDA

View Full Version : SLES-Other SLES 12.4 - libcurl-devel version 5 years old.



AAEBHolding
15-Jan-2019, 22:19
I am compiling my own PHP 7.2.x version. For other project I use my custom build curl [7.63.0] and openssl [1.1.0h]. I keep the distribution Apache version 2.4.23

I have now this issue:
Due to the fact the SLES 12.4 libcurl-devel version is 5 years old [7.37.0] I wanted to compile PHP with my own build. Unfortunately this doesn't work [Apache crashes when I try to start it] which I believe is due to the incompatible openssl version [which is used by curl].

My question:
Is there a plan to update libcurl-devel to a more recent version? 5 years is already too old - especially in the internet access library.

@Administrator:
In the prefix SLES 12 SP4 is missing...

malcolmlewis
15-Jan-2019, 23:03
Hi
Do you have the SLE SDK repository added and active, I see version 7.60.0?



Information for package libcurl-devel:
--------------------------------------
Repository : SLE-SDK12-SP4-Pool for x86_64 SLED-SP4
Name : libcurl-devel
Version : 7.60.0-2.11


Thanks for the Prefix heads up, asked the Admin to add :)

AAEBHolding
09-Mar-2019, 14:24
Hi
Do you have the SLE SDK repository added and active, I see version 7.60.0?


Yep. Exactly this was the problem [Star added :-)]. May be I am naive but I expected the repository will be upgraded as well when I ran the upgrade from 12.3 to 12.4 - instead of this the 12.3 remained registered which caused then of course the problem.