PDA

View Full Version : SLES 11 SP3 Can i install opencv in SLES 11?



yashirathore_90
16-Jan-2019, 15:29
Hi,

I am trying to use an application which needs libopencv dependency package, but in SLES 11 there is no libopencv package whereas it is available in opensuse leap 15.

So , can i install libopencv package in SLES 11?

Thank you for help in advance.

malcolmlewis
16-Jan-2019, 15:46
Hi,

I am trying to use an application which needs libopencv dependency package, but in SLES 11 there is no libopencv package whereas it is available in opensuse leap 15.

So , can i install libopencv package in SLES 11?

Thank you for help in advance.
Hi
What version of opencv is required? I'm sure there is a way, but would be unsupported.

yashirathore_90
17-Jan-2019, 06:20
Hi
What version of opencv is required? I'm sure there is a way, but would be unsupported.

We want to install opencv 2.4 in our system, would it work in SLES 11 properly?

malcolmlewis
17-Jan-2019, 13:55
We want to install opencv 2.4 in our system, would it work in SLES 11 properly?
Hi
There are multiple 2.4.x versions on the openSUSE Build Service from 'community' repositories, did you have a specific 2.4.x version or anything in the 2.4 series?

For example:
https://build.opensuse.org/package/show/home:markkp:openshot/opencv

No chance to upgrade your system to SLE 11 SP4?

yashirathore_90
18-Jan-2019, 06:33
Hi
There are multiple 2.4.x versions on the openSUSE Build Service from 'community' repositories, did you have a specific 2.4.x version or anything in the 2.4 series?

For example:
https://build.opensuse.org/package/show/home:markkp:openshot/opencv

No chance to upgrade your system to SLE 11 SP4?

Any version in the 2.4 series will be fine.

Sorry , but we want opencv in SLE 11 SP3, so is there any file for SP3 on internet?

yashirathore_90
22-Jan-2019, 15:18
Hi
There are multiple 2.4.x versions on the openSUSE Build Service from 'community' repositories, did you have a specific 2.4.x version or anything in the 2.4 series?

For example:
https://build.opensuse.org/package/show/home:markkp:openshot/opencv

No chance to upgrade your system to SLE 11 SP4?

I have installed SLE 11 SP4, but the package you have mentioned is not downloading the opencv package.

malcolmlewis
22-Jan-2019, 15:34
I have installed SLE 11 SP4, but the package you have mentioned is not downloading the opencv package.

Hi
Add the repository so it pulls everything in, then disable;



su -
zypper ar -f -g -n "repo-opencv" https://download.opensuse.org/repositories/home:/markkp:/openshot/SLE_11_SP4/ repo-opencv
zypper ref
zypper in opencv
zypper mr -d -R repo-opencv

yashirathore_90
23-Jan-2019, 12:05
Hi
Add the repository so it pulls everything in, then disable;



su -
zypper ar -f -g -n "repo-opencv" https://download.opensuse.org/repositories/home:/markkp:/openshot/SLE_11_SP4/ repo-opencv
zypper ref
zypper in opencv
zypper mr -d -R repo-opencv


Hi,
When i tried the above code, i am getting these messages:


zypper ar -f -g -n "repo-opencv" https://download.opensuse.org/repositories/home:/markkp:/openshot/SLE_11_SP4/ repo-opencv
command options:................
zypper ref
All repositories have been refreshed
zypper in opencv
Loading repository data...Reading installed packages...'opencv' not found in packages names. Trying capabilities. No provider of opencv found...

malcolmlewis
23-Jan-2019, 14:14
On Wed 23 Jan 2019 11:14:01 AM CST, yashirathore 90 wrote:

malcolmlewis;56335 Wrote:
> Hi
> Add the repository so it pulls everything in, then disable;
>
> >
Code:
--------------------
> >
> su -
> zypper ar -f -g -n "repo-opencv"
https://download.opensuse.org/repositories/home:/markkp:/openshot/SLE_11_SP4/
repo-opencv > zypper ref > zypper in opencv
> zypper mr -d -R repo-opencv
>
--------------------
> >

Hi,
When i tried the above code, i am getting these messages:

Code:
--------------------

zypper ar -f -g -n "repo-opencv"
https://download.opensuse.org/repositories/home:/markkp:/openshot/SLE_11_SP4/
repo-opencv command options:................ zypper ref
All repositories have been refreshed
zypper in opencv
Loading repository data...Reading installed packages...'opencv' not
found in packages names. Trying capabilities. No provider of opencv
found... --------------------




Hi
Can you show me the output from the command;


zypper lr -d



--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.25-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

yashirathore_90
24-Jan-2019, 08:02
Hi
Can you show me the output from the command;


zypper lr -d



--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.25-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!


Hi,
Output of the above command is :



yashi@linux-o1uk:~> zypper lr -d
# | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
--+--------------------------------------------------+--------------------------------------------------+---------+---------+----------+-------+-------------------------+--------
1 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
yashi@linux-o1uk:~>

yashirathore_90
24-Jan-2019, 12:23
Hi,
Output of the above command is :



yashi@linux-o1uk:~> zypper lr -d
# | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
--+--------------------------------------------------+--------------------------------------------------+---------+---------+----------+-------+-------------------------+--------
1 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
yashi@linux-o1uk:~>




I want to ask one more thing that, can i upgrade gcc version in SLE 11 SP4.(Current version is 4.3.4)
If i am upgrading it, then it is saying that highest available is already installed.

malcolmlewis
24-Jan-2019, 13:15
On Thu 24 Jan 2019 11:24:01 AM CST, yashirathore 90 wrote:

yashirathore_90;56362 Wrote:
> Hi,
> Output of the above command is :
>
> >
Code:
--------------------
> >
> yashi@linux-o1uk:~> zypper lr -d
> # | Alias |
Name | Enabled |
Refresh | Priority | Type | URI | Service >
--+--------------------------------------------------+--------------------------------------------------+---------+---------+----------+-------+-------------------------+--------
> 1 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 |
> SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 | Yes | No
> | 99 | yast2 | cd:///?devices=/dev/sr0 | >
> yashi@linux-o1uk:~> >
>
>
--------------------
> >

I want to ask one more thing that, can i upgrade gcc version in SLE 11
SP4.(Current version is 4.3.4)
If i am upgrading it, then it is saying that highest available is
already installed.




Hi
You have not added the opencv repository to your system, it should be
in the above output? You were root user when running the command to add?

If the system gets registered and available in the online repos it
should update.


--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.25-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!