PDA

View Full Version : Failure to start X windows after updating



davidehs
23-Jul-2012, 20:00
Dear SUSE colleagues,

I got a serious problem of losing the x windows for my server. I am using SUSE Linux Enterprise Server 11 (x86_64), with the patch level of 1. A couple of weeks ago, I did a system update from Yast. Everything worked fine except that the x window disappeared (became black screen) immediately after updating.

I restarted the system and input "startx" on the console. But it always stuck somewhere and show me a black screen. However, everything else ran great. I can ssh to it, do various calculation, and visit the apache server running on it.

I searched online and tried several times to restored the x windows system, but failed. Could you guys help figure out what is the problem?

I appreciate it very much.

The following is the information stored in the file ~/.xsession-errors.


X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux-eg 2.6.32.59-0.3-default #1 SMP 2012-04-27 11:14:44
+0200 x86_64
Build Date: 19 December 2011 06:05:06PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jul 18 17:24:09 2012
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "freetype" (module does not exist, 0)
(EE) MGA(0): [drm] Direct rendering only supported with G200/G400/G450/G550.
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
/etc/X11/xim: Checking whether an input method should be started.
/etc/X11/xim: user environment variable LANG=en_US.UTF-8
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_US.UTF-8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
GNOME_KEYRING_SOCKET=/tmp/keyring-2yVAzb/socket
SSH_AUTH_SOCK=/tmp/keyring-2yVAzb/socket.ssh
GNOME_KEYRING_PID=2843
/usr/lib/gnome-settings-daemon/gnome-settings-daemon: symbol lookup error: /usr/lib64/gio
/modules/libdconfsettings.so: undefined symbol: g_settings_backend_get_type
Window manager warning: Failed to read saved session file /home/david/.config/metacity/se
ssions/1078c31dcc2411dc451342646651151200000028160015.ms: Failed to open file '/home/davi
d/.config/metacity/sessions/1078c31dcc2411dc451342646651151200000028160015.ms' : No such f
ile or directory
gnome-panel: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings.so: undefined s
ymbol: g_settings_backend_get_type
nautilus: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings.so: undefined symb
ol: g_settings_backend_get_type
Exit: gpk_check_privileged_user returned FALSE
Traceback (most recent call last):
File "/usr/lib64/python2.6/site-packages/system-config-printer/applet.py", line 20, in
<module>
import cups
ImportError: No module named cups
gnome-volume-control-applet: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings
.so: undefined symbol: g_settings_backend_get_type

Thanks,

David

enovaklbank
25-Jul-2012, 13:22
That seems to fail on many levels.
Backup&delete your /etc/X11/xorg.conf file and run sax2.

davidehs
31-Jul-2012, 19:45
Hi Enovaklbank,

Thanks for your suggestion. I tried it. The x-window still did not work and failed at the same reason. Before updating, everything worked just fine.

I tried to reply this thread several days ago. But this forum kept blocking me out and said I had no right to reply.

It looks like a pretty complicated reason that leads to x-window failure on my server. Please let me know if you or anybody get more ideas.

I appreciate it.

malcolmlewis
31-Jul-2012, 19:59
Hi Enovaklbank,

Thanks for your suggestion. I tried it. The x-window still did not
work and failed at the same reason. Before updating, everything worked
just fine.

I tried to reply this thread several days ago. But this forum kept
blocking me out and said I had no right to reply.

It looks like a pretty complicated reason that leads to x-window
failure on my server. Please let me know if you or anybody get more
ideas.

I appreciate it.



Hi
Sure everything is up to date and your repositories are active?


zypper lr -d
zypper ref
zypper lu


--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 2 days 15:31, 4 users, load average: 0.37, 0.34, 0.34
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

davidehs
31-Jul-2012, 22:37
I did all the updates using the command "zypper update". When run the two commands suggested by Malcolmlewis, it indicate the update is complete as following.

> sudo zypper ref
Repository 'dell-preinstall' is up to date.
Repository 'devel:languages:R:patched' is up to date.
Repository 'SLES11-SP1-Pool' is up to date.
Repository 'SLES11-SP1-Updates' is up to date.
All repositories have been refreshed.
> zypper lu
Loading repository data...
Reading installed packages...
No updates found.

Then, I ran sax2. It failed again. The followings are the output when running sax2.

SaX: no X-Server is runningSaX: will start own server if needed
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.SPP: prepare device [1] profile: BMC
SPP: prepare device [0] profile: BMCSPP: including prepared profile(s)...
SPP: prepare device [0] profile: nobus
SPP: including prepared profile(s)...

SaX: startup


Any ideas?

Thanks for you guys help!!

malcolmlewis
31-Jul-2012, 22:51
I did all the updates using the command "zypper update". When run the
two commands suggested by Malcolmlewis, it indicate the update is
complete as following.

> sudo zypper ref
Repository 'dell-preinstall' is up to date.
Repository 'devel:languages:R:patched' is up to date.
Repository 'SLES11-SP1-Pool' is up to date.
Repository 'SLES11-SP1-Updates' is up to date.
All repositories have been refreshed.
> zypper lu
Loading repository data...
Reading installed packages...
No updates found.

Then, I ran sax2. It failed again. The followings are the output when
running sax2.

SaX: no X-Server is runningSaX: will start own server if needed
ISaX: could not import file: /var/cache/sax/files/config at
/usr/sbin/isax line 199.ISaX: could not import file:
/var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at
/usr/sbin/isax line 199.ISaX: could not import file:
/var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at
/usr/sbin/isax line 199.ISaX: could not import file:
/var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at
/usr/sbin/isax line 199.SPP: prepare device [1] profile: BMC
SPP: prepare device [0] profile: BMCSPP: including prepared
profile(s)...
SPP: prepare device [0] profile: nobus
SPP: including prepared profile(s)...

SaX: startup


Any ideas?

Thanks for you guys help!!



Hi
Log out from the desktop, then press ctrl+alt+F1 to get to a console
(VT) login. Log in as root user, then;


init 3
sax2 -r
init 5 && exit


--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 2 days 18:23, 4 users, load average: 0.57, 0.44, 0.39
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

davidehs
01-Aug-2012, 14:24
Hi Malcolmlewis,

Just to be safe. I have a couple of programs which are running now on my server. These programs will keep running for 24-48 hours and are pretty important to my project. If I execute the commands you suggest, will the system be halted, or rebooted? In such cases, all my programs will be stopped and I have to rerun them, right?

My programs are just written with python/R and used to analyze my experiment data.

Thanks for clarifying.

David

malcolmlewis
01-Aug-2012, 14:55
Hi Malcolmlewis,

Just to be safe. I have a couple of programs which are running now on
my server. These programs will keep running for 24-48 hours and are
pretty important to my project. If I execute the commands you suggest,
will the system be halted, or rebooted? In such cases, all my programs
will be stopped and I have to rerun them, right?

My programs are just written with python/R and used to analyze my
experiment data.

Thanks for clarifying.

David



Hi
Unless the programs where started at runlevel 3 (which I doubt) they
will stop running, better to wait ;)

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 3 days 10:27, 3 users, load average: 0.15, 0.31, 0.71
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

davidehs
01-Aug-2012, 15:40
Hi Malcolmlewis,

Thank you very much. I will wait until the programs are done.

David

davidehs
03-Aug-2012, 17:04
I restarted the server, and run the commands suggested by Malcolmlewis. But after execute "startx", still nothing showed up.

Here are the output in ~/.xsession-errors.

X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux-eg 2.6.32.59-0.7-default #1 SMP 2012-07-13 15:50:56 +0200 x86_64
Build Date: 29 June 2012 07:48:20PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 3 11:29:56 2012
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "freetype" (module does not exist, 0)
(EE) MGA(0): [drm] Direct rendering only supported with G200/G400/G450/G550.
/etc/X11/xim: Checking whether an input method should be started.
/etc/X11/xim: user environment variable LANG=en_US.UTF-8
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_US.UTF-8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
GNOME_KEYRING_SOCKET=/tmp/keyring-5XazpM/socket
SSH_AUTH_SOCK=/tmp/keyring-5XazpM/socket.ssh
GNOME_KEYRING_PID=7178
/usr/lib/gnome-settings-daemon/gnome-settings-daemon: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings.so: undefined symbol: g_settings_backend_get_type
Window manager warning: Failed to read saved session file /home/david/.config/metacity/sessions/1081cd1b45c5713a76134400779937436200000071490015.m s: Failed to open file '/home/david/.config/metacity/sessions/1081cd1b45c5713a76134400779937436200000071490015.m s': No such file or directory
gnome-panel: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings.so: undefined symbol: g_settings_backend_get_type
nautilus: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings.so: undefined symbol: g_settings_backend_get_type
Exit: gpk_check_privileged_user returned FALSE
gnome-volume-control-applet: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings.so: undefined symbol: g_settings_backend_get_type
python: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings.so: undefined symbol: g_settings_backend_get_type

I am wondering whether it is the reason that I have ever changed the software updating repositories, which probably caused the updating was not complete. But I do not know which repositories I should choose now. Here are the output of yast.

Priority │Enabled│Autorefresh│Name │URL │
75 │ │ │openSUSE:12.1:Update │http://download.opensuse.org/update/1│
80 │ │ │openSUSE:11.4 │http://download.opensuse.org/distribu│
99 (Default)│ x │ │dell-preinstall │file:/var/os │
99 (Default)│ x │ x │devel:languages:R:patched │http://download.opensuse.org/reposito│
99 (Default)│ │ x │SLE11-SP1-Debuginfo-Pool │https://nu.novell.com/repo/$RCE/SLE11│
99 (Default)│ │ x │SLE11-SP1-Debuginfo-Updates│https://nu.novell.com/repo/$RCE/SLE11│
99 (Default)│ │ x │SLE11-WebYaST-SP1-Pool │https://nu.novell.com/repo/$RCE/SLE11│
99 (Default)│ │ x │SLE11-WebYaST-SP1-Updates │https://nu.novell.com/repo/$RCE/SLE11│
99 (Default)│ │ x │SLES11-Extras │https://nu.novell.com/repo/$RCE/SLES1│
99 (Default)│ x │ x │SLES11-SP1-Pool │https://nu.novell.com/repo/$RCE/SLES1│
99 (Default)│ x │ x │SLES11-SP1-Updates │https://nu.novell.com/repo/$RCE/SLES1│


Do you guys think they are the right ones?


Thanks for any suggestions.


David

malcolmlewis
03-Aug-2012, 17:50
I restarted the server, and run the commands suggested by Malcolmlewis.
But after execute "startx", still nothing showed up.

<snip>

I am wondering whether it is the reason that I have ever changed the
software updating repositories, which probably caused the updating was
not complete. But I do not know which repositories I should choose now.

Hi
I see the openSUSE ones are disabled, but with those priorities, lord
knows what it's pulled in when enabled. I would remove 1 & 2, disable 3
and 4, then run zypper dup to try and get back to a SLE 11 SP1 state.


--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 5 days 13:20, 4 users, load average: 0.27, 0.32, 0.28
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

davidehs
03-Aug-2012, 18:42
Hi malcolmlewis,

Do you mean I only need to enable "SLES11-SP1-Pool" and "SLES11-SP1-Updates", and prevent all the other repositories? Do I also need to enable "SLE11-SP1-Debuginfo-Pool", "SLE11-SP1-Debuginfo-Updates", "SLE11-WebYaST-SP1-Pool", "SLE11-WebYaST-SP1-Updates", and "SLES11-Extras"? They all have "SLE11" in their name and seem not to do harm to my system.

malcolmlewis
03-Aug-2012, 19:20
Hi malcolmlewis,

Do you mean I only need to enable "SLES11-SP1-Pool" and
"SLES11-SP1-Updates", and prevent all the other repositories? Do I also
need to enable "SLE11-SP1-Debuginfo-Pool",
"SLE11-SP1-Debuginfo-Updates", "SLE11-WebYaST-SP1-Pool",
"SLE11-WebYaST-SP1-Updates", and "SLES11-Extras"? They all have "SLE11"
in their name and seem not to do harm to my system.



Hi
Just disable the Debug ones as well, if your running web YaST then
leave enabled.

Can you also post the output from;


hwinfo --gfxcard


--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 5 days 14:51, 6 users, load average: 2.75, 1.82, 1.01
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

davidehs
06-Aug-2012, 17:07
I did all the updates. The x-windows still do not work. The screen is black. But the mouse seems to work now. I can see a mouse cursor and move it freely.

When viewing the ~/.xsession-errors, it show the same failure reason as before.

Here are the output of "hwinfo --gfxcard" command:

33: PCI 603.0: 0300 VGA compatible controller (VGA)
[Created at pci.323]
UDI: /org/freedesktop/Hal/devices/pci_102b_532
Unique ID: 7p19.GQCSMqQrnoB
Parent ID: 6NW+.two+GgbUMg7
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:06:03.0
SysFS BusID: 0000:06:03.0
Hardware Class: graphics card
Model: "Matrox G200 eW"
Vendor: pci 0x102b "Matrox Graphics, Inc."
Device: pci 0x0532 "G200 eW"
SubVendor: pci 0x1028 "Dell"
SubDevice: pci 0x029b
Revision: 0x0a Memory Range: 0xd5000000-0xd57fffff (rw,prefetchable)
Memory Range: 0xde7fc000-0xde7fffff (rw,non-prefetchable)
Memory Range: 0xde800000-0xdeffffff (rw,non-prefetchable)
Memory Range: 0xde000000-0xde00ffff (ro,prefetchable,disabled)
IRQ: 10 (no events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: "pci:v0000102Bd00000532sv00001028sd0000029Bbc03sc00 i00"
Driver Info #0:
XFree86 v4 Server Module: mga Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #25 (PCI bridge)

Primary display adapter: #33

malcolmlewis
06-Aug-2012, 17:30
I did all the updates. The x-windows still do not work. The screen is
black. But the mouse seems to work now. I can see a mouse cursor and
move it freely.

Model: "Matrox G200 eW"
Vendor: pci 0x102b "Matrox Graphics, Inc."
Device: pci 0x0532 "G200 eW"

Driver Info #0: XFree86 v4 Server Module: mga

Hi
OK that card uses the mga driver, so try this after logging out and
pressing alt+ctrl+F1 and logging in as root;


init 3
sax2 -r -m 0=mga
init 5 && exit


--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 8 days 13:00, 2 users, load average: 0.27, 0.41, 0.47
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

davidehs
06-Aug-2012, 18:09
It works now.

The error message said "/usr/lib/gnome-settings-daemon/gnome-settings-daemon: symbol lookup error: /usr/lib64/gio/modules/libdconfsettings.so: undefined symbol: g_settings_backend_get_type" in ~/.xsession-errors file. I googled "undefined symbol: g_settings_backend_get_type" and was redirected here "http://forums.opensuse.org/english/get-technical-help-here/applications/444302-vmware-undefined-symbol-suse-11-3-a.html". A solution was suggested to remove gsettings-backend-dconf package by "sudo rpm -ef gsettings-backend-dconf". I did not remove, just renamed the package from "libdconfsettings.so.changeName" to "libdconfsettings.so.changeName" at the directory /usr/lib64/gio/modules.

Then, I issued "startx" from terminal. The x-windows showed up. Everything works like a charm.

Thanks for you guys help,

David

malcolmlewis
06-Aug-2012, 18:32
It works now.

The error message said
"/usr/lib/gnome-settings-daemon/gnome-settings-daemon: symbol lookup
error: /usr/lib64/gio/modules/libdconfsettings.so: undefined symbol:
g_settings_backend_get_type" in ~/.xsession-errors file. I googled
"undefined symbol: g_settings_backend_get_type" and was redirected here
"http://forums.opensuse.org/english/get-technical-help-here/applications/444302-vmware-undefined-symbol-suse-11-3-a.html".
A solution was suggested to remove gsettings-backend-dconf package by
"sudo rpm -ef gsettings-backend-dconf". I did not remove, just renamed
the package from "libdconfsettings.so.changeName" to
"libdconfsettings.so.changeName" at the directory
/usr/lib64/gio/modules.

Then, I issued "startx" from terminal. The x-windows showed up.
Everything works like a charm.

Thanks for you guys help,

David



Hi
gsettings is in gnome3 not the default for SUSE 11? Are you running
openSUSE? Or did you add some additional stuff?

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 8 days 14:04, 2 users, load average: 0.42, 0.39, 0.37
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU