PDA

View Full Version : SLES 15 varnish-cache support



cisaksen
28-Jan-2019, 20:26
Is there any plans for SUSE to support varnish-cache https://varnish-cache.org/ with future release of SLES ?

I'm attempting to compile varnish-cache 6.1.1 from source, as there is no rpm available from varnish-cache.org.
So far I've run into 2 packages that are not available - python-docutils & python-sphinx

In varnish 5.x on SUSE 12 I was able to use the python-docsutils from opensuse and eventually it was available from 12sp3. In SUSE 15 SP0 it again is not available.
A new one: python-sphinx was not needed in varnish-cache 5.x but is now. It is available I think from packagehub but with a different name: python-sphinxcontrib-pecanwsme. I was going to try it until I tried to install it; Problem: nothing provides python2-Sphinx needed by python2-sphinxcontrib-httpdomain-1.5.0-bp150.2.4.noarch So it too is not available, python-sphinx.

After doing some research it appears that most of the other major distributions, RH, Ubuntu, centos all seem to have it. I was wondering why SUSE doesn't have them or are they working on it and just haven't released it yet for SLES 15?

For the time being I'll have to see if I can compile it on SLES 12SP4.

thanks

malcolmlewis
28-Jan-2019, 23:59
On Mon 28 Jan 2019 07:34:01 PM CST, cisaksen wrote:

Is there any plans for SUSE to support varnish-cache
https://varnish-cache.org/ with future release of SLES ?

I'm attempting to compile varnish-cache 6.1.1 from source, as there is
no rpm available from varnish-cache.org.
So far I've run into 2 packages that are not available -
python-docutils & python-sphinx

In varnish 5.x on SUSE 12 I was able to use the python-docsutils from
opensuse and eventually it was available from 12sp3. In SUSE 15 SP0 it
again is not available.
A new one: python-sphinx was not needed in varnish-cache 5.x but is now.
It is available I think from packagehub but with a different name:
python-sphinxcontrib-pecanwsme. I was going to try it until I tried to
install it; Problem: nothing provides python2-Sphinx needed by
python2-sphinxcontrib-httpdomain-1.5.0-bp150.2.4.noarch So it too is
not available, python-sphinx.

After doing some research it appears that most of the other major
distributions, RH, Ubuntu, centos all seem to have it. I was wondering
why SUSE doesn't have them or are they working on it and just haven't
released it yet for SLES 15?

For the time being I'll have to see if I can compile it on SLES 12SP4.

thanks




Hi
It is built in SLE 15 Backports? It's only version 5.1.2 though....
https://build.opensuse.org/package/show/openSUSE%3ABackports%3ASLE-15/varnish

https://download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15/standard/

Version 6.0.0 is in server:http (I can look at pushing an update to
6.0.2?)
https://build.opensuse.org/package/show/server%3Ahttp/varnish

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.25-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

cisaksen
30-Jan-2019, 16:38
Thanks you the response - but funny thing is I found the packages I needed but they are renamed for python3. python3-docutils & python3-sphinx are both available in SLES 15 and both are recognized but the varnish source code. I found them using the package search in SUMA. Strange that the package search web site didn't find them though. In any case I was able to compile varnish-cache 6.1.1 with these packages and it appears to be running as expected. Still early in the testing phase.

Thanks for your help.