PDA

View Full Version : SLES 12 SP4 Cannot download kernel-default-4.12.14-95.6.1.x86_64.rpm



jpn_lcc
12-Feb-2019, 06:52
Hi
I cannnot download latest errata kernel of SLES12SP4, kernel-default-4.12.14-95.6.1.x86_64.rpm.

When I click the "download" botton from following patch download page, the page displays error "We're sorry, we are unable to complete the download at this time".
https://download.suse.com/protected/Summary.jsp?buildid=5oHEBgPJalE~

When I tried same thing on January, I could download rpm file, but could not install it with following cpio error.
(I checked MD5 and sha256, and it's same value with origiral file, so I don't think downloaded rpm file is corrupted.)

# rpm -ivh kernel-default-4.12.14-95.6.1.x86_64.rpm
Preparing... ################################# [100%]
Updating / installing...
1:kernel-default-4.12.14-95.6.1 ################################# [100%]
error: unpacking of archive failed on file /lib/modules/4.12.14-95.6-default/kernel/sound/usb/snd-usb-audio.ko;5c50419e: cpio: read failed - No such file or directory
error: kernel-default-4.12.14-95.6.1.x86_64: install failed

Thanks

Franz Sirl
12-Feb-2019, 11:03
Hi,

I already installed the kernel version a few times without problems, but
I used zypper via our SMT server. For reference, here is the SHA256 again:

smt-scc:~ # sha256sum
/srv/www/htdocs/repo/SUSE/Updates/SLE-SERVER/12-SP4/x86_64/update/x86_64/kernel-default-4.12.14-95.6.1.x86_64.rpm
5d6e53aa7e2ca667534f1b51b8bc47b686e4d094205d634ca7 6780006b539450
/srv/www/htdocs/repo/SUSE/Updates/SLE-SERVER/12-SP4/x86_64/update/x86_64/kernel-default-4.12.14-95.6.1.x86_64.rpm

But maybe you are bitten by the annoying TTY bug in the previous
kernel-default-4.12.14-95.3.1 package. In that case try the install
(with rpm or zypper) again from a fresh login (and make sure your login
scripts don't start any background tasks). Because the TTY bug could
lead to extremely confusing behaviour on the command line when the shell
had any background tasks running.

Franz.

Am 2019-02-12 um 06:54 schrieb jpn lcc:
>
> Hi
> I cannnot download latest errata kernel of SLES12SP4,
> kernel-default-4.12.14-95.6.1.x86_64.rpm.
>
> When I click the "download" botton from following patch download page,
> the page displays error "We're sorry, we are unable to complete the
> download at this time".
> https://download.suse.com/protected/Summary.jsp?buildid=5oHEBgPJalE~
>
> When I tried same thing on January, I could download rpm file, but could
> not install it with following cpio error.
> (I checked MD5 and sha256, and it's same value with origiral file, so I
> don't think downloaded rpm file is corrupted.)
>
> # rpm -ivh kernel-default-4.12.14-95.6.1.x86_64.rpm
> Preparing... #################################
> [100%]
> Updating / installing...
> 1:kernel-default-4.12.14-95.6.1 #################################
> [100%]
> error: unpacking of archive failed on file
> /lib/modules/4.12.14-95.6-default/kernel/sound/usb/snd-usb-audio.ko;5c50419e:
> cpio: read failed - No such file or directory
> error: kernel-default-4.12.14-95.6.1.x86_64: install failed
>
> Thanks
>
>

malcolmlewis
14-Feb-2019, 14:31
On Tue 12 Feb 2019 05:54:01 AM CST, jpn lcc wrote:

Hi
I cannnot download latest errata kernel of SLES12SP4,
kernel-default-4.12.14-95.6.1.x86_64.rpm.

When I click the "download" botton from following patch download page,
the page displays error "We're sorry, we are unable to complete the
download at this time".
https://download.suse.com/protected/Summary.jsp?buildid=5oHEBgPJalE~

When I tried same thing on January, I could download rpm file, but could
not install it with following cpio error.
(I checked MD5 and sha256, and it's same value with origiral file, so I
don't think downloaded rpm file is corrupted.)

# rpm -ivh kernel-default-4.12.14-95.6.1.x86_64.rpm
Preparing... #################################
[100%]
Updating / installing...
1:kernel-default-4.12.14-95.6.1 #################################
[100%]
error: unpacking of archive failed on file
/lib/modules/4.12.14-95.6-default/kernel/sound/usb/snd-usb-audio.ko;5c50419e:
cpio: read failed - No such file or directory
error: kernel-default-4.12.14-95.6.1.x86_64: install failed

Thanks




Hi
It should be fixed now?

--
Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.28-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

jpn_lcc
15-Feb-2019, 03:19
Hi, thank you for your help, but still facing same error.

regards,

jpn_lcc
15-Feb-2019, 11:11
Thank you for your help.
Following your advice, I could download rpm file using zypper from official repository, and installed successfully
(sha256 of file was same as your value).
But rpm downoad site remains same error.

==
Downloads
We're sorry, we are unable to complete the download at this time.

The token you're using to access this download has expired. If any file is currently still in the process of being downloaded, please try again later. Otherwise, you can generate a new token by refreshing the download page for this build, then try the download again.

InvalidToken
==

regards,

jpn_lcc
01-Apr-2019, 05:16
Hi
Now I found that rpm file was replaced and the problem(cpio error) was fixed.

<MD5/SHA256 of old rpm>
#md5sum kernel-default-4.12.14-95.6.1.x86_64.rpm
6a0f642a4ec8b49d614fec6433e21805
# sha256sum kernel-default-4.12.14-95.6.1.x86_64.rpm
f31920f99db99018e23fd6807897566018a84ddc0437ff0fca 6df3f2aeee830c

<MD5/SHA256 of new rpm>
# md5sum kernel-default-4.12.14-95.6.1.x86_64.rpm
099ebd19b7170b1da6c323b2bbb6980d
# sha256sum kernel-default-4.12.14-95.6.1.x86_64.rpm
5d6e53aa7e2ca667534f1b51b8bc47b686e4d094205d634ca7 6780006b539450

Thany you all for your help!