PDA

View Full Version : SLED 15 Install AAC codec



kofabjzl
16-Feb-2019, 05:36
Hello everyone.

I'm installed SLED 15, but i need the AAC Codec to lisen my MKV videos.

¿Any have installed this code?

My system:

cat /etc/issue

Welcome to SUSE Linux Enterprise Desktop 15 (x86_64) - Kernel \r (\l).

eth0: \4{eth0} \6{eth0}

Linux linux-jp0s 4.12.14-25.28-default #1 SMP Wed Jan 16 20:00:47 UTC 2019 (dd6077c) x86_64 x86_64 x86_64 GNU/Linux

My repos:

El repositorio 'Basesystem-Module 15-0' está actualizado.
El repositorio 'Basesystem-Module 15-0' está actualizado.
El repositorio 'SLE-Module-Basesystem15-Pool' está actualizado.
El repositorio 'SLE-Module-Basesystem15-Updates' está actualizado.
El repositorio 'Containers-Module 15-0' está actualizado.
El repositorio 'Desktop-Applications-Module 15-0' está actualizado.
El repositorio 'Desktop-Applications-Module 15-0' está actualizado.
El repositorio 'SLE-Module-Desktop-Applications15-Pool' está actualizado.
El repositorio 'SLE-Module-Desktop-Applications15-Updates' está actualizado.
El repositorio 'SLE-Module-DevTools15-Pool' está actualizado.
El repositorio 'SLE-Module-DevTools15-Updates' está actualizado.
El repositorio 'DVD2' está actualizado.
El repositorio 'SLE-Module-CAP-Tools15-Pool' está actualizado.
El repositorio 'SLE-Module-CAP-Tools15-Updates' está actualizado.
El repositorio 'SLE-15-GA-Desktop-NVIDIA-Driver' está actualizado.
El repositorio 'SLE-Product-SLED15-Pool' está actualizado.
El repositorio 'SLE-Product-SLED15-Updates' está actualizado.
El repositorio 'SLE-15-GA-Desktop-NVIDIA-Driver' está actualizado.
El repositorio 'SLE-Product-WE15-Pool' está actualizado.
El repositorio 'SLE-Product-WE15-Updates' está actualizado.
El repositorio 'SLE-Module-Packagehub-Subpackages15-Pool' está actualizado.
El repositorio 'SLE-Module-Packagehub-Subpackages15-Updates' está actualizado.
El repositorio 'SUSE-PackageHub-15-Pool' está actualizado.
Recuperando los metadatos del repositorio 'SUSE-PackageHub-15-Standard-Pool' .................................................. ............[terminado]
Construyendo el caché del repositorio SUSE-PackageHub-15-Standard-Pool .................................................. ..................[terminado]
El repositorio 'Server-Applications-Module 15-0' está actualizado.
El repositorio 'Web-Scripting-Module 15-0' está actualizado.

malcolmlewis
17-Feb-2019, 16:13
Hi and welcome to the Forum :)
Those are probably part of patented codecs, so you can either look at getting the fluendo codec pack, or perhaps vist the third party repository called packman....

http://packman.links2linux.org/



zypper ar -f -g -n "SLE-15-Packman" http://packman.inode.at/suse/SLE_15/ SLE-15-Packman

zypper in ffmpeg lame gstreamer-plugins-libav gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon


None of these packages are supported, if you have issues, you need to follow up with the packman folks.

AndreasMeyer
17-Feb-2019, 23:47
The fluendo codec pack has included a legal AAC Audio decoder which works fine under SLED12 SP4:
https://forums.suse.com/showthread.php?10190-problem-with-playing-video-files&p=40787#post40787

https://fluendo.com/es/products/multimedia/oneplay-codec-pack/

kofabjzl
18-Feb-2019, 20:42
Hi and welcome to the Forum :)
Those are probably part of patented codecs, so you can either look at getting the fluendo codec pack, or perhaps vist the third party repository called packman....

http://packman.links2linux.org/



zypper ar -f -g -n "SLE-15-Packman" http://packman.inode.at/suse/SLE_15/ SLE-15-Packman

zypper in ffmpeg lame gstreamer-plugins-libav gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon


None of these packages are supported, if you have issues, you need to follow up with the packman folks.

Than's for help me!
But I tried your solution and have this messages:
Leyendo los paquetes instalados...
'gstreamer-plugins-bad' ya está instalado.
No hay ninguna actualización posible para 'gstreamer-plugins-bad-1.12.5-3.3.1.x86_64'. La última versión disponible ya está instalada.
'ffmpeg' ya está instalado.
Hay un candidato de actualización para 'ffmpeg', pero es de un proveedor diferente. Use 'zypper install ffmpeg-3.4.2-6.8.x86_64' para instalar este candidato.
'lame' ya está instalado.
No hay ninguna actualización posible para 'lame-3.100-1.33.x86_64'. La última versión disponible ya está instalada.
'gstreamer-plugins-libav' ya está instalado.
Hay un candidato de actualización para 'gstreamer-plugins-libav', pero es de un proveedor diferente. Use 'zypper install gstreamer-plugins-libav-1.12.5-3.3.x86_64' para instalar este candidato.
'gstreamer-plugins-ugly' ya está instalado.
No hay ninguna actualización posible para 'gstreamer-plugins-ugly-1.14.4-4.7.x86_64'. La última versión disponible ya está instalada.
'gstreamer-plugins-ugly-orig-addon' ya está instalado.
El paquete 'gstreamer-plugins-ugly-orig-addon' no está disponible en los repositorios. No es posible reinstalarlo, actualizarlo ni volver a una versión anterior.
Resolviendo dependencias de paquete...

Your opinion??

kofabjzl
18-Feb-2019, 22:21
Hello again.
Whit change of vendor fo ffmpeg, a have sound in my movies!!
Thanks a lot!!