PDA

View Full Version : SLES11sp2, where to get officially supported gnutls



heinkonijn
26-Jul-2012, 03:56
I am trying to patch my SLES11sp2 server to the latest and greatest (using ZLM).

But I ran into an issue, I can't upgrade the libsoup RPM's:

S | Catalog | Bundle | Name | Version | Arch
--+--------------------+---------------------------------------------------------------------+---------------------+---------------+-------
v | SLES11-SP2-Updates | patch-slessp2-libsoup_SLES11-SP2-Updates, SLES11-SP2-Updates-bundle | libsoup-2_4-1 | 2.32.2-4.11.1 | x86_64
v | SLES11-SP2-Updates | patch-slessp2-libsoup_SLES11-SP2-Updates, SLES11-SP2-Updates-bundle | libsoup-2_4-1-32bit | 2.32.2-4.11.1 | x86_64

server:/mnt/iso # rpm -qa|grep libsoup
libsoup-2_4-1-32bit-2.32.2-4.7.1
libsoup-2_4-1-2.32.2-4.7.1

The error in the zmd-messages log is:

26 Jul 2012 14:43:54 INFO Progress Progress.Stop Message: NOTHING_PROVIDES_DEP: gnutls(cert-auth) needed by libsoup-2_4-1-2.32.2-4.11.1.x86_64


But obviously I get the same error when I manually try to update the RPM's.
So the requirements for the latest RPM's changed, so I needs gnutls installed on the server.

Where do I get an offlicially supported version of the gnutls RPM's?
I found them for SLES11sp1 on the opensuse website, but these are not supported obviously.

Hein

enovaklbank
26-Jul-2012, 12:39
The dependency changed between 2.32.2-4.7.1 and 2.32.2-4.11.1 .

The diff is only one line:
gnutls(cert-auth)

# zypper lu
...
v | SLES11-SP1-Updates | libgnutls26 | 2.4.1-24.39.33.1 | 2.4.1-24.39.39.1 | x86_64
v | SLES11-SP1-Updates | libgnutls26-32bit | 2.4.1-24.39.33.1 | 2.4.1-24.39.39.1 | x86_64
v | SLES11-SP2-Updates | libsoup-2_4-1 | 2.32.2-4.7.1 | 2.32.2-4.11.1 | x86_64
v | SLES11-SP2-Updates | libsoup-2_4-1-32bit | 2.32.2-4.7.1 | 2.32.2-4.11.1 | x86_64
...

# zypper up libsoup-2_4-1

It updated two packages: libgnutls26 and libsoup-2_4-1 successfully.

So you simply have to install libgnutls26, which is officially supported.

asvetter
26-Jul-2012, 14:11
Nice workaround, using SP1-Updates for resolving SP2 problems.
Can somebody from SUSE please comment about the missing "provides" in libgnutls26 ?


The dependency changed between 2.32.2-4.7.1 and 2.32.2-4.11.1 .

The diff is only one line:
gnutls(cert-auth)

# zypper lu
...
v | SLES11-SP1-Updates | libgnutls26 | 2.4.1-24.39.33.1 | 2.4.1-24.39.39.1 | x86_64
v | SLES11-SP1-Updates | libgnutls26-32bit | 2.4.1-24.39.33.1 | 2.4.1-24.39.39.1 | x86_64
v | SLES11-SP2-Updates | libsoup-2_4-1 | 2.32.2-4.7.1 | 2.32.2-4.11.1 | x86_64
v | SLES11-SP2-Updates | libsoup-2_4-1-32bit | 2.32.2-4.7.1 | 2.32.2-4.11.1 | x86_64
...

# zypper up libsoup-2_4-1

It updated two packages: libgnutls26 and libsoup-2_4-1 successfully.

So you simply have to install libgnutls26, which is officially supported.

heinkonijn
26-Jul-2012, 22:49
The dependency changed between 2.32.2-4.7.1 and 2.32.2-4.11.1 .

The diff is only one line:
gnutls(cert-auth)

# zypper lu
...
v | SLES11-SP1-Updates | libgnutls26 | 2.4.1-24.39.33.1 | 2.4.1-24.39.39.1 | x86_64
v | SLES11-SP1-Updates | libgnutls26-32bit | 2.4.1-24.39.33.1 | 2.4.1-24.39.39.1 | x86_64
v | SLES11-SP2-Updates | libsoup-2_4-1 | 2.32.2-4.7.1 | 2.32.2-4.11.1 | x86_64
v | SLES11-SP2-Updates | libsoup-2_4-1-32bit | 2.32.2-4.7.1 | 2.32.2-4.11.1 | x86_64
...

# zypper up libsoup-2_4-1

It updated two packages: libgnutls26 and libsoup-2_4-1 successfully.

So you simply have to install libgnutls26, which is officially supported.

OK, thanks. I found the RPM's on the ZLM server and installed them.
So SuSe just forgot to include these in the SLES11sp2 repo, but not in the SLES11sp1 repo??

Is there an official place where to report this, or should I open a bug in bugzilla?

heinkonijn
27-Jul-2012, 00:12
Just saw this in another thread...
http://www.suse.com/support/kb/doc.php?id=7010225

That explains why it didn't work.

enovaklbank
27-Jul-2012, 08:12
Yup, that's the reason.