PDA

View Full Version : Configure Clock



scottjsn
26-Jul-2012, 16:02
Running SUSE 11. The click displays the military time, i.e., 0-24. How can I set it up to 1-12. For example, for 19:30, instead, displaying 7:30.

malcolmlewis
26-Jul-2012, 17:01
Running SUSE 11. The click displays the military time, i.e., 0-24.
How can I set it up to 1-12. For example, for 19:30, instead,
displaying 7:30.



Hi
Right click on the date/time visible in the panel, then select
preferences. Else you can configure via YaST -> System -> Date/Time.

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 4 days 14:00, 2 users, load average: 0.28, 0.22, 0.22
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

mikewillis
26-Jul-2012, 17:06
This is one of those options GNOME doesn't expose in the GUI you have to manually edit something in gconf. So run gconf-editor then find /apps/panel/applets/clock_screen0/prefs under there you should seen option called format. If you select it you'll see that gconf-editor lists the possible valid values in a section of the window labeled 'Key Documentation'. One of them is '12-hour' which is probably what you want. If you want to get adventurous you can set it to custom and then populate the custom_format value which will even take some style information. E.g. I have it set to this

%a %d %b, <span size='large'><b>%H:%M</b></span>
so the time appears larger than the date and also in bold. %a %d %b %H %M represent the usual values. (See 'man date' if you're not familiar with those. You'd probably want %I or %l instead of %H)


This answer is only valid if you're using GNOME for you're desktop environment. I've assumed you're using GNOME because that's the default in SLED. I also assume you're using SLED given you've posted in the SLED forum (not everyone who posts here is using SLED) 'SUSE 11' which could be interpreted as a variety of SUSE variants ;) )

mikewillis
26-Jul-2012, 17:09
I think we were typing at the same time but you typed less than I did so posted first :)


Right click on the date/time visible in the panel, then select preferences.

That was my first thought but I can't see anything there to change the format from 24 hour to 12. Maybe I'm looking at the wrong thing :/

scottjsn
26-Jul-2012, 18:35
Sorry for not clearly indicating my system. I am using SUSE Linux Enterprise Desktop (11) and KDE4.

malcolmlewis
26-Jul-2012, 18:43
I think we were typing at the same time but you typed less than I did so
posted first :)
malcolmlewis;5833 Wrote:
>
> Right click on the date/time visible in the panel, then select
> preferences.
>
That was my first thought but I can't see anything there to change the
format from 24 hour to 12. Maybe I'm looking at the wrong thing :/



Hi
A screenshot... ;)
http://www.imagebam.com/gallery/zdxl65c2cmkn8bogt11a4htktem4njdm/

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 4 days 15:43, 2 users, load average: 0.39, 0.28, 0.25
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

malcolmlewis
26-Jul-2012, 18:46
Sorry for not clearly indicating my system. I am using SUSE Linux
Enterprise Desktop (11) and KDE4.



Hi
Ahh, should be in the KDE control settings somewhere. Else try
configuring via YaST

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 4 days 15:45, 2 users, load average: 0.50, 0.33, 0.26
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

mikewillis
26-Jul-2012, 20:42
A screenshot... ;)
http://www.imagebam.com/gallery/zdxl65c2cmkn8bogt11a4htktem4njdm/

This is what I see
http://www.imagebam.com/image/f057d1203250175
That's a grab of an instance of SLED I have at home. I was at work when I posted earlier and what I saw there is consistent with what I see linked above. Curious.