PDA

View Full Version : SLES 12 SP4 Installing htop



AAEBHolding
02-Mar-2019, 16:42
Is there a repository for SLES 12.4 or do I have to install it from the source?

AAEBHolding
02-Mar-2019, 17:26
OK, this I could solve fast. Run this:


zypper ar https://download.opensuse.org/repositories/server:/monitoring/SLE_12_SP4/server:monitoring.repo

malcolmlewis
02-Mar-2019, 17:37
OK, this I could solve fast. Run this:


zypper ar https://download.opensuse.org/repositories/server:/monitoring/SLE_12_SP4/server:monitoring.repo
Hi
Better to use SUSE Package Hub, then your system is still supported with this version of htop.... ;)
https://packagehub.suse.com/packages/htop/

AAEBHolding
02-Mar-2019, 23:00
Hi
Better to use SUSE Package Hub, then your system is still supported with this version of htop.... ;)
https://packagehub.suse.com/packages/htop/

Please, can you brief describe why using zypper isn't the best way? I don't understand your note. I am using zypper for MySQL and this works perfectly - each time a new version is available I update MySQL running zypper update.

malcolmlewis
02-Mar-2019, 23:56
Please, can you brief describe why using zypper isn't the best way? I don't understand your note. I am using zypper for MySQL and this works perfectly - each time a new version is available I update MySQL running zypper update.
Hi
Not about using zypper, anything from the openSUSE Build Service is technically unsupported, so if you raise a Service Request for a bug report etc it may declined, if you use packages from SUSE Package Hub, your system will still be supported. See https://packagehub.suse.com/#features

If the package your after is not on Package Hub, you can always ask the maintainers to push the package to Package Hub so you can then have a supported system :)